Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » how to install papyrus 2.0.1 on neon(how to install papyrus 2.0.1 modelling plug-in for neon)
icon13.gif  how to install papyrus 2.0.1 on neon [message #1746795] Fri, 04 November 2016 16:09 Go to next message
Iaroslaw KARDASH is currently offline Iaroslaw KARDASHFriend
Messages: 10
Registered: October 2016
Junior Member
Dear Sirs,

Could you give me a hand on installing papysus 2 0.1 Modolling Developing plug in for Eclipse neon.

I'd looked for set-up documentation, but did not find.

Thank you for your help.
Re: how to install papyrus 2.0.1 on neon [message #1746806 is a reply to message #1746795] Fri, 04 November 2016 19:10 Go to previous messageGo to next message
Charles Rivet is currently offline Charles RivetFriend
Messages: 219
Registered: May 2014
Location: Canada
Senior Member

Iaroslaw,

To install Papyrus, all you need to do is download the file for your operating system from Papyrus Downloads, extract to a proper location for your platform, and then run it.


/Charles Rivet
icon7.gif  how to install papyrus 2.0.1 on neon [message #1746833 is a reply to message #1746806] Sat, 05 November 2016 10:57 Go to previous messageGo to next message
Iaroslaw KARDASH is currently offline Iaroslaw KARDASHFriend
Messages: 10
Registered: October 2016
Junior Member

Dear Charles Rivet,
Please, tell me what is appropriate catalog for installing Papyrus? Is it Neon directory?

And what I need is to unzip Papyrus zip folder, and launch eclipse application? Am I right?

Thank you for helping hand.
Re: how to install papyrus 2.0.1 on neon [message #1746923 is a reply to message #1746833] Mon, 07 November 2016 17:41 Go to previous messageGo to next message
Charles Rivet is currently offline Charles RivetFriend
Messages: 219
Registered: May 2014
Location: Canada
Senior Member

Iaroslaw,

If you are not installing in an existing Eclipse shell, then your best approach is what I stated before, so yes, just unzip the file downloaded from the link I provided and then execute it.

If you are installing in an existing Eclipse shell, you can go "Help -> Install new software"


  1. Help -> Install new software
  2. In the "Work with" section of "Available Software", select the release of interest (e.g., Neon)
  3. In the type filter, type "Papyrus"
  4. Select "Papyrus UML" and, optionally, the model comparison feature.
  5. Select [Next]
  6. Select [Next] again to the details
  7. Accept the licenses and click [Finish].
  8. Enjoy modeling!


I hope this helps.


/Charles Rivet
Re: how to install papyrus 2.0.1 on neon [message #1747229 is a reply to message #1746923] Fri, 11 November 2016 03:58 Go to previous messageGo to next message
Iaroslaw KARDASH is currently offline Iaroslaw KARDASHFriend
Messages: 10
Registered: October 2016
Junior Member
Dear Charles Rivet,

Thank you for your help.
I followed your instructions and now I've got it.

Best regards,
Iaroslaw Smile
Re: how to install papyrus 2.0.1 on neon [message #1747230 is a reply to message #1746923] Fri, 11 November 2016 03:58 Go to previous message
Iaroslaw KARDASH is currently offline Iaroslaw KARDASHFriend
Messages: 10
Registered: October 2016
Junior Member
Dear Charles Rivet,

Thank you for your help.
I followed your instructions and now I've got it.

Best regards,
Iaroslaw Smile
Previous Topic:Programmatically create a diagram of custom diagram kind
Next Topic:getAfterCreateRelationshipCommand() not called on my SpecializationType
Goto Forum:
  


Current Time: Sun Jan 26 03:27:35 GMT 2020

Powered by FUDForum. Page generated in 0.02203 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top