Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EMF Forms] What happened to the JavaFX renderer between version 1.7.2 and 1.8.0?(What happened to the JavaFX renderer between version 1.7.2 and 1.8.0?)
icon5.gif  [EMF Forms] What happened to the JavaFX renderer between version 1.7.2 and 1.8.0? [message #1746295] Wed, 26 October 2016 14:43 Go to next message
Uwe Sander is currently offline Uwe SanderFriend
Messages: 2
Registered: October 2016
Junior Member
Hi,

I noticed there is no JavaFX renderer in the EMF Forms target platform for version 1.8 or higher. The FX bundles can be still found in the Git repo and the EMF Forms website mentions JavaFX as a supported UI toolkit so I'm wondering why it was dropped from the target platform after version 1.7.2? I could not find any related announcement.

Thanks,
Uwe

[Updated on: Thu, 27 October 2016 07:44]

Report message to a moderator

Re: [EMF Forms] What happened to the JavaFX renderer between version 1.7.2 and 1.8.0? [message #1746342 is a reply to message #1746295] Thu, 27 October 2016 09:05 Go to previous messageGo to next message
Eugen Neufeld is currently offline Eugen NeufeldFriend
Messages: 129
Registered: May 2015
Senior Member
Hi Uwe,
We removed the bundles from the release, as we don't have the capacity to keep them up-to-date. Tom Schindl is very actively developing the integration of JavaFX with Eclipse and this results in changes. Also we are doing some refactoring in emfforms in order to prepare the 2.0.0 release.
Furthermore we never got any feedback on or saw any interest in the JavaFX renderer.

We are happy to accept contributions or get sponsored development on this. Because of this lack of interest (as far as we could see it) we silently dropped the bundles from the release.

Cheers,
Eugen


--
Eugen Neufeld

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: [EMF Forms] What happened to the JavaFX renderer between version 1.7.2 and 1.8.0? [message #1746345 is a reply to message #1746342] Thu, 27 October 2016 10:07 Go to previous messageGo to next message
Uwe Sander is currently offline Uwe SanderFriend
Messages: 2
Registered: October 2016
Junior Member
Hi Eugen,

thanks for the update. I can see why you decided to stop investing resources into the further development of the JavaFX renderer.
It might be worthwhile to update the documentation on the EMF Forms website as the chapter "Using the JavaFX Renderer" suggests (to new users at least) one could use this feature with the latest version of EMF Forms.

Thanks,
Uwe
Re: [EMF Forms] What happened to the JavaFX renderer between version 1.7.2 and 1.8.0? [message #1746399 is a reply to message #1746345] Fri, 28 October 2016 07:28 Go to previous message
Eugen Neufeld is currently offline Eugen NeufeldFriend
Messages: 129
Registered: May 2015
Senior Member
Hi Uwe,
good point. We will do this asap.

Thank you.
Cheers,
Eugen


--
Eugen Neufeld

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Previous Topic:[TEXO][ACCELEO] Web-form Vaadin editor for Texo JPA classes
Next Topic:[EMF Forms] How to select specific view model for view
Goto Forum:
  


Current Time: Tue Jan 16 23:43:54 GMT 2018

Powered by FUDForum. Page generated in 0.01995 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software