Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » [NEON] Error deploying a helloworld app(simple deploy, dificult error right now)
[NEON] Error deploying a helloworld app [message #1746125] Sat, 22 October 2016 16:38 Go to next message
Santo Mota is currently offline Santo MotaFriend
Messages: 62
Registered: July 2013
Member
Hi expert, now I'm focused on scout and all my time is in order to learn too much about it.
So, I'm trying to deploy an helloworld simple aplication but I'm facing problem.
This is the error triggered.

I'm checking the pom file inside the helloworld.ui.html and I can't see any problem.
Can you put me in a right way to solve this issue?
thank you so much.

this happend when I run the maven project using deploy parameter.

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.8.2:deploy (default-deploy) on project helloworld.ui.html.app.war: Failed to deploy artifacts: Could not find artifact xgc.commons.apps.example:helloworld:pom:1.0.0-20161022.162229-1 in repo.eclipse.org (https://repo.eclipse.org/content/repositories/scout-snapshots/) -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.8.2:deploy (default-deploy) on project helloworld.ui.html.app.war: Failed to deploy artifacts: Could not find artifact xgc.commons.apps.example:helloworld:pom:1.0.0-20161022.162229-1 in repo.eclipse.org (https://repo.eclipse.org/content/repositories/scout-snapshots/)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)

[Updated on: Sat, 22 October 2016 17:30]

Report message to a moderator

Re: [NEON] Error deploying a helloworld app [message #1746136 is a reply to message #1746125] Sun, 23 October 2016 07:29 Go to previous message
Santo Mota is currently offline Santo MotaFriend
Messages: 62
Registered: July 2013
Member
ok, I'm going to assume that it was a command issue.
If I use INSTALL command, OR CLEAN VERIFY the result is right.
I'm able to reproduce the error just if I use DEPLOY command.
Previous Topic:OLD and dificul FORUM
Next Topic:deploy app with tomcat, server error
Goto Forum:
  


Current Time: Wed Sep 20 04:06:21 GMT 2017

Powered by FUDForum. Page generated in 0.14163 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software