Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Migration to new "execute external command" step
Migration to new "execute external command" step [message #1743852] Tue, 20 September 2016 09:09 Go to next message
Dominik Gabriel is currently offline Dominik GabrielFriend
Messages: 113
Registered: June 2013
Senior Member
hi there,

i tried to get rid of my execute external command steps (the old ones) and replace them withe the new ones but i didn't get how i have to set the parameters in the new step to get it running....

maybe you can give an example how a step and it parameters looked in the old version and how in will look like in the new version of the step.

here is a screenshot of the old version step in my case:
index.php/fa/27132/0/

how would this case look in the new version?

best regards
dominik
Re: Migration to new "execute external command" step [message #1743903 is a reply to message #1743852] Tue, 20 September 2016 13:53 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member
Hi Dominik,

I've forwarded this onto one of the team to take a look at, but in the meantime - did you check out the documentation already?
http://testing.bredex.de/files/content/software/documentation/reference/actions/usableOnMostApps/thatExecuteBehavior/executeExternalCommandOperatingSystem/actionExecuteExternalCommandOperatingSystem.html

(Apologies if you did Smile )

Best regards,
Alex
Re: Migration to new "execute external command" step [message #1743958 is a reply to message #1743903] Wed, 21 September 2016 07:21 Go to previous messageGo to next message
Dominik Gabriel is currently offline Dominik GabrielFriend
Messages: 113
Registered: June 2013
Senior Member
hi Alex,

thanks for your answer. yes i did but it seems that theres an issue in the documentation cause this site (http://testing.bredex.de/files/content/software/documentation/reference/parameters/arguments.html) is exactly the same as this (http://testing.bredex.de/files/content/software/documentation/reference/parameters/executable.html)

Best Regards
Dominik

[Updated on: Wed, 21 September 2016 07:22]

Report message to a moderator

Re: Migration to new "execute external command" step [message #1744084 is a reply to message #1743958] Thu, 22 September 2016 09:29 Go to previous messageGo to next message
Kevin Barbe is currently offline Kevin BarbeFriend
Messages: 64
Registered: July 2016
Member
Hi Dominik,

in the new version of Execute External Command you would simply have to split the arguments from the name of the executable. So for example on the old version you would have entered as a command: "cmd /C echo "Hello World!" whereas in the new version you have to enter the following parameters:

Executable: cmd
Arguments: /C echo "Hello World!"

Best regards,
Kevin
Re: Migration to new "execute external command" step [message #1744093 is a reply to message #1744084] Thu, 22 September 2016 10:11 Go to previous messageGo to next message
Dominik Gabriel is currently offline Dominik GabrielFriend
Messages: 113
Registered: June 2013
Senior Member
hi Kevin,

i tried to do that but i couldn't get it run. Maybe you can help me...

my old step (works):
index.php/fa/27165/0/

my new step (not working):
index.php/fa/27166/0/

result:
index.php/fa/27167/0/


i couldn't figure out what the problem is...

best regards
Dominik
Re: Migration to new "execute external command" step [message #1744108 is a reply to message #1744093] Thu, 22 September 2016 11:29 Go to previous messageGo to next message
Kevin Barbe is currently offline Kevin BarbeFriend
Messages: 64
Registered: July 2016
Member
Hi Dominik,

there might currently be a bug when using directories with back slashes (e.g. in Windows) as an argument for the Directory parameter. Could you please try using the following as directory: "C:\\Windows\\System32\\" and if that is not working please try it without \\ at the end.

Best regards,
Kevin

EDIT: This actually is not a bug but all parameters with back slashes require escaped back slashes "\\". This information is missing in the documentation of Execute External Command and will be added.

[Updated on: Fri, 23 September 2016 06:54]

Report message to a moderator

Re: Migration to new "execute external command" step [message #1744135 is a reply to message #1744093] Thu, 22 September 2016 15:06 Go to previous messageGo to next message
Achim Loerke is currently offline Achim LoerkeFriend
Messages: 376
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

You are actually using a command line like cmd.exe /c cmd /c <rest of your command. I am quite sure that this cannot work on Windows (cannot check because I have no Windows system nearby).

HTH

Achim
Re: Migration to new "execute external command" step [message #1744337 is a reply to message #1744135] Mon, 26 September 2016 06:02 Go to previous messageGo to next message
Dominik Gabriel is currently offline Dominik GabrielFriend
Messages: 113
Registered: June 2013
Senior Member
Hi there,

i tried your suggestions Kevin but no version i tried was working.... you can have a look at it here:
index.php/fa/27208/0/

Achim i can assure you that it is working on windows you can see a screenshot here:
index.php/fa/27209/0/

any other idea what i can try?

best regards
Dominik

ps i tried it also without the double quotes (") and the \\ instead of \

[Updated on: Mon, 26 September 2016 06:08]

Report message to a moderator

Re: Migration to new "execute external command" step [message #1744447 is a reply to message #1743852] Tue, 27 September 2016 07:23 Go to previous messageGo to next message
Kevin Barbe is currently offline Kevin BarbeFriend
Messages: 64
Registered: July 2016
Member
It looks like you entered the path with quotation marks and this might cause the problem.

I just tried the following configuration:
index.php/fa/27218/0/

and this is the test result:
index.php/fa/27217/0/

So that works perfectly fine for me. One other thing you can try is to run Jubula as Administrator. Maybe Jubula does not have the permission to access some of the files.

If that is not working, please upload the Jubula log files in a zip. You can find them by default at %USERPROFILE%/.jubula/logs.
Re: Migration to new "execute external command" step [message #1744467 is a reply to message #1744447] Tue, 27 September 2016 10:41 Go to previous messageGo to next message
Dominik Gabriel is currently offline Dominik GabrielFriend
Messages: 113
Registered: June 2013
Senior Member
thanks for your help, Kevin. i tried your configuration and it's working now. the problem was the environment....

if i try to run the same configuration in environment of AUT its not working. with ITE its working...

thanks for your help
Re: Migration to new "execute external command" step [message #1744601 is a reply to message #1744467] Wed, 28 September 2016 19:05 Go to previous message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member
Excellent news, thanks for the update Smile
Previous Topic:testexec on Linux: NullpointerExecption while starting AUT
Next Topic:Loop and event handler
Goto Forum:
  


Current Time: Fri Sep 21 11:49:23 GMT 2018

Powered by FUDForum. Page generated in 0.02294 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top