Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Can't disable oomph completely
Can't disable oomph completely [message #1743127] Mon, 12 September 2016 12:42 Go to next message
Sergei Karimov is currently offline Sergei KarimovFriend
Messages: 14
Registered: July 2009
Junior Member
Hello All!
Every time eclipse starts it spams warnings in error log, saying "Forbidden ..."
I discovered that it's new feature oomph to blame. When I did some research I discovered many things I don't like about this new feature:
1. You can't disable it completely. Every time you start IDE something happens in background
2. It's doing internet requests even if I didn't ask it to
3. Something is wrong with installation package or external servers that every startup 3 Forbidden warnings written to error log without specifying which server returns http 503
4. It creates system global folders user/.p2 and user/.eclipse. This is very bad because now you can't keep different eclipse versions on same machine, which is very important when you have many projects, each with it's own environment

You are trying to create feature that will allow to share settings between workspaces, I get it. But why it's so buggy and unstable? If you know it's buggy (you should've), why you didn't allow to switch it off completely, or add more configuration options or at least add some more?

I usually track eclipse error log very carefully because errors predict something will go wrong soon. And I'm very disappointed to see error logs every startup on empty workspace with 0 projects.
I tried to revert to previous release and apparently MARS is also infected with this buggy oomph, I have to revert even further to luna sr2

[Updated on: Mon, 12 September 2016 12:45]

Report message to a moderator

Re: Can't disable oomph completely [message #1743131 is a reply to message #1743127] Mon, 12 September 2016 13:44 Go to previous messageGo to next message
Abel Hegedus is currently offline Abel HegedusFriend
Messages: 189
Registered: September 2015
Senior Member
First of all, I understand your frustration that Eclipse as an IDE is not working as well in Neon for you as it did before.

Quote:

1. You can't disable it completely. Every time you start IDE something happens in background

In Preferences, there is Oomph -> Setup Tasks -> Skip automatic task execution at startup time.

Quote:

2. It's doing internet requests even if I didn't ask it to

I'm not sure if this happens even if you disable it as written above.

Quote:

3. Something is wrong with installation package or external servers that every startup 3 Forbidden warnings written to error log without specifying which server returns http 503

Since you say you don't see what server returns http 503, I can't really help. Are you behind a firewall that blocks all unknown requests? It seems that you are not using Oomph to setup projects, so I guess it is not related to faulty setup models.

Quote:

4. It creates system global folders user/.p2 and user/.eclipse. This is very bad because now you can't keep different eclipse versions on same machine, which is very important when you have many projects, each with it's own environment


Those folders are there, because they are common to all Eclipse installations and contain information that is reused. You can have different Eclipse versions and as many installations as you want just as before. Even better, you can have a common bundle pool so that a given version of each plugin is only stored once, even if it is used by multiple installations. This can reduce the disk usage of Eclipse installations by a lot (the more you have, the more space you save).

Quote:

You are trying to create feature that will allow to share settings between workspaces, I get it. But why it's so buggy and unstable? If you know it's buggy (you should've), why you didn't allow to switch it off completely, or add more configuration options or at least add some more?

Since Neon, EPP packages allow uninstalling individual features, so you can try to uninstall Oomph from Help -> Installation details. Note that a lot of people are using Oomph without having all sorts of problems (since it is bundled in all Eclipse packages since Mars).

Quote:

I usually track eclipse error log very carefully because errors predict something will go wrong soon. And I'm very disappointed to see error logs every startup on empty workspace with 0 projects.

It would help if you would copy-paste your error log entry details so someone might tell you why it occurs.

Quote:

I tried to revert to previous release and apparently MARS is also infected with this buggy oomph, I have to revert even further to luna sr2


Yes, Eclipse has chosen to include Oomph in Mars by default and since the feedback was not negative overall, they haven't gone back on this decision for Neon.
Re: Can't disable oomph completely [message #1743139 is a reply to message #1743131] Mon, 12 September 2016 14:46 Go to previous messageGo to next message
Sergei Karimov is currently offline Sergei KarimovFriend
Messages: 14
Registered: July 2009
Junior Member
Quote:
In Preferences, there is Oomph -> Setup Tasks -> Skip automatic task execution at startup time.

yes, I did that. Didn't help. It just prevents jobs from running at startup. They run sometime later anyway

Quote:
Are you behind a firewall that blocks all unknown requests?

No, I don't have any firewalls, I'm on retail ISP directly and even if it would block some urls, then it would respond with human readable info message and http 200, not http 503

Quote:
lot of people are using Oomph without having all sorts of problems

Lots of ppl just don't know how to show "error log" panel, so it doesn't say anything. I bet they all have such warnings.
You may try it yourself. Just create new clean workspace and check eclipse error log, you would see those warnings too.

Quote:
You can have different Eclipse versions and as many installations as you want just as before. Even better, you can have a common bundle pool so that a given version of each plugin is only stored once, even if it is used by multiple installations

That works nice in theory. But then one eclipse version erases some flag because of bug/feature, another eclipse version tries to find such flag and fails with exception, etc. Eclipse was never 100% free of bugs and it's generally a bad idea when several eclipse versions (with different set of features/bugs) works with same repository. I never opened (and had problems with it) a workspace in an eclipse with different version/set of features, although I bet all eclipse developers would say it's safe.

I take all warnings and errors in eclipse error log seriously becase there were many cases when strange problems occur leading to total recreation of a workspace after some bugs occur in eclipse. And usually those bugs trace in error log. Error log helps to discover workarounds and keep your environment stable.
So please don't suggest just to ignore those warnings. I better revert to luna then have any warnings in my error log.
Re: Can't disable oomph completely [message #1743142 is a reply to message #1743139] Mon, 12 September 2016 15:21 Go to previous messageGo to next message
Abel Hegedus is currently offline Abel HegedusFriend
Messages: 189
Registered: September 2015
Senior Member
Quote:
They run sometime later anyway

If they are Oomph setup tasks, they will only run if you trigger them manually (if you have disabled startup execution).

Quote:
You may try it yourself. Just create new clean workspace and check eclipse error log, you would see those warnings too.

I just unpacked an Eclipse for DSL developers Neon package (eclipse-dsl-neon-R-win32-x86_64.zip) and started it. After startup the only entry in the Error Log is the "Warning: The environment variable HOME is not set." from EGit. Once again, you could copy the Error log entries to give us some details.

Quote:

it's generally a bad idea when several eclipse versions (with different set of features/bugs) works with same repository.

The bundle pool is a collection of bundles, it is not the same as a single installation of Eclipse. There is a clear separation between bundles and p2 profiles that explicitly describe the precise version of all bundles to be used for a single installation.

Still, zipped Eclipse packages will not use it by default and you can disable using the bundle pool in the Eclipse Installer as well.

Quote:
I never opened (and had problems with it) a workspace in an eclipse with different version/set of features, although I bet all eclipse developers would say it's safe.

Generally, you can open a workspace created with a previous version of Eclipse, but it will warn you before opening that doing so will update the workspace and it may not work anymore in the older version.

Quote:

So please don't suggest just to ignore those warnings.

I did not say to ignore the warnings. I understand that for you it is important to avoid errors in the log and to be able to decide why they occur.

Again, without further details I'm afraid I cannot help you.
Maybe Ed or Eike will pipe in.

Best regrads
Re: Can't disable oomph completely [message #1743152 is a reply to message #1743142] Mon, 12 September 2016 16:13 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29483
Registered: July 2009
Senior Member
Abel, thanks for helping answer the questions. Certainly a stack trace would help. We're using ECF and it creates the exception. But perhaps we can wrap it to provide more information than ECF is associating with the exception. Probably the code is trying to load the setups.zip, and I think a 503 (service unavailable) might just mean eclipse.org is overloaded and it's a transient problem. But there was mention of "forbidden" but that's a 403 so it's not so clear what exactly is failing. We could just log no warning at all, but we expect a 503 to be a transient problem; networks and servers can and sometimes do fail...
Re: Can't disable oomph completely [message #1743156 is a reply to message #1743152] Mon, 12 September 2016 18:05 Go to previous messageGo to next message
Sergei Karimov is currently offline Sergei KarimovFriend
Messages: 14
Registered: July 2009
Junior Member
dowloaded eclipse neon jee package
started with java 1.8, specified default workspace path (which does not exist), activated error log view, closed eclipse
1.log - initial boot result. several forbidden exceptions

switched on checkboxes: "use offline cache", "skip automatic task execution..."
2.log - second boot with checkboxes, also several forbidden exceptions that occur during "Initialize setup models".
Same number of exceptions occur on any subsequent boot. So it's not an intermediate error. seems that server returning 403 (yes, it was 403, not 503) for every response.

another test: I disabled my network card, so no internet at all.
3.log - no internet. several exceptions with slightly different text
  • Attachment: 1.log
    (Size: 11.79KB, Downloaded 52 times)
  • Attachment: 2.log
    (Size: 10.52KB, Downloaded 41 times)
  • Attachment: 3.log
    (Size: 10.12KB, Downloaded 47 times)
Re: Can't disable oomph completely [message #1743158 is a reply to message #1743152] Mon, 12 September 2016 18:11 Go to previous messageGo to next message
Sergei Karimov is currently offline Sergei KarimovFriend
Messages: 14
Registered: July 2009
Junior Member
Yes, that would be nice if exception text includes some meaningfull text what to do with it (try later, change config, ignore, etc)
And most usefull would be some checkbox that disables oomph completely.
Re: Can't disable oomph completely [message #1743162 is a reply to message #1743158] Mon, 12 September 2016 19:17 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29483
Registered: July 2009
Senior Member
Why doesn't this message bother you?

!ENTRY org.eclipse.egit.ui 2 0 2016-09-12 22:06:39.268
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: 'C:\Users\Sergey'. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

It comes up each time too and you've neither set the preference nor set the environment variable. Why aren't you upset about it?

Are you able to download the setup.zip link I had in my post? That's what's failing in this case. Someone else complained about the same problem, but the cause isn't clear. Normally this works, and it isn't downloaded again until there is a new version of it...
Re: Can't disable oomph completely [message #1743195 is a reply to message #1743162] Tue, 13 September 2016 08:55 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29483
Registered: July 2009
Senior Member
I've committed changes to ensure that the exception includes the URL being accessed.
Re: Can't disable oomph completely [message #1743230 is a reply to message #1743162] Tue, 13 September 2016 13:10 Go to previous messageGo to next message
Sergei Karimov is currently offline Sergei KarimovFriend
Messages: 14
Registered: July 2009
Junior Member
Ed Merks wrote on Mon, 12 September 2016 15:17
Why doesn't this message bother you?
...
It comes up each time too and you've neither set the preference nor set the environment variable. Why aren't you upset about it?

Because there is a way to disable it via settings
I always switch it off, this time I left everything by default just for demo
Re: Can't disable oomph completely [message #1743231 is a reply to message #1743162] Tue, 13 September 2016 13:13 Go to previous messageGo to next message
Sergei Karimov is currently offline Sergei KarimovFriend
Messages: 14
Registered: July 2009
Junior Member
Ed Merks wrote on Mon, 12 September 2016 15:17

Are you able to download the setup.zip link I had in my post? That's what's failing in this case.

I'm able to download it via browser. Not sure how can I check if its downloadable via eclipse though. I don't have any proxy, just straight connection pc-router-isp.

[Updated on: Tue, 13 September 2016 13:14]

Report message to a moderator

Re: Can't disable oomph completely [message #1743232 is a reply to message #1743195] Tue, 13 September 2016 13:17 Go to previous messageGo to next message
Sergei Karimov is currently offline Sergei KarimovFriend
Messages: 14
Registered: July 2009
Junior Member
Ed Merks wrote on Tue, 13 September 2016 04:55
I've committed changes to ensure that the exception includes the URL being accessed.

Ok, I'll wait for nightly (or something like that) and try to test it
Re: Can't disable oomph completely [message #1743236 is a reply to message #1743232] Tue, 13 September 2016 13:50 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29483
Registered: July 2009
Senior Member
Is it possible that your firewall has blocked Eclipse's access to the internet? Does the Internal Web Browser view work? Can it download the zip file? Does Help -> Check for Updates result in errors in the log or some other type of failure?
Re: Can't disable oomph completely [message #1743253 is a reply to message #1743236] Tue, 13 September 2016 15:24 Go to previous messageGo to next message
Sergei Karimov is currently offline Sergei KarimovFriend
Messages: 14
Registered: July 2009
Junior Member
I compared requests using fiddler and made a test program to demonstrate the issue. It seems www.eclipse.org doesn't like User-Agent: Apache-HttpClient/4.3.6 (java 1.5)
package delme;

import java.net.HttpURLConnection;
import java.net.URL;

public class Main {
public static void main(String[] args) throws Exception {
final URL url = new URL("http://www.eclipse.org/setups/setups.zip");
final HttpURLConnection con = (HttpURLConnection) url.openConnection();
//this header value is sent from eclipse and 403 received
con.setRequestProperty("User-Agent", "Apache-HttpClient/4.3.6 (java 1.5)");
//this header value is sent from browser and 200 received
// con.setRequestProperty("User-Agent", "Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko");
con.connect();
final int responseCode = con.getResponseCode();
System.out.println("responseCode=" + responseCode);
}
}
Re: Can't disable oomph completely [message #1743255 is a reply to message #1743253] Tue, 13 September 2016 15:25 Go to previous message
Sergei Karimov is currently offline Sergei KarimovFriend
Messages: 14
Registered: July 2009
Junior Member
But still my main idea was some checkbox that disables oomh completely...
Previous Topic:Unable to Preference Synchronizer due to invalid password
Next Topic:Enter Projects Page from Eclipse will cause the program gets stuck
Goto Forum:
  


Current Time: Sun Aug 19 13:52:47 GMT 2018

Powered by FUDForum. Page generated in 0.02460 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top