Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » [neon] Login page fails to show for french
[neon] Login page fails to show for french [message #1741731] Mon, 29 August 2016 06:35 Go to next message
Urs Beeli is currently offline Urs BeeliFriend
Messages: 562
Registered: October 2012
Location: Bern, Switzerland
Senior Member
We've encountered a problem with NLS support in Scout Neon.

Our login.html File looks as follows:
<!DOCTYPE html>
<html>
  <head>
    <meta charset="UTF-8">
    <title>CISI Angebot</title>
    <scout:include template="head.html" />
    <scout:stylesheet src="res/scout-login-module.css" />
    <scout:script src="res/jquery-all-macro.js" />
    <scout:script src="res/cisi-login-module.js" />
    <script>
      $(document).ready(function() {
        scout.login.init({texts: <scout:message style="javascript" key="ui.Login" key="ui.LoginFailed" key="ui.User" key="ui.Password" /> });
      });
    </script>
  </head>
  <body>
    <scout:include template="no-script.html" />
    <!-- 
    <p>This is plain text</p>
    <p>Generated text: <scout:message key="ui.BrowserTooOld" /></p>
     -->
  </body>
</html>


While using German or English as languages, it worked perfectly.

After switching browser language to French, all we get is a blank page. The firebug console shows the following error:
Quote:
SyntaxError: missing } after property list
...ailed': 'Echec de l'identification', 'ui.User': 'Utilisateur', 'ui.Password': '


And looking at the HTML source I see the following (excerpt only):
<script>
      $(document).ready(function() {
        scout.login.init({texts: {'ui.Login': 'Identification', 'ui.LoginFailed': 'Echec de l'identification', 'ui.User': 'Utilisateur', 'ui.Password': 'Mot de passe'} });
      });
    </script>


I assume that the problem is the apostrophe in "Echec de l'identification" which prematurely terminates the string. If I'm not mistaken, this text is one provided by the scout runtime, as is the login.html file.

So I am wondering, has anyone else seen this issue and if so, how did you solve it? I would assume that the BSI CRM application which runs under Scout Neon is also used in French, do you not see this issue? Can we do something to escape such characters?

On a related note: Even though I have switched my browser language back to English or German (and have totally remove french from it), I still get the broken, french login page, even when using a different browser, and other users have the same problem. Is the language somehow stored somewhere on the server side? Restarting it did not help. How can we get back to a non-french login page?
Re: [neon] Login page fails to show for french [message #1741733 is a reply to message #1741731] Mon, 29 August 2016 06:51 Go to previous messageGo to next message
Urs Beeli is currently offline Urs BeeliFriend
Messages: 562
Registered: October 2012
Location: Bern, Switzerland
Senior Member
I've made some progress: It seems that at certain times a cookie is set for "scout.preferredLocale", and once that cookie is set, changing browser languages has no effect at all. Deleting that cookie, I was able to revert back to German. What is the recommended way to manage languages in Scout Neon applications? Is there a built in way to modify that cookie from the application to switch languages on the fly using an in-application menu?

However, the question remains: How do I get my application running in French?

By the way, we're still on Neon-M7, is this perhaps a known bug that is fixed in the release version of Scout Neon?
Re: [neon] Login page fails to show for french [message #1742635 is a reply to message #1741733] Tue, 06 September 2016 08:55 Go to previous messageGo to next message
Claudio Guglielmo is currently offline Claudio GuglielmoFriend
Messages: 157
Registered: March 2010
Senior Member
Thanks for pointing this out, Urs. I opened the ticket Login page fails to show for french for this issue.

The purpose of the cookie is that the login and logout page show the text in the language of the user. Because the user is not logged in, the system does not know the preferred language yet and uses the browsers default. If the locale is changed while the user is logged in using IClientSession#setLocale, the cookie is updated accordingly.

Edit: Ticket has been resolved for Neon SR1 RC4.

[Updated on: Tue, 06 September 2016 15:10]

Report message to a moderator

Re: [neon] Login page fails to show for french [message #1745183 is a reply to message #1742635] Thu, 06 October 2016 07:32 Go to previous messageGo to next message
Urs Beeli is currently offline Urs BeeliFriend
Messages: 562
Registered: October 2012
Location: Bern, Switzerland
Senior Member
I've just upgraded the Scout version in our parent.pom from 6.0.0.M7 to 6.0.0.RC4 but the issue still exists.

What version number do I need to use to get "Neon SR1 RC4". Generally, is there a list showing the various Scout Neon release versions?
Re: [neon] Login page fails to show for french [message #1745292 is a reply to message #1745183] Fri, 07 October 2016 10:50 Go to previous messageGo to next message
René  Eigenheer is currently offline René EigenheerFriend
Messages: 100
Registered: July 2009
Senior Member
Hi Urs

At the time being I use 6.0.0.SR1_RC1 ... seems newer than the one you mentioned, but no idea, whether it's the last one.

As you mentioned, a list would be nice.

cu
Re: [neon] Login page fails to show for french [message #1745294 is a reply to message #1745292] Fri, 07 October 2016 11:05 Go to previous messageGo to next message
Judith Gull is currently offline Judith GullFriend
Messages: 75
Registered: February 2010
Member
Hi Urs
The latest versions are now in the release notes:
Neon: https://eclipsescout.github.io/6.0/release-notes.html
6.1 for Oxygen: https://eclipsescout.github.io/6.1/release-notes.html
Re: [neon] Login page fails to show for french [message #1745565 is a reply to message #1745294] Wed, 12 October 2016 14:29 Go to previous message
Urs Beeli is currently offline Urs BeeliFriend
Messages: 562
Registered: October 2012
Location: Bern, Switzerland
Senior Member
Thanks Judith

The 6.0 release-note link indicated that 6.0.100.RC4 is the latest Neon Version and using that, I can confirm that the issue has been fixed.
Previous Topic:Eclipse Scout User Group Meeting 2016
Next Topic:The Scout content assist dose not work?
Goto Forum:
  


Current Time: Thu Jun 29 16:08:44 GMT 2017

Powered by FUDForum. Page generated in 0.04418 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software