Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Mylyn update error
Mylyn update error [message #1740868] Fri, 19 August 2016 08:43 Go to next message
Mikael Springer is currently offline Mikael SpringerFriend
Messages: 6
Registered: July 2012
Junior Member
Hi.

When I try to update my Eclipse I get an update error:

> An error occurred while collecting items to be installed
> session context was:(profile=_home_micke_devel_eclipse,
> phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
> No repository found containing: osgi.bundle,org.eclipse.cdt.mylyn.ui,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.bugzilla.core,3.20.2.v20160630-1642
> No repository found containing: osgi.bundle,org.eclipse.mylyn.bugzilla.ide,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.bugzilla.ui,3.20.2.v20160630-1642
> No repository found containing: osgi.bundle,org.eclipse.mylyn.builds.core,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.builds.ui,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.core,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.identity.core,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.net,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.notifications.core,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.notifications.feed,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.notifications.ui,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.repositories.core,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.repositories.http.core,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.repositories.ui,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.screenshots,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.ui,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.workbench,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.commons.xmlrpc,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.context.core,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.context.tasks.ui,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.context.ui,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.discovery.core,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.discovery.ui,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.help.ui,3.20.2.v20160630-1642
> No repository found containing: osgi.bundle,org.eclipse.mylyn.hudson.core,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.hudson.ui,1.12.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.ide.ui,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.monitor.core,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.monitor.ui,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.resources.ui,3.20.2.v20160630-1640
> No repository found containing: osgi.bundle,org.eclipse.mylyn.tasks.bugs,3.20.2.v20160630-1642
> No repository found containing: osgi.bundle,org.eclipse.mylyn.tasks.core,3.20.2.v20160630-1642
> No repository found containing: osgi.bundle,org.eclipse.mylyn.tasks.index.core,3.20.2.v20160630-1642
> No repository found containing: osgi.bundle,org.eclipse.mylyn.tasks.index.ui,3.20.2.v20160630-1642
> No repository found containing: osgi.bundle,org.eclipse.mylyn.tasks.search,3.20.2.v20160630-1642
> No repository found containing: osgi.bundle,org.eclipse.mylyn.tasks.ui,3.20.2.v20160630-1858
> No repository found containing: osgi.bundle,org.eclipse.mylyn.team.ui,3.20.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.cdt.mylyn,5.16.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.bugzilla_feature,3.20.2.v20160630-1642
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.builds,1.12.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.commons,3.20.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.commons.identity,1.12.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.commons.notifications,1.12.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.commons.repositories,1.12.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.commons.repositories.http,1.12.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.context_feature,3.20.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.discovery,3.20.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.hudson,1.12.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.ide_feature,3.20.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.monitor,3.20.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.tasks.ide,3.20.2.v20160630-1642
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn.team_feature,3.20.2.v20160630-1640
> No repository found containing: org.eclipse.update.feature,org.eclipse.mylyn_feature,3.20.2.v20160630-1858

Anybody knows why and what I can do to fix it?

Regards, Micke.
Re: Mylyn update error [message #1741053 is a reply to message #1740868] Mon, 22 August 2016 06:21 Go to previous messageGo to next message
Mikael Springer is currently offline Mikael SpringerFriend
Messages: 6
Registered: July 2012
Junior Member
I changed the update site from

http://download.eclipse.org/mylyn/releases/latest

to

http://download.eclipse.org/mylyn/releases/3.20

, then it worked. What's the difference between these update sites?
Which one should I use?

Regards, Micke.




On 2016-08-19 10:43, Mikael Springer wrote:
> Hi.
>
> When I try to update my Eclipse I get an update error:
>
>> An error occurred while collecting items to be installed
>> session context was:(profile=_home_micke_devel_eclipse,
>> phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=,
>> action=).
>> No repository found containing:
>> osgi.bundle,org.eclipse.cdt.mylyn.ui,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.bugzilla.core,3.20.2.v20160630-1642
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.bugzilla.ide,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.bugzilla.ui,3.20.2.v20160630-1642
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.builds.core,1.12.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.builds.ui,1.12.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.core,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.identity.core,1.12.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.net,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.notifications.core,1.12.2.v20160630-1640
>>
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.notifications.feed,1.12.2.v20160630-1640
>>
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.notifications.ui,1.12.2.v20160630-1640
>>
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.repositories.core,1.12.2.v20160630-1640
>>
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.repositories.http.core,1.12.2.v20160630-1640
>>
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.repositories.ui,1.12.2.v20160630-1640
>>
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.screenshots,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.ui,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.workbench,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.commons.xmlrpc,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.context.core,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.context.tasks.ui,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.context.ui,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.discovery.core,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.discovery.ui,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.help.ui,3.20.2.v20160630-1642
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.hudson.core,1.12.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.hudson.ui,1.12.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.ide.ui,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.monitor.core,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.monitor.ui,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.resources.ui,3.20.2.v20160630-1640
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.tasks.bugs,3.20.2.v20160630-1642
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.tasks.core,3.20.2.v20160630-1642
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.tasks.index.core,3.20.2.v20160630-1642
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.tasks.index.ui,3.20.2.v20160630-1642
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.tasks.search,3.20.2.v20160630-1642
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.tasks.ui,3.20.2.v20160630-1858
>> No repository found containing:
>> osgi.bundle,org.eclipse.mylyn.team.ui,3.20.2.v20160630-1640
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.cdt.mylyn,5.16.2.v20160630-1640
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.bugzilla_feature,3.20.2.v20160630-1642
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.builds,1.12.2.v20160630-1640
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.commons,3.20.2.v20160630-1640
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.commons.identity,1.12.2.v20160630-1640
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.commons.notifications,1.12.2.v20160630-1640
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.commons.repositories,1.12.2.v20160630-1640
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.commons.repositories.http,1.12.2.v20160630-1640
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.context_feature,3.20.2.v20160630-1640
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.discovery,3.20.2.v20160630-1640
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.hudson,1.12.2.v20160630-1640
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.ide_feature,3.20.2.v20160630-1640
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.monitor,3.20.2.v20160630-1640
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.tasks.ide,3.20.2.v20160630-1642
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn.team_feature,3.20.2.v20160630-1640
>>
>> No repository found containing:
>> org.eclipse.update.feature,org.eclipse.mylyn_feature,3.20.2.v20160630-1858
>>
>
> Anybody knows why and what I can do to fix it?
>
> Regards, Micke.
Re: Mylyn update error [message #1741070 is a reply to message #1741053] Mon, 22 August 2016 16:26 Go to previous messageGo to next message
Jaxsun McCarthy Huggan is currently offline Jaxsun McCarthy HugganFriend
Messages: 7
Registered: January 2016
Junior Member
Hello Micke,

I am not sure why changing to the latest repository fxed the issue. Both the 3.20 and latest update sites have the all 3.20 releases (3.20.0, 3.20.1 and 3.20.2). So there is currently no difference between these two sites. The main difference between them is that in future the latest release site will have newer releases once they are released, as you might expect.

I suspect your initial error was due to some caching issue where it wasn't seeing 3.20.2 in the update site, or perhaps some connectivity issue.

-Jaxsun
Re: Mylyn update error [message #1759462 is a reply to message #1741070] Tue, 11 April 2017 12:58 Go to previous messageGo to next message
David Frantz is currently offline David FrantzFriend
Messages: 6
Registered: March 2017
Junior Member
Thanks guys, this got me on the right track. For some reason My Eclipse update was pointing to an e3.4 directory, this on a newish install. In my case pointed the update system at http://download.eclipse.org/mylyn/releases/latest and updates went as planned. Not at all sure how that happened.
Re: Mylyn update error [message #1768652 is a reply to message #1759462] Fri, 21 July 2017 01:25 Go to previous messageGo to next message
Spencer Williams is currently offline Spencer WilliamsFriend
Messages: 5
Registered: November 2014
Junior Member
I was having a very similar problem for updating version 3.23 when the http://download.eclipse.org/mylyn/releases/latest update site was set. When I went to Available Software Sites, I noticed that a listing for http://download.eclipse.org/mylyn/releases/3.23 was there but unchecked. When I checked it and clicked OK, it was finally able to do the update.
Re: Mylyn update error [message #1798217 is a reply to message #1768652] Wed, 14 November 2018 09:55 Go to previous messageGo to next message
Nicholas Wright is currently offline Nicholas WrightFriend
Messages: 1
Registered: November 2018
Junior Member
Same here - your solution worked for me! Thanks!
Re: Mylyn update error [message #1815893 is a reply to message #1798217] Mon, 14 October 2019 14:53 Go to previous messageGo to next message
Alvargon NA is currently offline Alvargon NAFriend
Messages: 1
Registered: October 2019
Junior Member
Nowadays, the best solution is still to change the repository from http://download.eclipse.org/mylyn/releases/latest to http://download.eclipse.org/mylyn/releases/3.25

Re: Mylyn update error [message #1826713 is a reply to message #1815893] Wed, 29 April 2020 10:45 Go to previous message
Missing name Mising name is currently offline Missing name Mising nameFriend
Messages: 1
Registered: July 2009
Junior Member
I know this is an old thread, but I arrived here after having exactly the same problem (Eclipse Photon 2020-03 release). My update sites also already included the mylyn release link:

https://download.eclipse.org/mylyn/releases/latest

But then I noticed a slight difference in the suggested link above:

http://download.eclipse.org/mylyn/releases/latest

When I switched from https to http the updates installed immediately, and without problem. So there appears to be some problem when accessing the update site via https, although I don't know if it's a recent problem (I only noticed the problem with the mylyn updates about two weeks ago) or something that's been happening for some time.

When I first noticed the problem I also had difficulty updating SonarLint - that plugin had been installed from the MarketPlace app, and attempts to use the autoupdate feature of Eclipse also failed. I had to use MarketPlace to update that plugin (again, about two weeks ago when I noticed the mylyn problem).

Hope this info helps others in a similar situation.
Previous Topic:Info strings in code blocks
Goto Forum:
  


Current Time: Mon May 25 02:45:31 GMT 2020

Powered by FUDForum. Page generated in 0.02109 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top