Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse SmartHome » Setup ESH development environment failed(Setting up a new eclipse development environment with esh ends up in a huge number of errors)
icon8.gif  Setup ESH development environment failed [message #1736718] Fri, 01 July 2016 10:09 Go to next message
Michael Weller is currently offline Michael WellerFriend
Messages: 1
Registered: July 2016
Junior Member
I've tried about 10 times with slight variations to setup Eclipse with ESH (with and without OH2).

I use the Eclipse Installer and selected "Smart Home".
I've even tried to select OH from GIT.

But I have no success at all. I get some hundreds of compile errors.

Here are 2 examples, each stands for hunderds of similar errors:

ModelItem cannot be resolved to a type. // ItemsLabelProvider.xtend // Xtend Problem

Package 'org.eclipse.smarthome.model.rule.parser.antlr' does not exist in this plug-in// MANIFEST.MF /org.eclipse.smarthome.model.rule/META-INF line 54 Plug-in Problem


Can anybody help me to get up and running with a development environment "eclipse + Smarthome + OH" ??
Re: Setup ESH development environment failed [message #1736986 is a reply to message #1736718] Mon, 04 July 2016 19:11 Go to previous messageGo to next message
Markus Rathgeb is currently offline Markus RathgebFriend
Messages: 101
Registered: August 2014
Senior Member

Are you using the Eclipse SmartHome project or the openHAB one in Oomph?
Perhaps you can first start with Eclipse SmartHome and if that is working you can setup a new IDE using the openHAB setup with OH+ESH
Re: Setup ESH development environment failed [message #1737520 is a reply to message #1736718] Sat, 09 July 2016 00:36 Go to previous messageGo to next message
Dale Angus is currently offline Dale AngusFriend
Messages: 9
Registered: July 2016
Junior Member
I am also having problems getting a good build. Getting hundreds of errors.



Re: Setup ESH development environment failed [message #1737521 is a reply to message #1736718] Sat, 09 July 2016 00:38 Go to previous messageGo to next message
Dale Angus is currently offline Dale AngusFriend
Messages: 9
Registered: July 2016
Junior Member
I am not able to get a good build by just following the instructions. Getting hundreds of errors.
Re: Setup ESH development environment failed [message #1737530 is a reply to message #1737521] Sat, 09 July 2016 09:10 Go to previous messageGo to next message
Markus Rathgeb is currently offline Markus RathgebFriend
Messages: 101
Registered: August 2014
Senior Member

Have you had a look at this one:
https://github.com/eclipse/smarthome/issues/1760

Can you go step by step through the setup instructions and post at which time errors occurred etc.
If the instructions are not clear, we should work improve the documentation, so complain about every thing that is not clear.
Have you used Neon?
Re: Setup ESH development environment failed [message #1737539 is a reply to message #1737530] Sat, 09 July 2016 16:13 Go to previous messageGo to next message
Dale Angus is currently offline Dale AngusFriend
Messages: 9
Registered: July 2016
Junior Member
Yes I followed the same steps from the "Setting Up a Development Environment" page.
I noticed these errors after I clean all projects. Did not build automatically.
See image.



I fixed the build-path to get rid of those errors.
But it looks like the code generated by xtext are having issues with missing classes.
See image.


[Updated on: Sat, 09 July 2016 16:26]

Report message to a moderator

Re: Setup ESH development environment failed [message #1737540 is a reply to message #1737539] Sat, 09 July 2016 16:20 Go to previous messageGo to next message
Markus Rathgeb is currently offline Markus RathgebFriend
Messages: 101
Registered: August 2014
Senior Member

The missing src-gen folder of the model bundles looks like the model generation does not succeeded.
The model generation should be triggered by a setup task, so at step 8.

You can try to trigger the model generation yourself:
https://github.com/eclipse/smarthome/issues/1760#issuecomment-230324873

Another option would be to close the IDE, trigger a maven build and then start the IDE and perform a clean.

I will try a new installation myself and give you feedback if it is working for me.
Re: Setup ESH development environment failed [message #1737541 is a reply to message #1737540] Sat, 09 July 2016 16:28 Go to previous messageGo to next message
Dale Angus is currently offline Dale AngusFriend
Messages: 9
Registered: July 2016
Junior Member
OK. I'll do a reinstall.
Re: Setup ESH development environment failed [message #1737543 is a reply to message #1737540] Sat, 09 July 2016 17:07 Go to previous messageGo to next message
Dale Angus is currently offline Dale AngusFriend
Messages: 9
Registered: July 2016
Junior Member
Linux installation:
I ran mvn under ~/smarthome-master/git/smarthome

Looks like I missed an argument. Which lifecycle to use?

[ERROR] No goals have been specified for this build. You must specify a valid lifecycle phase or a goal in the format <plugin-prefix>:<goal> or <plugin-group-id>:<plugin-artifact-id>[:<plugin-version>]:<goal>. Available lifecycle phases are: validate, initialize, generate-sources, process-sources, generate-resources, process-resources, compile, process-classes, generate-test-sources, process-test-sources, generate-test-resources, process-test-resources, test-compile, process-test-classes, test, prepare-package, package, pre-integration-test, integration-test, post-integration-test, verify, install, deploy, pre-clean, clean, post-clean, pre-site, site, post-site, site-deploy. -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/NoGoalSpecifiedException
Re: Setup ESH development environment failed [message #1737544 is a reply to message #1737540] Sat, 09 July 2016 17:09 Go to previous messageGo to next message
Markus Rathgeb is currently offline Markus RathgebFriend
Messages: 101
Registered: August 2014
Senior Member

I cannot reproduce it. If I follow all steps there are 0 errors remaining.
Here a short summary of what I have done / the results:

* Using Eclipe Installer "1.4.0 Build 2444"

Product
* Eclipse IDE for Java Developers
* Product Version: Latest Release (Neon)
* Java 1.8 + VM: /usr/bin/jvm/oracle-jdk-bin-1.8

Project
* Eclipse Projects, SmartHome, Runtime and Designer

After step 7
* Problems: 299 errors, 1,620 warnings, 0 others (Filtter matches 200 of 1919 items)

After step 8 (after the last step "Launch Generate All Models" succeeded")
* Problems: 95 errors, 1,949 warnings, 0 others (Filtter matches 195 of 2044 items)

After step 9 (clean all with a rebuild)
* Problems: 0 errors, 1,635 warnings, 0 others (Filtter matches 100 of 1947 items)
Re: Setup ESH development environment failed [message #1737545 is a reply to message #1737544] Sat, 09 July 2016 17:14 Go to previous messageGo to next message
Markus Rathgeb is currently offline Markus RathgebFriend
Messages: 101
Registered: August 2014
Senior Member

For Maven:
mvn clean install
Re: Setup ESH development environment failed [message #1737547 is a reply to message #1737545] Sat, 09 July 2016 17:44 Go to previous messageGo to next message
Dale Angus is currently offline Dale AngusFriend
Messages: 9
Registered: July 2016
Junior Member
OK. I'll keep trying. So far it's doing something with node and npm install (both Windows and Linux)

I saw this
[INFO] Installed node locally.
[INFO] Installing npm version 3.3.12
[INFO] Downloading http://registry.npmjs.org/npm/-/npm-3.3.12.tgz to C:\Users\d7qm322\.m2\repository\com\github\eirslett\npm\3.3.12\npm-3.3.12.tar.gz
[INFO] No proxies configured
[INFO] No proxy was configured, downloading directly
[INFO] Unpacking C:\Users\d7qm322\.m2\repository\com\github\eirslett\npm\3.3.12\npm-3.3.12.tar.gz into C:\smarthome-master\git\smarthome\extensions\ui\org.eclipse.smarthome.ui.paper\node\node_modules
[INFO] Installed npm locally.
[INFO]
[INFO] --- frontend-maven-plugin:1.0:npm (npm install) @ org.eclipse.smarthome.ui.paper ---
[INFO] Running 'npm install' in C:\smarthome-master\git\smarthome\extensions\ui\org.eclipse.smarthome.ui.paper
[WARNING] npm WARN engine bootstrap@3.3.2: wanted: {"node":"~0.10.1"} (current: {"node":"5.4.0","npm":"3.3.12"})
[WARNING] npm WARN install Couldn't install optional dependency: Unsupported

[Updated on: Sat, 09 July 2016 17:46]

Report message to a moderator

Re: Setup ESH development environment failed [message #1737548 is a reply to message #1737547] Sat, 09 July 2016 17:51 Go to previous messageGo to next message
Dale Angus is currently offline Dale AngusFriend
Messages: 9
Registered: July 2016
Junior Member
Taking a long time on this node / npm install. I did a mvn compile. I'll run it again.

But just FYI

Windows
[WARNING] npm WARN engine bootstrap@3.3.2: wanted: {"node":"~0.10.1"} (current: {"node":"5.4.0","npm":"3.3.12"})
[WARNING] npm WARN install Couldn't install optional dependency: Unsupported
[WARNING] npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

Should I preinstall node and npm before I do a mvn clean install?
Re: Setup ESH development environment failed [message #1737549 is a reply to message #1737548] Sat, 09 July 2016 18:08 Go to previous messageGo to next message
Dale Angus is currently offline Dale AngusFriend
Messages: 9
Registered: July 2016
Junior Member
I ran mvn clean install on both Linux (Ubuntu) and Windows 10

Both are in

[INFO] Node v5.4.0 is already installed.
[INFO] NPM 3.3.12 is already installed.
[INFO]
[INFO] --- frontend-maven-plugin:1.0:npm (npm install) @ org.eclipse.smarthome.ui.paper ---
[INFO] Running 'npm install' in C:\smarthome-master\git\smarthome\extensions\ui\org.eclipse.smarthome.ui.paper
[WARNING] npm WARN engine bootstrap@3.3.2: wanted: {"node":"~0.10.1"} (current: {"node":"5.4.0","npm":"3.3.12"})
[WARNING] npm WARN install Couldn't install optional dependency: Unsupported

Long running process... Will leave those running for now...
Re: Setup ESH development environment failed [message #1737551 is a reply to message #1737549] Sat, 09 July 2016 18:42 Go to previous messageGo to next message
Dale Angus is currently offline Dale AngusFriend
Messages: 9
Registered: July 2016
Junior Member
In both Windows and Linux, the build was successful.

Opened the IDE, did a clean. No more errors!

Now under Run Configuration, ran SmartHome Runtime. Failed. see image
Example,

"The project cannot be built until its prerequisite org.eclipse.smarthome.io.rest is built. Cleaning and building all projects is recommended "

And so I did. And SUCCESS!




  • Attachment: isbuilt.GIF
    (Size: 141.13KB, Downloaded 58 times)
Re: Setup ESH development environment failed [message #1737553 is a reply to message #1737551] Sat, 09 July 2016 18:59 Go to previous message
Markus Rathgeb is currently offline Markus RathgebFriend
Messages: 101
Registered: August 2014
Senior Member

Dale Angus wrote on Sat, 09 July 2016 18:42
And so I did. And SUCCESS!


Sounds good.
The npm stuff is for the Paper UI (its dependencies). It downloads a lot of stuff, so the time depends on your internet connection and the speed that is provided by the servers that hosting the third party stuff.

Happy coding.
Previous Topic:Channels not yet linked when initialize() method of handler is called?
Next Topic:Auto created items are not managed
Goto Forum:
  


Current Time: Fri Sep 21 19:27:41 GMT 2018

Powered by FUDForum. Page generated in 0.02507 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top