Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Lua Development Tools » Crash when upgrading to new debugger.lua
Crash when upgrading to new debugger.lua [message #1735039] Tue, 14 June 2016 20:36 Go to next message
Andres Ispani is currently offline Andres IspaniFriend
Messages: 1
Registered: June 2016
Junior Member
Hi, I've been the LDT lua debugger for the past year or so, and it worked great. Today I updated debugger.lua to the new version provided by the IDE (LDT Version 1.3.1.201601191732), and it throws an error when using the interactive console.

Steps to reproduce:
1. Connect debugger
2. Pause execution inside a function that has at least 1 local variable
3. Type in the Interactive console: "a = function() end"
5. Type in the Interactive console: "a"
6. It throws an error, and the debugger stops working:
Execution error 998: [string "debugger.lua"]:1410: [string "debugger.lua"]:2353: assertion failed!
stack traceback:
[C]: in function 'assert'
[string "debugger.lua"]:1410: in function 'make_property'
[string "debugger.lua"]:479: in function <[string "debugger.lua"]:445>
[C]: in function 'xpcall'
[string "debugger.lua"]:3085: in function <[string "debugger.lua"]:3055>
[C]: in function 'pcall'
[string "debugger.lua"]:3140: in function 'line_hook'
[string "debugger.lua"]:3189: in function <[string "debugger.lua"]:3174>

It seems the assert is in the "get_script_level" function, called when trying to get a local variable, so step "2" is important. The crash does not happen if execution is paused outside a function with local variables.
I also tried the same steps on an older version of debugger.lua (very old, about 2013) and it works fine.

Any help would be appreciated.
Thanks!
Re: Crash when upgrading to new debugger.lua [message #1737190 is a reply to message #1735039] Wed, 06 July 2016 10:14 Go to previous message
Simon Bernard is currently offline Simon BernardFriend
Messages: 337
Registered: July 2009
Senior Member
I tried to reproduce this and it works for me with LDT 1.3.1 and LDT 1.4.0M3.
Previous Topic:A good example of luadoc usage ...
Next Topic:Debugger crashes with Torch and Mars
Goto Forum:
  


Current Time: Mon Sep 24 23:03:12 GMT 2018

Powered by FUDForum. Page generated in 0.01362 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top