Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Equinox Launcher EXE vs. bundle jar
Equinox Launcher EXE vs. bundle jar [message #1733551] Mon, 30 May 2016 06:41
Dirk Fauth is currently offline Dirk FauthFriend
Messages: 2603
Registered: July 2012
Senior Member
I came across some strange issue regarding the embedded SWT browser control. The SWT browser behaves different whether I start it from the EXE or via

java -jar plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar


I created a small sample that uses the Nebula RichText control (which uses the ckeditor within an embedded SWT browser) and attached it to [1]. Starting the product from within the IDE or via command line as above, everything looks as intended. Starting it from the generated EXE the icons that use opacity style are not shown.

I created ticket [2] because I'm not sure whether it is a SWT or an Equinox Launcher issue. The original ticket [1] was based on even older versions of Eclipse and IE.

Any hints would be welcome.

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=364743
[2] https://bugs.eclipse.org/bugs/show_bug.cgi?id=494865
Previous Topic:osgi.dev property in eclipse 4.5.2
Next Topic:Slow classloading after second start of equinox
Goto Forum:
  


Current Time: Mon Jun 25 19:44:23 GMT 2018

Powered by FUDForum. Page generated in 0.01738 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top