Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Jubula » RCP AUT is started but the AUT progress is still running
icon9.gif  RCP AUT is started but the AUT progress is still running [message #1721406] Wed, 27 January 2016 08:12 Go to next message
wang victor is currently offline wang victorFriend
Messages: 3
Registered: January 2016
Junior Member
I'm using the Jubula(Version:8.2.0.021) Standalone Eclipse RCP Client to start the configured AUT,
The executable defined in the aut starts up and lauches successfully, but the aut progress is still running.

I've already added org.eclipse.jubula.rc.rcp@start to the end of the osgi.bundles parameter in my product config.ini file,
my tools is base osgi and javafx2.0

What is the problem?
  • Attachment: aut.png
    (Size: 7.00KB, Downloaded 101 times)
  • Attachment: rcp.png
    (Size: 18.13KB, Downloaded 133 times)
Re: RCP AUT is started but the AUT progress is still running [message #1721456 is a reply to message #1721406] Wed, 27 January 2016 15:11 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member
Hello,

am I correct that the application you want to test is an OSGi application with JavaFX? If so, then you should set the AUT toolkit to JavaFX and you do not need the RCP accessor.

Best regards,
Alex
Re: RCP AUT is started but the AUT progress is still running [message #1721671 is a reply to message #1721456] Fri, 29 January 2016 06:09 Go to previous messageGo to next message
wang victor is currently offline wang victorFriend
Messages: 3
Registered: January 2016
Junior Member
thanks,alex
you are right,My application is an OSGi application with JavaFX,But if set the AUT as javaFX,my application can not started, Jubula show a error form.

The error infomation is:
5009:AUT start failed
Establishing connection to AUT failed

My application's jre is 1.7,has some problem ?
Re: RCP AUT is started but the AUT progress is still running [message #1722044 is a reply to message #1721671] Tue, 02 February 2016 13:14 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member
Thanks for the further information. Jubula only supports applications for JavaFX from Java 8.
Can you run the AUT with Java 8?

Best regards,
Alex
Re: RCP AUT is started but the AUT progress is still running [message #1722161 is a reply to message #1722044] Wed, 03 February 2016 07:30 Go to previous messageGo to next message
wang victor is currently offline wang victorFriend
Messages: 3
Registered: January 2016
Junior Member
My issue had resolved,JRE8 is required.
Re: RCP AUT is started but the AUT progress is still running [message #1722201 is a reply to message #1722161] Wed, 03 February 2016 11:12 Go to previous message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member
Glad it worked! Thanks for the feedback Smile
Previous Topic:Providing custom location for Jubula H2 Database
Next Topic:Check coordinates button
Goto Forum:
  


Current Time: Mon Feb 26 06:04:46 GMT 2024

Powered by FUDForum. Page generated in 0.02024 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top