Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » can't debug with xdebug
can't debug with xdebug [message #1713097] Fri, 30 October 2015 22:00 Go to next message
Eran Lev is currently offline Eran LevFriend
Messages: 2
Registered: October 2015
Junior Member
Hi there,
I'm trying to debug with eclipse and xdebug a php script.
I've installed xdebug correctly, because it does appear in phpinfo() as follows:
xdebug
xdebug support enabled Version 2.2.7 IDE Key ECLIPSE_DBGP
Supported protocols Revision DBGp - Common DeBuGger Protocol $Revision: 1.145 $
Directive Local Value Master Value xdebug.auto_trace Off Off xdebug.cli_color 0 0 xdebug.collect_assignments Off Off xdebug.collect_includes On On xdebug.collect_params 0 0 xdebug.collect_return Off Off xdebug.collect_vars Off Off xdebug.coverage_enable On On xdebug.default_enable On On xdebug.dump.COOKIE no value no value xdebug.dump.ENV no value no value xdebug.dump.FILES no value no value xdebug.dump.GET no value no value xdebug.dump.POST no value no value xdebug.dump.REQUEST no value no value xdebug.dump.SERVER no value no value xdebug.dump.SESSION no value no value xdebug.dump_globals On On xdebug.dump_once On On xdebug.dump_undefined Off Off xdebug.extended_info On On xdebug.file_link_format no value no value xdebug.idekey no value no value xdebug.max_nesting_level 100 100 xdebug.overload_var_dump On On xdebug.profiler_aggregate Off Off xdebug.profiler_append Off Off xdebug.profiler_enable Off Off xdebug.profiler_enable_trigger Off Off xdebug.profiler_output_dir /tmp /tmp xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p xdebug.remote_autostart On On xdebug.remote_connect_back On On xdebug.remote_cookie_expire_time 3600 3600 xdebug.remote_enable On On xdebug.remote_handler dbgp dbgp xdebug.remote_host 77.127.241.252 77.127.241.252 xdebug.remote_log /log.txt /log.txt xdebug.remote_mode req req xdebug.remote_port 10002 10002 xdebug.scream Off Off xdebug.show_exception_trace Off Off xdebug.show_local_vars Off Off xdebug.show_mem_delta Off Off xdebug.trace_enable_trigger Off Off xdebug.trace_format 0 0 xdebug.trace_options 0 0 xdebug.trace_output_dir /tmp /tmp xdebug.trace_output_name trace.%c trace.%c xdebug.var_display_max_children 128 128 xdebug.var_display_max_data 512 512 xdebug.var_display_max_depth 3 3


eclipse keeps stucking in 78%, though it does not stop at any breakpoint. can somebody help? Thanks
Re: can't debug with xdebug [message #1713173 is a reply to message #1713097] Sun, 01 November 2015 22:44 Go to previous message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 207
Registered: March 2013
Senior Member
As I see you are using non standard xdebug port (10002).

Make sure same is set in eclipse debugger preferences: Preferences / PHP / Debug / Debuggers and select xdebug.


Previous Topic:Search > File closes opens file automatically
Next Topic:Unzipping eclipse Java IDE
Goto Forum:
  


Current Time: Fri Jan 19 01:50:36 GMT 2018

Powered by FUDForum. Page generated in 0.01764 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software