Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Missing binaries when building rt.equinox.framework
Missing binaries when building rt.equinox.framework [message #1710515] Wed, 07 October 2015 09:37
Adrian PrFriend
Messages: 4
Registered: October 2015
Junior Member
Hi,

I've got the following error while trying to build "rt.equinox.framework":

org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-
antrun-plugin:1.8:run (copy-launcher-natives) on project org.eclipse.equinox.launcher.win32.win32.x86: An Ant
BuildException has occured: D:\ptcm-dev3\eclipse\equinox-master-clean\git\rt.equinox.binaries\org.eclipse.equi
nox.launcher.win32.win32.x86 does not exist.

Caused by: D:\ptcm-dev3\eclipse\equinox-master-clean\git\rt.equinox.framework\bundles\org.eclipse.equinox.laun
cher.win32.win32.x86\target\antrun\build-main.xml:4: D:\ptcm-dev3\eclipse\equinox-master-clean\git\rt.equinox.
binaries\org.eclipse.equinox.launcher.win32.win32.x86 does not exist.


It works with downloaded binaries and copied into the expected directory, but that's probably not the intended way. What is the correct way to build this project?
The project was set up using the Oomph installer, selecting the "Committers" product and the Equinox project setups "bundles" and "framework".

Regards,
Adrian
Previous Topic:Equinox servlet bridge invalid code according to Servlet 3.0 specifications
Next Topic:Using OSGI LogReaderService with SLF4J/Logback
Goto Forum:
  


Current Time: Fri Sep 21 04:32:20 GMT 2018

Powered by FUDForum. Page generated in 0.03183 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top