Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » font display issues with mars/centos6
font display issues with mars/centos6 [message #1707229] Thu, 03 September 2015 08:02 Go to next message
Vlad Gheorghe is currently offline Vlad GheorgheFriend
Messages: 127
Registered: May 2011
Senior Member
Hello,

We have the following setup:
Eclipse Mars 4.5
GTK version 2.18.9
CentOS 6

With this configuration, the drop-down lists contain garbled text, probably when there are more elements than can be displayed without scrolling.
Please see attached image.

Can anyone please recommend a fix or work-around ?

Best regards
Vlad Gheorghe
  • Attachment: GTK_ISSUE.png
    (Size: 124.12KB, Downloaded 146 times)
Re: font display issues with mars/centos6 [message #1707317 is a reply to message #1707229] Thu, 03 September 2015 16:39 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 693
Registered: January 2012
Senior Member

I've seen oddities like that when an exception has occurred when building up the menu content

Does it happen on all popup menus, or just this particular menu?


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: font display issues with mars/centos6 [message #1707409 is a reply to message #1707317] Fri, 04 September 2015 14:41 Go to previous messageGo to next message
Andreea Pintea is currently offline Andreea PinteaFriend
Messages: 5
Registered: September 2015
Junior Member
Hi Brian,

It seems that no exception occurs in our case. This happens on all drop-down lists that
surpass a specific size (in this case more than 13 items).
Can you give us some hints regarding a potential fix for this?

Thank you !
Best Regards,

Andreea Pintea
Re: font display issues with mars/centos6 [message #1708118 is a reply to message #1707409] Mon, 14 September 2015 02:04 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 693
Registered: January 2012
Senior Member

Andreea,

Does this happen within the Eclipse IDE? If no, then there's something specific to your app.

In the case I described, it happened on most context menus. In trying to track the cause down, I discovered that the actual exception was caught and never actually logged: I stumbled across it by accident. Look at your code for dynamic menu builders (e.g., the org.eclipse.ui.menus <dynamic>).

If it happens within the IDE too, then try building a small standalone example that demonstrates the problem, ideally something using just pure SWT. You can build something pretty quickly in WindowBuilder.

Brian.


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.

[Updated on: Mon, 14 September 2015 02:04]

Report message to a moderator

Re: font display issues with mars/centos6 [message #1708429 is a reply to message #1708118] Wed, 16 September 2015 12:39 Go to previous messageGo to next message
Andreea Pintea is currently offline Andreea PinteaFriend
Messages: 5
Registered: September 2015
Junior Member
Hi Brian,

I do not manage to reproduce this in Eclipse IDE, so it it definitely an issue of the application.
However, i have discovered that this issue happens only with Combos that have the SWT.READ_ONLY constant set to TRUE.
It seems to be some conflict between this setting and the scrolling option of the Combo.
Therefore after applying SWT.NONE to the concerned combo, the scrolling becomes possible and the issue is solved.

Andreea
Re: font display issues with mars/centos6 [message #1708451 is a reply to message #1708429] Wed, 16 September 2015 15:41 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 693
Registered: January 2012
Senior Member

Could you try to put together a small testcase using just plain SWT to reproduce your issue? And then please open a bug against SWT as SWT.READ_ONLY is a valid bit for a Combo.



Thanks!


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: font display issues with mars/centos6 [message #1708669 is a reply to message #1708451] Fri, 18 September 2015 14:28 Go to previous messageGo to next message
Andreea Pintea is currently offline Andreea PinteaFriend
Messages: 5
Registered: September 2015
Junior Member
So far i have not succeeded in reproducing this issue in an isolated context. Regular Combos with this flag set, work fine in a separate application.
Of course, in case this proves to be an SWT issue, i will open a bug.

Thank you for your support!

Re: font display issues with mars/centos6 [message #1710010 is a reply to message #1708669] Fri, 02 October 2015 15:37 Go to previous messageGo to next message
Andreea Pintea is currently offline Andreea PinteaFriend
Messages: 5
Registered: September 2015
Junior Member
Hi Brian,

I have found the cause of our troubles. It seems that the default ViewerComparator that we use to sort the items makes them "overlap". Therefore i believe it is a JFace bug. I attatch the code. What do you think?

Best regards,

Andreea Pintea

Re: font display issues with mars/centos6 [message #1710034 is a reply to message #1710010] Fri, 02 October 2015 19:04 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 693
Registered: January 2012
Senior Member

Just eyeballing the code, it looks ok to me. I can't imagine how the ViewerComparator makes a difference, but please submit a bug on SWT and report the bug number here!

https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform&component=SWT

Brian.


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: font display issues with mars/centos6 [message #1710771 is a reply to message #1710034] Fri, 09 October 2015 07:41 Go to previous message
Andreea Pintea is currently offline Andreea PinteaFriend
Messages: 5
Registered: September 2015
Junior Member
Thank you Brian, i have reported the problem here:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=479306

Andreea

[Updated on: Fri, 09 October 2015 11:50]

Report message to a moderator

Previous Topic:Table: set "focused" row
Next Topic:Progressbar display sync
Goto Forum:
  


Current Time: Fri Dec 15 12:15:21 GMT 2017

Powered by FUDForum. Page generated in 0.02676 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software