Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Webkit will not work on CentOS 6--Following SWT FAQ Instructions(It works on Ubuntu and on CentOS 7.1 and on CentOS 6.7 in a runtime workbench)
Webkit will not work on CentOS 6--Following SWT FAQ Instructions [message #1706933] Tue, 01 September 2015 03:27 Go to next message
Mark Leone is currently offline Mark LeoneFriend
Messages: 69
Registered: April 2012
Member
I have an RCP app that uses the Browser widget with style SWT.WEBKIT. It works when I launch it from within eclipse, but when I launch it from the command line after building it with Maven, I get the "No more handles" SWT Exception.

I followed the SWT FAQ, and I have a supported version of webkitgtk installed (1.4.3). Running ldd on the webkitgtk .so files shows no problems. I thought that maybe I'm missing a bundle in the app built with Maven, but I've compared carefully the bundles in the standalone app with those running in the runtime workbench, and nothing is missing. Furthermore, the Maven-built app does not throw the SWT Exception when I run it on Ubuntu or CentOS 7.1, so I don't think there is a bundle missing.

If I create the Browser with SWT.NONE and set properties org.eclipse.swt.browser.DefaultType=mozilla and org.eclipse.swt.browser.XULRunnerPath to point to a compatible version of XULRunner, the Browser can be created successfully. Unfortunately the performance of the gecko renderer is an order of magnitude worse than webkit, and my app bogs down to the point of being useless (it runs a javascript plotter that does some intensive rendering).

I've spent a couple months developing the app, and now I have no way to create a working distribution, as I cannot require my users to install CentOS 7.1. The fact that it works in the runtime workbench should give a clue to what the problem is; but the fact that it works from the command line for other distributions is a contrary symptom, and seems to indicate that SWT has an incompatibility with CentOS 6. I tried setting LD_LIBRARY_PATH to point to the webkitgtk .so files, to no avail.

The app is based on Eclipse 4.4, but I downgraded it to 4.3 and got the same behavior.
Re: Webkit will not work on CentOS 6--Following SWT FAQ Instructions [message #1707041 is a reply to message #1706933] Tue, 01 September 2015 17:28 Go to previous message
Mark Leone is currently offline Mark LeoneFriend
Messages: 69
Registered: April 2012
Member
I think I found what's causing the problem. After looking in detail at the short status output in the osgi console for the Maven-built product, I noticed a slight discrepancy in the launcher library version as compared to the launcher installed in the eclipse IDE:

The plugin running in the Maven-built product is
org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20150204-1316
and the plugin installed with the Mars release of the IDE is
org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.300.v20150602-1417

I replaced the slightly older native launcher plugin in the built product with the one from the Mars installation, changed the value of the launcher.library property in the application's .ini file, and this fixed the problem.

The native launcher plugin that fails to link to webkitgtk was installed in my target platform from update site http://download.eclikpse.org/eclipse/updates/4.4,
by selecting the latest version (4.4.2.M20150204-1700) of the Eclipse Platform SDK, Eclipse RCP Plug-in Developer Resources, and Eclipse SDK features (not sure which one provides the launcher plug-in).
The Mars installation is Mars Release (4.5.0) Build id: 20150621-1200.
This seems like a bug, but I haven't seen any reports of anyone else running into it. Clearly the launcher from the update site doesn't work with the latest webkitgtk on CentOS 6.x, and the one in the Mars installaiton does. Is there another update site where I can get the later version of the launcher, so I don't have to manually swap it out after running the MAven build?
Previous Topic:SWT browser on linux
Next Topic:[Solved] Segoe Ui semibold font creation
Goto Forum:
  


Current Time: Tue Dec 12 10:43:20 GMT 2017

Powered by FUDForum. Page generated in 0.02227 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software