Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Can I use org.eclipse.equinox.ds v1.4.1 instead of 1.3.1 in RCP app based on 3.7.2?
icon5.gif  Can I use org.eclipse.equinox.ds v1.4.1 instead of 1.3.1 in RCP app based on 3.7.2? [message #1703429] Fri, 31 July 2015 13:38
Stephan Druskat is currently offline Stephan DruskatFriend
Messages: 102
Registered: October 2011
Location: Berlin, Germany
Senior Member

My Eclipse app (3.7.2-based) wraps an OSGi application with a dependency to org.eclipse.equinox.ds 1.4.1.

The Eclipse RCP plugin defines a dependency to org.eclipse.equinox.ds 1.3.1.

Two issues: I cannot install both in the target platform, and also the OSGi app simply doesn't run with .ds 1.3.1.

Is there a way to get the Eclipse RCP Plugin to work with .ds 1.4.1 rather than 1.3.1 (a way other than re-compiling it myself with a changed dependency, hoping that it'll run with 1.4.1 out-of-the-box)?

Or is there a way to install both in the target platform (I guess not)?

Many thanks!

[Updated on: Fri, 31 July 2015 13:38]

Report message to a moderator

Previous Topic:Uninstall feature does not work as expected
Next Topic:Programmatically get java proposals for eclipse bundle
Goto Forum:
  


Current Time: Fri Sep 21 23:47:45 GMT 2018

Powered by FUDForum. Page generated in 0.01712 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top