Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Could not find JRE executable(Trying to run a StaticWebProject)
Could not find JRE executable [message #1702727] Fri, 24 July 2015 11:08 Go to next message
Jay Sal is currently offline Jay SalFriend
Messages: 1
Registered: July 2015
Junior Member
Hello, I am running into problems in Eclipse Mars when trying to run a static web project using the HTTP preview server (as well as dynamic web project running on apache, but one thing at a time), I get this error.

'Launching HTTP Preview at localhost' has encountered a problem.
Could not find JRE executable.

I tried searching these forums and did not find anything so sorry if this has been addressed before. Also tried searching internet but did not find anything that worked for me.

When I run, java -version in terminal it shows:
java version "1.8.0_20"
Java(TM) SE Runtime Environment (build 1.8.0_20-b26)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b23, mixed mode)

Please help
Re: Could not find JRE executable [message #1702836 is a reply to message #1702727] Sat, 25 July 2015 13:57 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 07/24/2015 06:36 AM, Jay Sal wrote:
> Hello, I am running into problems in Eclipse Mars when trying to run a
> static web project using the HTTP preview server (as well as dynamic web
> project running on apache, but one thing at a time), I get this error.
>
> 'Launching HTTP Preview at localhost' has encountered a problem.
> Could not find JRE executable.
>
> I tried searching these forums and did not find anything so sorry if
> this has been addressed before. Also tried searching internet but did
> not find anything that worked for me.
>
> When I run, java -version in terminal it shows:
> java version "1.8.0_20"
> Java(TM) SE Runtime Environment (build 1.8.0_20-b26)
> Java HotSpot(TM) 64-Bit Server VM (build 25.20-b23, mixed mode)
>
> Please help

Not sure I can help positively, but try these things:

1) Installed Eclipse IDE for Java EE Developers?

2) Windows -> Preferences -> Java -> Installed JREs?
Re: Could not find JRE executable [message #1703144 is a reply to message #1702727] Tue, 28 July 2015 20:57 Go to previous messageGo to next message
Eric Ford is currently offline Eric FordFriend
Messages: 11
Registered: July 2009
Junior Member
I had a similar issue that was due to having multiple JDK/JRE installations on the same machine. I removed all but the latest and the problem never occurred again.
Re: Could not find JRE executable [message #1703151 is a reply to message #1702727] Tue, 28 July 2015 21:59 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 07/24/2015 06:36 AM, Jay Sal wrote:
> Hello, I am running into problems in Eclipse Mars when trying to run a
> static web project using the HTTP preview server (as well as dynamic web
> project running on apache, but one thing at a time), I get this error.
>
> 'Launching HTTP Preview at localhost' has encountered a problem.
> Could not find JRE executable.
>
> I tried searching these forums and did not find anything so sorry if
> this has been addressed before. Also tried searching internet but did
> not find anything that worked for me.
>
> When I run, java -version in terminal it shows:
> java version "1.8.0_20"
> Java(TM) SE Runtime Environment (build 1.8.0_20-b26)
> Java HotSpot(TM) 64-Bit Server VM (build 25.20-b23, mixed mode)
>
> Please help

What I do is this...

I install exactly the JDK I want to use with Eclipse, usually the
latest. Not merely a JRE, but the JDK. And I do it locally, not for my
host. I let the host's notion of JRE be whatever it wants to be.

I run Eclipse wired up to my own private JDK.

This way, I know what JDK/JRE I'm running Eclipse on and what I'm using
to develop Java code to.
Re: Could not find JRE executable [message #1771688 is a reply to message #1703151] Tue, 29 August 2017 14:16 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3596
Registered: July 2009
Senior Member

It's a Mac-specific bug. It'll be fixed in Oxygen.1.

http://bugs.eclipse.org/518546


Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Error Message
Next Topic:How do I Change the Default Settings on Eclipse
Goto Forum:
  


Current Time: Fri Feb 28 23:00:55 GMT 2020

Powered by FUDForum. Page generated in 0.06234 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top