Downloads

Validation (Incubation) PhaseComponent selection

Modeling Build FeedLatest Builds

Archived Releases

Older UML2 Tools releases have been moved to archive.eclipse.org, and can be accessed here:

Questions?

If you have problems downloading the drops, contact the webmaster.

These are the minimum required downloads for using UML2:

  • To use UML2 Tools, you require both the UML2 Tools & EMF Runtimes.
  • To use UML2 Tools with XSD models, you will also require the XSD Runtime.
  • You will also require GMF to be installed, as well as its prerequisite dependencies. To know which Eclipse, EMF, UML2, GMF, etc. drivers were used to build a given release, see Build Dependencies for any build listed above.

All downloads are provided under the terms and conditions of the Eclipse Foundation Software User Agreement unless otherwise specified.

Getting Sources
Sort
Incubation

This component is currently in its Validation (Incubation) Phase.

IP Log

See committer/contributor IP log.