Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » qualifier replacement not happening
qualifier replacement not happening [message #510892] Fri, 29 January 2010 02:39 Go to previous message
Martin Taal is currently offline Martin Taal
Messages: 5339
Registered: July 2009
Senior Member
Hi,
I am not sure if I do this right, but I have this in my properties file:
# How .qualifier in versions should be replaced
qualifier.replacement.*=generator:buildTimestamp
#qualifier.replacement.*=generator:lastRevision

# How the qualifier (last revision) should be formatted
#generator.lastRevision.format=r{0,number,00000}
generator.buildTimestamp.format='I'yyyyMMddHHmm

and I pass the properties file to buckminster like this:

../buckminster/buckminster -data ../builds/workspace/ perform -P
.../setup/org.eclipse.emf.texo.releng.buckminster/buckminste r.properties org.eclipse.emf.texo.releng.buckminster#site.p2

I hoped that the p2 site plugins/features would have the .qualifier in the version replaced by a buildTimestamp but this
has not happened.

Can someone see if I do something wrong?


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:Problems installing headless buckminster 3.6
Next Topic:Buckminster does not see the cspec file it seems
Goto Forum:
  


Current Time: Fri Oct 24 12:49:29 GMT 2014

Powered by FUDForum. Page generated in 0.03231 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software