Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Debian testing, Gnome and Eclipse
Debian testing, Gnome and Eclipse [message #492089] Sun, 18 October 2009 14:18 Go to next message
Eclipse UserFriend
Originally posted by: gunnar.stahl.gunnarstahl.org

Hi,
since yesterday my eclipse installation is somewhat broken. The system I
use is a debian testing. After the most recent debian package updates,
performed yesterday, which included some gtk updates, eclipse has some
serious user interface issues.

Within some of the settings dialogs the buttons receive the "mouse
pressed" event, but no "mouse released" event. Which results in
clickable but unresponsive buttons.

For instance go into Windows -> preferences, and select the node "web ->
javascript -> include path -> user libraries". Create a new library via
the "New" button. A dialog window pops up. In this dialog window enter a
name for the new library. Then try to click the "OK" button. The button
gets pressed down, but after releasing the mouse button the ok-button
stays pressed down as long as the mouse pointer hovers above this button.

A workaround is to press the space bar after clicking the button. At
least this results in the click getting finished.

I guess some things changed in the way that gtk behaves and since swt
relies on gtk this results in the event handling being broken.

Any ideas?

Yt,

Gunnar
Re: Debian testing, Gnome and Eclipse [message #492094 is a reply to message #492089] Sun, 18 October 2009 15:23 Go to previous messageGo to next message
Michael Pellaton is currently offline Michael PellatonFriend
Messages: 289
Registered: July 2009
Senior Member
Hello

It's a well known issue with GTK 2.18 (from which the users of the
upcoming Ubuntu 2009.10 stable release will suffer too). The issues
in that area can easily be found using this bugzilla query:

https://bugs.eclipse.org/bugs/buglist.cgi?quicksearch=gtk+2. 18

The bug
https://bugs.eclipse.org/bugs/buglist.cgi?quicksearch=gtk+2. 18
describes a workaround, but I have no clue whether it really helps.

HTH

Michael
Re: Debian testing, Gnome and Eclipse [message #492101 is a reply to message #492094] Sun, 18 October 2009 17:02 Go to previous message
Eclipse UserFriend
Originally posted by: gunnar.stahl.gunnarstahl.org

Hello Michael,
thanks for the info! That solution actually did the trick!

Yt,

Gunnar

Michael Pellaton schrieb:
> Hello
>
> It's a well known issue with GTK 2.18 (from which the users of the
> upcoming Ubuntu 2009.10 stable release will suffer too). The issues
> in that area can easily be found using this bugzilla query:
>
> https://bugs.eclipse.org/bugs/buglist.cgi?quicksearch=gtk+2. 18
>
> The bug
> https://bugs.eclipse.org/bugs/buglist.cgi?quicksearch=gtk+2. 18
> describes a workaround, but I have no clue whether it really helps.
>
> HTH
>
> Michael
Previous Topic:eclipse 3.0 FAQ code examples
Next Topic:Adding external jars to a plug-in properly
Goto Forum:
  


Current Time: Wed Aug 10 21:28:08 GMT 2022

Powered by FUDForum. Page generated in 0.03283 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top