Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Version 1.6.0_65 of the JVM is not suitable for this product. Version: 1.7 or greater is required.
Version 1.6.0_65 of the JVM is not suitable for this product. Version: 1.7 or greater is required. [message #1398868] Fri, 11 July 2014 18:24 Go to next message
Prakash Jethwani is currently offline Prakash JethwaniFriend
Messages: 1
Registered: July 2014
Junior Member
If you get error when launching Eclipse:::: "Version 1.6.0_65 of the JVM is not suitable for this product. Version: 1.7 or greater is required."

***********Go and install latest JDK from Oracle website (Not from Java website).***********

Steps:-
1 - Make sure you have installed 64 bit Eclipse
2 - Go to : oracle.xxx/technetwork/java/javase/downloads/
3 - Accept License Agreement
4 - Install appropriate Java SE Development Kit

Note: For my MAC I installed:
- Java SE Development Kit 7u60 > jdk-7u60-macosx-x64.dmg
Re: Version 1.6.0_65 of the JVM is not suitable for this product. Version: 1.7 or greater is require [message #1727812 is a reply to message #1398868] Sun, 27 March 2016 23:07 Go to previous messageGo to next message
George Barz is currently offline George BarzFriend
Messages: 2
Registered: March 2016
Junior Member
posts like this one is why most people find this site useless. first of all, try the url provided. work for you? me neither. now, after you find the correct url and download what might be the correct version from an innumerable number of "mirrors", whatever the %^&& they are, and after running the oracle version check and verifying that you do in fact have the latest and greatest version of Java, trying installing Eclipse. Did you get the same error? me too.

simply installing Eclipse shouldn't be this #$%^ hard. What a waste of time.
Re: Version 1.6.0_65 of the JVM is not suitable for this product. Version: 1.7 or greater is require [message #1727853 is a reply to message #1727812] Mon, 28 March 2016 15:08 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
You are responding to a message that's approaching 2 years old, written by a user who has no other messages (so not exactly an authority on the subject). And in a forum group (Equinox) that isn't very active and not geared for newcomers or Eclipse beginners anyway.

Have you looked at the messages in the Newcomers forum? The issue with Java on Mac has been discussed there several times in the past couple of months. Here's one such thread: https://www.eclipse.org/forums/index.php/t/1073452/

By the way, in the instructions above, what you probably overlooked is the difference between JRE and JDK. The JRE on latest versions of OS X is screwed, and Eclipse requires the JDK in order to run on them.
Re: Version 1.6.0_65 of the JVM is not suitable for this product. Version: 1.7 or greater is require [message #1727969 is a reply to message #1727853] Tue, 29 March 2016 23:29 Go to previous message
George Barz is currently offline George BarzFriend
Messages: 2
Registered: March 2016
Junior Member
Thank you sir. That is useful. Much appreciated.
Previous Topic:Eclipsecon06 OSGi tutorials
Next Topic:Galileo - No action found for: addRepository.
Goto Forum:
  


Current Time: Wed Dec 19 06:36:51 GMT 2018

Powered by FUDForum. Page generated in 0.02207 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top