Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Cannot Install New Tomcat 7 Server After Removing It(Kepler Tomcat 7)
Cannot Install New Tomcat 7 Server After Removing It [message #1067761] Wed, 10 July 2013 13:23 Go to next message
Kevin Schulke is currently offline Kevin SchulkeFriend
Messages: 4
Registered: July 2013
Junior Member
I am experiencing a problem with adding a New Tomcat 7 Server with Eclipse Kepler after removing a Tomcat 7 Server instance. I am using Kepler Build:20130614-0229 running on Fedora 18. I executed these steps to create new Server in Eclipse after removing a prior instance:

1. Click Server tab
2. Click link to create new server
3. Highlight Tomcat v7.0 Server

Server host name is set to localhost
Server name is blank

Next> button is not active. Only Cancel button is available.

If I selected Tomcat v6.0 Server, the server host name is localhost and server name is populated. Next> button is active.

I was able to add the Tomcat 6 instance successfully using these steps. However, I noticed that cannot add a second instance of Tomcat 6. I experience the same issue when trying to add a Tomcat 7 instance.

I attempted to correct this issue by applying a fix that worked in Juno:

1. Close Eclipse
2. In {workspace-directory}/.metadata/.plugins/org.eclipse.core.runtime/.settings delete the following two files:
org.eclipse.wst.server.core.prefs
org.eclipse.jst.server.tomcat.core.prefs
3. Restart Eclipse

But, this fix did not work.

Any suggestions on how to get this working again properly?



Kevin Schulke
Re: Cannot Install New Tomcat 7 Server After Removing It [message #1068066 is a reply to message #1067761] Thu, 11 July 2013 21:45 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1311
Registered: July 2009
Senior Member
On 7/10/2013 9:23 AM, Kevin Schulke wrote:
> I am experiencing a problem with adding a New Tomcat 7 Server with
> Eclipse Kepler after removing a Tomcat 7 Server instance. I am using
> Kepler Build:20130614-0229 running on Fedora 18. I executed these steps
> to create new Server in Eclipse after removing a prior instance:
>
> 1. Click Server tab
> 2. Click link to create new server
> 3. Highlight Tomcat v7.0 Server
>
> Server host name is set to localhost
> Server name is blank
>
> Next> button is not active. Only Cancel button is available.
>
> If I selected Tomcat v6.0 Server, the server host name is localhost and
> server name is populated. Next> button is active.
>
> I was able to add the Tomcat 6 instance successfully using these steps.
> However, I noticed that cannot add a second instance of Tomcat 6. I
> experience the same issue when trying to add a Tomcat 7 instance.
>
> I attempted to correct this issue by applying a fix that worked in Juno:
>
> 1. Close Eclipse
> 2. In
> {workspace-directory}/.metadata/.plugins/org.eclipse.core.runtime/.settings
> delete the following two files:
> org.eclipse.wst.server.core.prefs
> org.eclipse.jst.server.tomcat.core.prefs
> 3. Restart Eclipse
>
> But, this fix did not work.
> Any suggestions on how to get this working again properly?
>
>

Is the Tomcat 7 being used a Tomcat installed by Fedora or a binary
download from tomcat.apache.org? If installed by Fedora, do you
encounter this behavior with a binary download of Tomcat?

Also, is there anything related in the Error Log view?

Cheers,
Larry
Re: Cannot Install New Tomcat 7 Server After Removing It [message #1069311 is a reply to message #1068066] Mon, 15 July 2013 16:39 Go to previous messageGo to next message
Kevin Schulke is currently offline Kevin SchulkeFriend
Messages: 4
Registered: July 2013
Junior Member
Larry Isaacs wrote on Thu, 11 July 2013 17:45
On 7/10/2013 9:23 AM, Kevin Schulke wrote:
> I am experiencing a problem with adding a New Tomcat 7 Server with
> Eclipse Kepler after removing a Tomcat 7 Server instance. I am using
> Kepler Build:20130614-0229 running on Fedora 18. I executed these steps
> to create new Server in Eclipse after removing a prior instance:
>
> 1. Click Server tab
> 2. Click link to create new server
> 3. Highlight Tomcat v7.0 Server
>
> Server host name is set to localhost
> Server name is blank
>
> Next> button is not active. Only Cancel button is available.
>
> If I selected Tomcat v6.0 Server, the server host name is localhost and
> server name is populated. Next> button is active.
>
> I was able to add the Tomcat 6 instance successfully using these steps.
> However, I noticed that cannot add a second instance of Tomcat 6. I
> experience the same issue when trying to add a Tomcat 7 instance.
>
> I attempted to correct this issue by applying a fix that worked in Juno:
>
> 1. Close Eclipse
> 2. In
> {workspace-directory}/.metadata/.plugins/org.eclipse.core.runtime/.settings
> delete the following two files:
> org.eclipse.wst.server.core.prefs
> org.eclipse.jst.server.tomcat.core.prefs
> 3. Restart Eclipse
>
> But, this fix did not work.
> Any suggestions on how to get this working again properly?
>
>

Is the Tomcat 7 being used a Tomcat installed by Fedora or a binary
download from tomcat.apache.org? If installed by Fedora, do you
encounter this behavior with a binary download of Tomcat?

Also, is there anything related in the Error Log view?

Cheers,
Larry


I am using the binary downloaded from Apache. I installed both version 6 and 7 into the /opt directory.

Thanks,
Kevin


Kevin Schulke
Re: Cannot Install New Tomcat 7 Server After Removing It [message #1069322 is a reply to message #1069311] Mon, 15 July 2013 17:06 Go to previous messageGo to next message
Kevin Schulke is currently offline Kevin SchulkeFriend
Messages: 4
Registered: July 2013
Junior Member
I believe that the installation of Tomcat 7 in /opt was corrupted or I did not have the proper permissions when I installed it.

I installed Tomcat 7 in my user home directory and configured Eclipse Server to point to this location instead of the /opt location. Then, I was able to get the server reconfigured and working.

Thanks for asking your questions. It made me think of an alternative way of setting it up.

Kevin Schulke



Kevin Schulke
Re: Cannot Install New Tomcat 7 Server After Removing It [message #1118162 is a reply to message #1069322] Fri, 27 September 2013 05:56 Go to previous message
Rekha D is currently offline Rekha DFriend
Messages: 1
Registered: September 2013
Junior Member
Can you please help me by specifying the steps you used for " configured Eclipse server to point to this location instead of the /opt location"
Previous Topic:Tomcat Server - ${catalina.base}/lib
Next Topic:HTML editor and its graphical view
Goto Forum:
  


Current Time: Wed Dec 17 19:54:57 GMT 2014

Powered by FUDForum. Page generated in 0.01749 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software