Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » "Selection does not contain a main type" error
"Selection does not contain a main type" error [message #1059501] Mon, 20 May 2013 03:25 Go to next message
Jared Beckham is currently offline Jared Beckham
Messages: 1
Registered: May 2013
Junior Member
Hey guys, so I think this is a pretty common error from searching through the forums, but it seems like everyone has it for a different reason and I can't quite make sense of some of the solutions.

Basically I'm working through a java textbook and I had eclipse working perfectly for the past 2 weeks or so but I started it up today and can't get anything to run. Before, when it was working, I could just hit ctrl+F11 and it would run the program, but now it prompts me to select a java applet or java application when I try to run my programs, and neither option successfully runs the program. Attached is an image of my setup with my code and the error.

index.php/fa/14966/0/

How can I get eclipse to run my programs again?

Thanks!
Re: "Selection does not contain a main type" error [message #1059760 is a reply to message #1059501] Tue, 21 May 2013 14:28 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2254
Registered: July 2009
Senior Member
Java is a case sensitive language. Your "main" method name has to be lowercase.

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: "Selection does not contain a main type" error [message #1085515 is a reply to message #1059760] Tue, 13 August 2013 02:25 Go to previous messageGo to next message
soran sorany is currently offline soran sorany
Messages: 1
Registered: August 2013
Junior Member
hellow , i have same problem did you find any thing new ????
Re: "Selection does not contain a main type" error [message #1201048 is a reply to message #1059501] Thu, 21 November 2013 14:54 Go to previous message
vn nb is currently offline vn nb
Messages: 1
Registered: November 2013
Junior Member
I got same problem, when I modify argument of the main method, ...main(String arg[])...
Not ...main(String[] arg)...
It works.

Previous Topic:Eclipse Juno Update crashes
Next Topic:iserver usage report
Goto Forum:
  


Current Time: Wed Sep 03 00:01:09 GMT 2014

Powered by FUDForum. Page generated in 0.04947 seconds