Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Which is the latest Xulrunner version supported in SWT version X ?
Which is the latest Xulrunner version supported in SWT version X ? [message #915419] Mon, 17 September 2012 08:29 Go to next message
Mickael Istria is currently offline Mickael IstriaFriend
Messages: 771
Registered: July 2009
Location: Grenoble, France
Senior Member
Hi all,

I'm just wondering if there is a place where we can find a kind of
"compatibility matrix" between SWT and XulRunner version?

What is the latest XulRunner version supported in Eclipse 3.6,3.7, 3.8,
4.2...?
Which ones of these XulRuneer versions have support for
maxosx,Cocoa,64-bits?
Is there a place where we could get some pre-built bundles for these
XulRunner on all platforms ?

Thanks in advance.
--
Mickael Istria
JBoss, by Red Hat
My blog: http://mickaelistria.wordpress.com
My Tweets: http://twitter.com/mickaelistria
Re: Which is the latest Xulrunner version supported in SWT version X ? [message #915529 is a reply to message #915419] Mon, 17 September 2012 13:17 Go to previous messageGo to next message
Lakshmi ShanmugamFriend
Messages: 274
Registered: July 2009
Location: India
Senior Member
Hi,

Please see this link for the supported Xulrunner and SWT versions --> http://eclipse.org/swt/faq.php#browserlinux

The Xulrunner versions for different platforms can be downloaded from mozilla.org --> http://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/


Lakshmi P Shanmugam
Re: Which is the latest Xulrunner version supported in SWT version X ? [message #915595 is a reply to message #915529] Mon, 17 September 2012 15:50 Go to previous messageGo to next message
Mickael Istria is currently offline Mickael IstriaFriend
Messages: 771
Registered: July 2009
Location: Grenoble, France
Senior Member
On 09/17/2012 03:17 PM, Lakshmi Shanmugam wrote:
> Please see this link for the supported Xulrunner and SWT versions -->
> http://eclipse.org/swt/faq.php#browserlinux

Thanks

> The Xulrunner versions for different platforms can be downloaded from
> mozilla.org --> http://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/

I'm a bit confused with these xulrunner builds... Is there a build
available for Cocoa 64-bits which is supported by SWT ?
(2-years-old) comment from
https://bugs.eclipse.org/bugs/show_bug.cgi?id=274197 say that there is
not XulRunner build available for MacOSX 64-bits that can work with
Eclipse. Is it still the case?
--
Mickael Istria
JBoss, by Red Hat
My blog: http://mickaelistria.wordpress.com
My Tweets: http://twitter.com/mickaelistria
Re: Which is the latest Xulrunner version supported in SWT version X ? [message #915713 is a reply to message #915595] Mon, 17 September 2012 20:26 Go to previous messageGo to next message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2151
Registered: July 2009
Senior Member
On 9/17/2012 11:50 AM, Mickael Istria wrote:
> I'm a bit confused with these xulrunner builds... Is there a build
> available for Cocoa 64-bits which is supported by SWT ?
> (2-years-old) comment from
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=274197 say that there is
> not XulRunner build available for MacOSX 64-bits that can work with
> Eclipse. Is it still the case?

Correct, there isn't a XULRunner for Cocoa x86_64 from mozilla.org. At
the time of that report it seemed that there would be one, probably
based on newsgroup discussions, so a 64-bit XULRunner was built locally
from source and a 64-bit swt library compiled against it. This is why
swt's Cocoa x86_64 fragment contains a xulrunner library, which in
theory should still work if mozilla.org ever starts building XULRunner
for this arch. However at this point in time they don't.

Grant
Re: Which is the latest Xulrunner version supported in SWT version X ? [message #915920 is a reply to message #915713] Tue, 18 September 2012 08:03 Go to previous messageGo to next message
Mickael Istria is currently offline Mickael IstriaFriend
Messages: 771
Registered: July 2009
Location: Grenoble, France
Senior Member
On 09/17/2012 10:27 PM, Grant Gayed wrote:
> Correct, there isn't a XULRunner for Cocoa x86_64 from mozilla.org. At
> the time of that report it seemed that there would be one, probably
> based on newsgroup discussions, so a 64-bit XULRunner was built locally
> from source and a 64-bit swt library compiled against it. This is why
> swt's Cocoa x86_64 fragment contains a xulrunner library, which in
> theory should still work if mozilla.org ever starts building XULRunner
> for this arch. However at this point in time they don't.

Ok thanks. Last question: can you please tell me what's the version of
XulRunner provided by default as part of platform-specific SWT fragments?

--
Mickael Istria
JBoss, by Red Hat
My blog: http://mickaelistria.wordpress.com
My Tweets: http://twitter.com/mickaelistria
Re: Which is the latest Xulrunner version supported in SWT version X ? [message #915973 is a reply to message #915713] Tue, 18 September 2012 10:34 Go to previous messageGo to next message
Yahor Radtsevich is currently offline Yahor RadtsevichFriend
Messages: 1
Registered: July 2009
Junior Member
Grant Gayed wrote on Mon, 17 September 2012 16:26
Cocoa x86_64 fragment contains a xulrunner library...

Do you mean that this fragment contains a library providing xulrunner support, but not xulrunner itself?
Re: Which is the latest Xulrunner version supported in SWT version X ? [message #916855 is a reply to message #915973] Wed, 19 September 2012 14:55 Go to previous messageGo to next message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2151
Registered: July 2009
Senior Member
Yes, all of the platform fragments are like this, SWT/Eclipse never
ships XULRunner itself. If a XULRunner installation with version < 2 is
detected on the user's machine then a mozilla-based Browser can use it.
In order to use a newer XULRunner version than this (currently
restricted to XULRunner 10.x) an app must ship the XULRunner binary and
explicitly point at it as described in
http://www.eclipse.org/swt/faq.php#specifyxulrunner .

Grant


On 9/18/2012 6:34 AM, Yahor Radtsevich wrote:
> Grant Gayed wrote on Mon, 17 September 2012 16:26
>> Cocoa x86_64 fragment contains a xulrunner library...
>
> Do you mean that this fragment contains a library providing xulrunner
> support, but not xulrunner itself?
Re: Which is the latest Xulrunner version supported in SWT version X ? [message #916856 is a reply to message #915920] Wed, 19 September 2012 14:57 Go to previous message
Grant Gayed is currently offline Grant GayedFriend
Messages: 2151
Registered: July 2009
Senior Member
See my other reply in this thread to Yahor.

Grant


On 9/18/2012 4:03 AM, Mickael Istria wrote:
> On 09/17/2012 10:27 PM, Grant Gayed wrote:
>> Correct, there isn't a XULRunner for Cocoa x86_64 from mozilla.org. At
>> the time of that report it seemed that there would be one, probably
>> based on newsgroup discussions, so a 64-bit XULRunner was built locally
>> from source and a 64-bit swt library compiled against it. This is why
>> swt's Cocoa x86_64 fragment contains a xulrunner library, which in
>> theory should still work if mozilla.org ever starts building XULRunner
>> for this arch. However at this point in time they don't.
>
> Ok thanks. Last question: can you please tell me what's the version of
> XulRunner provided by default as part of platform-specific SWT fragments?
>
Previous Topic:osx - leopard (no(t) snow) - eclipse 3.5.1 JavaTimeZoneError
Next Topic:issue with org.eclipse.swt.dnd.TextTransfer DND on Linux
Goto Forum:
  


Current Time: Sun Dec 21 08:36:53 GMT 2014

Powered by FUDForum. Page generated in 0.01825 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software