Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » New 3.7.2 fails to download core bundles, inexplicable MD5 errors from all mirrors
New 3.7.2 fails to download core bundles, inexplicable MD5 errors from all mirrors [message #889993] Wed, 20 June 2012 09:53 Go to next message
Tom Chiverton is currently offline Tom Chiverton
Messages: 26
Registered: August 2010
Junior Member
My newly installed Eclipse 3.7.2 (WinXP, latest Java) is failing to apply updates to several core modules, after spending an hour or two downloading (from every mirror according to the urls that flash by in the progress dialogue) it eventually stops with an alert saying:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.javascript, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Retry another mirror
Problems downloading artifact: osgi.bundle,org.eclipse.jem,2.0.501.v201111030500.
MD5 hash is not as expected. Expected: 1ef870387ede77efcaa8b70c1b444f14 and found 1ed523a1897832e31d3efd9459ab0504.
Retry another mirror
Problems downloading artifact: osgi.bundle,org.eclipse.jst.common.annotations.controller,1.1.300.v200908252030.
MD5 hash is not as expected. Expected: 3b1e08d826e36a0e9cc1c0a0c5645c8a and found 609d67ec72177d9d9d639841169da145.
Problems downloading artifact: osgi.bundle,org.eclipse.jst.common.annotations.core,1.1.300.v201004141630.
MD5 hash is not as expected. Expected: 352612e228dad6a2cfceb6abbff1dd77 and found 61cec0116ad9dd09c0bcc48a1c62f555.
Retry another mirror
Problems downloading artifact: osgi.bundle,org.eclipse.jst.common.frameworks,1.1.501.v201201190400.
MD5 hash is not as expected. Expected: 77fb059f49f9d91458c2e54a626e0c5c and found 2e568e9d0ff9b5b6b44fba28b4a18d08.
Problems downloading artifact: osgi.bundle,org.eclipse.jst.j2ee.jca,1.1.501.v201111030500.
MD5 hash is not as expected. Expected: ea25329f627bfc1619104f6a39c7f782 and found 26249dafb85a6525c74be654083024f2.
Problems downloading artifact: osgi.bundle,org.eclipse.jst.jee,1.0.402.v201202021530.
MD5 hash is not as expected. Expected: 46c76eeebcf7f69d5b26c0fa8172f31a and found 1c4c229d797626e4d1bf91abf5743261.
Retry another mirror
Problems downloading artifact: osgi.bundle,org.jsoup,1.6.1.v201201201356.
MD5 hash is not as expected. Expected: 2e1abf82e472ccb18f704a79b8aeae97 and found 3423d90e8ab8dbe4d53882926e1ad633.


I don't believe this is my network's problem, as I don't get random corruption to other downloads.
Restating Eclipse doesn't seem to have helped.

[Updated on: Wed, 20 June 2012 11:03]

Report message to a moderator

Re: New 3.7.2 fails to download core bundles, inexplicable MD5 errors from all mirrors [message #890260 is a reply to message #889993] Thu, 21 June 2012 12:04 Go to previous messageGo to next message
Tom Chiverton is currently offline Tom Chiverton
Messages: 26
Registered: August 2010
Junior Member
Am I asking in the wrong place ?
Re: New 3.7.2 fails to download core bundles, inexplicable MD5 errors from all mirrors [message #890640 is a reply to message #890260] Fri, 22 June 2012 14:29 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de Alwis
Messages: 242
Registered: July 2009
Senior Member
Hi Tom.

You're not asking in the wrong place, but you haven't provided enough information for anybody to recreate your problem. Which Eclipse intallation are you using? What action did you do? (e.g.,Help > Check for Updates?) Are you behind a firewall? (Just because you can download from a browser doesn't mean other programs aren't affected.) Is there anything in your error log?

My immediate reaction upon reading your description is that it's unlikely to be a problem within p2: you're using a heavily tested very of Eclipse and doing updates against a popular publicly released package, something that's done by thousands of people a day. If there were issues in p2, there would have been a lot of chatter about it by now. But I haven't seen any other reports about experiencing errors on IRC or other bug reports.

My guess: you either hit a bad mirror or you have a misbehaving proxy. Try running Eclipse with -Declipse.p2.mirrors=false and see if that rectifies the situation. And check your .metadata/.log to see if the was any useful information logged there.

Brian.
Re: New 3.7.2 fails to download core bundles, inexplicable MD5 errors from all mirrors [message #892575 is a reply to message #890640] Thu, 28 June 2012 12:11 Go to previous messageGo to next message
Tom Chiverton is currently offline Tom Chiverton
Messages: 26
Registered: August 2010
Junior Member
Help, check for updates, or via install new software and pick a single new module (such as the SVN integration for Mylyn from Tigris).

There is a firewall here, but I can request the files given in the error message directly from my web browser fine.

With the mirrors off I still see it trying all sorts of mirror-ish looking domain names in the progress window. eclupse.cu.de eclipse.ialto.com etc.

Log attached.
  • Attachment: log.txt
    (Size: 49.79KB, Downloaded 121 times)
Re: New 3.7.2 fails to download core bundles, inexplicable MD5 errors from all mirrors [message #892681 is a reply to message #892575] Fri, 29 June 2012 03:52 Go to previous messageGo to next message
Tom Chiverton is currently offline Tom Chiverton
Messages: 26
Registered: August 2010
Junior Member
Correction, I hadn't added the no mirror option in the right place.

Here is the output in the popup window with no mirrors:
An error occurred while collecting items to be installed
session context was:(profile=epp.package.javascript, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at hXXp:\\market.eclipsesource.com/dist/.sitestore/c5/c5de464ae8829be2b6eaa002701a23b7/../../../../artifacts/plugins/org.eclipse.jem_2.0.501.v201111030500.jar.
The server market.eclipsesource.com failed to respond
Unable to read repository at hXXp:\\market.eclipsesource.com/dist/.sitestore/c5/c5de464ae8829be2b6eaa002701a23b7/../../../../artifacts/plugins/org.eclipse.jst.common.annotations.controller_1.1.300.v200908252030.jar.
The server market.eclipsesource.com failed to respond
Unable to read repository at hXXp:\\market.eclipsesource.com/dist/.sitestore/c5/c5de464ae8829be2b6eaa002701a23b7/../../../../artifacts/plugins/org.eclipse.jst.common.annotations.core_1.1.300.v201004141630.jar.
The server market.eclipsesource.com failed to respond
Unable to read repository at hXXp:\\market.eclipsesource.com/dist/.sitestore/c5/c5de464ae8829be2b6eaa002701a23b7/../../../../artifacts/plugins/org.eclipse.jst.common.frameworks_1.1.501.v201201190400.jar.
The server market.eclipsesource.com failed to respond
Unable to read repository at hXXp:\\market.eclipsesource.com/dist/.sitestore/c5/c5de464ae8829be2b6eaa002701a23b7/../../../../artifacts/plugins/org.eclipse.jst.j2ee.jca_1.1.501.v201111030500.jar.
The server market.eclipsesource.com failed to respond
Unable to read repository at hXXp:\\market.eclipsesource.com/dist/.sitestore/c5/c5de464ae8829be2b6eaa002701a23b7/../../../../artifacts/plugins/org.eclipse.jst.jee_1.0.402.v201202021530.jar.
The server market.eclipsesource.com failed to respond
Problems downloading artifact: org.eclipse.update.feature,org.tigris.subversion.subclipse.mylyn,3.0.0.
MD5 hash is not as expected. Expected: 97f80726c9b2209104ccf83d4a82562f and found eb39ee474daf667aa90882e98485b1ae.


The log says
!SUBENTRY 1 org.eclipse.equinox.p2.transport.ecf 4 1002 2012-06-28 17:16:00.722
!MESSAGE Unable to read repository at hXXp:\\market.eclipsesource.com/dist/.sitestore/c5/c5de464ae8829be2b6eaa002701a23b7/../../../../artifacts/plugins/org.eclipse.jst.jee_1.0.402.v201202021530.jar.
!STACK 0
org.apache.commons.httpclient.NoHttpResponseException: The server market.eclipsesource.com failed to respond
	at org.apache.commons.httpclient.HttpMethodBase.readStatusLine(HttpMethodBase.java:1976)
	at org.apache.commons.httpclient.HttpMethodBase.readResponse(HttpMethodBase.java:1735)
	at org.apache.commons.httpclient.HttpMethodBase.execute(HttpMethodBase.java:1098)
	at org.eclipse.ecf.provider.filetransfer.httpclient.HttpClientRetrieveFileTransfer$GzipGetMethod.execute(HttpClientRetrieveFileTransfer.java:117)
	at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:398)
	at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
	at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
	at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
	at org.eclipse.ecf.provider.filetransfer.httpclient.HttpClientRetrieveFileTransfer.performConnect(HttpClientRetrieveFileTransfer.java:1142)
	at org.eclipse.ecf.provider.filetransfer.httpclient.HttpClientRetrieveFileTransfer.openStreams(HttpClientRetrieveFileTransfer.java:710)
	at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer.sendRetrieveRequest(AbstractRetrieveFileTransfer.java:889)
	at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer.sendRetrieveRequest(AbstractRetrieveFileTransfer.java:576)
	at org.eclipse.ecf.provider.filetransfer.retrieve.MultiProtocolRetrieveAdapter.sendRetrieveRequest(MultiProtocolRetrieveAdapter.java:106)
	at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.sendRetrieveRequest(FileReader.java:349)
	at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.readInto(FileReader.java:295)
	at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryTransport.download(RepositoryTransport.java:87)
	at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryTransport.download(RepositoryTransport.java:137)
	at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(SimpleArtifactRepository.java:625)
	at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(SimpleArtifactRepository.java:569)
	at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(SimpleArtifactRepository.java:680)
	at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.getArtifact(MirrorRequest.java:260)
	at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transferSingle(MirrorRequest.java:235)
	at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transfer(MirrorRequest.java:191)
	at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.perform(MirrorRequest.java:122)
	at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(SimpleArtifactRepository.java:664)
	at org.eclipse.equinox.internal.p2.artifact.repository.simple.DownloadJob.run(DownloadJob.java:63)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2012-06-28 17:16:00.722
!MESSAGE Problems downloading artifact: org.eclipse.update.feature,org.tigris.subversion.subclipse.mylyn,3.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 4 1203 2012-06-28 17:16:00.722
!MESSAGE MD5 hash is not as expected. Expected: 97f80726c9b2209104ccf83d4a82562f and found eb39ee474daf667aa90882e98485b1ae.


Is there a way to download these by hand and put them in the cache directory ? Where is that so I can check the hash by hand ?
Re: New 3.7.2 fails to download core bundles, inexplicable MD5 errors from all mirrors [message #892686 is a reply to message #892681] Fri, 29 June 2012 04:22 Go to previous message
Tom Chiverton is currently offline Tom Chiverton
Messages: 26
Registered: August 2010
Junior Member
Follow up: based on the URLs (why is it using Marketplace to download standard parts of Eclipse) I found two repositories in the list that matched that I do not recall adding by hand "hXXp://market.eclipsesource.com/yoxos/mpc/latestrepo/org.tigris.subversion.subclipse.feature.group/3.7.0.v20110110/" and "hXXp://market.eclipsesource.com/yoxos/mpc/latestrepo/org.tigris.subversion.subclipse.mylyn.feature.group/3.7.0.v20110110/". The name of both is 'Yoxos Custom Repository' which doesn't seem as have it would really have anything to do with Subclipse.

If I disable those, then install and update work fine.
Previous Topic:Update Site Projects & other plugins
Next Topic:Juno vs. p2
Goto Forum:
  


Current Time: Wed Jul 30 01:05:02 EDT 2014

Powered by FUDForum. Page generated in 0.02226 seconds