Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Disable XML Comment Autocompletion(How do I disable XML comment autocompletion?)
Disable XML Comment Autocompletion [message #504805] Tue, 22 December 2009 18:47 Go to next message
Dan Forward is currently offline Dan ForwardFriend
Messages: 2
Registered: July 2009
Junior Member
This is a major annoyance. I want to comment out some XML code, so I begin typing <!-- and the editor immediately appends " -->" with my cursor in the middle.

I then have to press Delete four times and Backspace once to get rid of it so I can place the closing tag where it belongs at the end of the XML block.

I tried modifying the XML comment template, unchecking it, and turning Auto Insert off, but the behavior remains. How do I turn off or modify this behavior?
Re: Disable XML Comment Autocompletion [message #505356 is a reply to message #504805] Tue, 29 December 2009 22:34 Go to previous messageGo to next message
David Carver is currently offline David CarverFriend
Messages: 174
Registered: July 2009
Senior Member
You can turn off comment autocompletion by going to:

Preferences->XML Files->Editor->Typing.

Uncheck the check box that says Automatically close "Comments".

Re: Disable XML Comment Autocompletion [message #505358 is a reply to message #505356] Tue, 29 December 2009 22:51 Go to previous message
Dan Forward is currently offline Dan ForwardFriend
Messages: 2
Registered: July 2009
Junior Member
Thank you! That is exactly what I needed.
Previous Topic:Contribution of enhancements and bug fixes to the Web Page Editor
Next Topic:JSPs throwing incorrect compiler warnings
Goto Forum:
  


Current Time: Mon Nov 24 20:21:36 GMT 2014

Powered by FUDForum. Page generated in 0.02412 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software