Skip to main content
October Donation Campaign Donate Now

Incompatibilities between Eclipse JDT 3.8 and 3.9 (Kepler)

Eclipse changed in incompatible ways between 3.8 and 3.9 in ways that affect JDT plug-ins. The following entries describe the areas that changed and provide instructions for migrating 3.8 plug-ins to 3.9. Note that you only need to look here if you are experiencing problems compiling or running your 3.8 plug-in on 3.9.

  1. SDK ships only one org.junit plug-in (4.11)

1. SDK ships only one org.junit plug-in (4.11)

What is affected: Clients that require the org.junit4 bundle, or org.junit with an upper version bound

Description: The org.junit bundle has been updated to JUnit 4.11. The org.junit4 compatibility bundle has been removed, and org.junit version 3.8.2 is no longer shipped with the Eclipse SDK. Note that JUnit 4 still contains the JUnit 3 APIs. If you need org.junit_3.8.2 back for whatever reason, you can still get it from Orbit.

Action required: Clients that require org.junit4 should switch over to org.junit. Your Require-Bundle: entries should just point to org.junit;bundle-version="4.11.0" (or an earlier version, if you like).

Back to the top