tycho-p2-extras:compare-version-with-baselines

Full name:

org.eclipse.tycho.extras:tycho-p2-extras-plugin:1.4.0:compare-version-with-baselines

Description:

This mojo compares versions the output artifacts of your module build with the version of the same artifacts available in configured baselines, in order to detect version inconsistencies (version moved back, or not correctly bumped since last release). Rules for "illegal" versions are:
  • version decreased compared to baseline
  • same fully-qualified version as baseline, but with different binary content
  • same major.minor.micro as baseline, with different qualifier (at least micro should be increased)
  • This mojo doesn't allow to use qualifier as a versioning segment and will most likely drive to false-positive errors if your qualifier has means to show versioniterations.

Attributes:

Optional Parameters

Name Type Since Description
<baselines> List - A list of p2 repositories to be used as baseline. Those are typically the most recent released versions of your project.
User property is: baselines.
<onIllegalVersion> CompareWithBaselineMojo$ReportBehavior - (no description)
Default value is: fail.
User property is: onIllegalVersion.
<skip> boolean - (no description)
User property is: skip.

Parameter Details

<baselines>

A list of p2 repositories to be used as baseline. Those are typically the most recent released versions of your project.
  • Type: java.util.List
  • Required: No
  • User Property: baselines

<onIllegalVersion>

(no description)
  • Type: org.eclipse.tycho.plugins.p2.extras.CompareWithBaselineMojo$ReportBehavior
  • Required: No
  • User Property: onIllegalVersion
  • Default: fail

<skip>

(no description)
  • Type: boolean
  • Required: No
  • User Property: skip