Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » EGit update site broken?
Re: EGit update site broken? [SOLVED] [message #1780975 is a reply to message #1780929] Tue, 30 January 2018 18:00 Go to previous message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 384
Registered: March 2011
Senior Member
Hi Ed.

I know now what is causing the problem.

First, I noticed that it was not just the EGit repo, but also, rather worryingly with http://download.eclipse.org/eclipse/updates/4.7. For reference I'm attaching the full error log (running with -console -consoleLog -debug).

I ruled out a network issue because I tried on two different networks and got the same result.

The issue seems to be with user privileges. On macOS, aside from "standard" and "admin" users, there is a third kind: "managed". The error occurs on "managed" user accounts. As to why exactly that causes the error, what kind of restrictions does this "managed" account imposes on p2, I don't know. So I think one has to assume that Eclipse cannot be updated on "managed" accounts.

Thanks for your help.



  • Attachment: error_log.txt
    (Size: 53.41KB, Downloaded 145 times)
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:p2 bundle pools and caching
Next Topic:Problem building oomph
Goto Forum:
  


Current Time: Fri Apr 03 02:15:36 GMT 2020

Powered by FUDForum. Page generated in 0.07531 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top