Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » headless build "forgets" native swt plugins for linux
headless build "forgets" native swt plugins for linux [message #29232] Fri, 24 October 2008 08:54 Go to next message
Tobias Hoppenthaler is currently offline Tobias HoppenthalerFriend
Messages: 21
Registered: July 2009
Junior Member
Hi there,

I succeeded in getting a headless build of my software by following this
guide:
http://rcpquickstart.com/2007/06/06/getting-started-with-pde -build/
So the build succeeds, but when I start my application (gtk,linux,x86) I
get the error message:

"An error has occurred. See the log file
/home/tobias/emulator/configuration/1224837580357.log."

In the logfile I got this

Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.SWTError
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl assInternal(BundleLoader.java:481)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:397)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:385)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:87)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319 )
... 71 more

and some more. So I copied the linux native swt plugins in the plugin
folder of the resulting build and added them in the config.ini and voilá,
it worked fine.

Since I am not willing to do that every time - since I actually wanted to
have a fully automatic build, I'd love to hear another opinion - or even
better - a solution to that. The funny thing is: the Windows build works
perfectly! Every plugin is copied right. I tried to build from both
platforms - windows and linux, but both showed the same behavior.

Please help! Cheers,

Tobias
Re: headless build "forgets" native swt plugins for linux [message #31209 is a reply to message #29232] Wed, 05 November 2008 11:29 Go to previous message
Tobias Hoppenthaler is currently offline Tobias HoppenthalerFriend
Messages: 21
Registered: July 2009
Junior Member
I just got it working. In the preferences for the target platform in
Eclipse I unchecked the "Build target platform based on the target's
installed plug-ins" and then hit the "add required plug-ins" button in
the product-file on the configuration tab. After that everything
worked like a charm.
Re: headless build "forgets" native swt plugins for linux [message #584315 is a reply to message #29232] Wed, 05 November 2008 11:29 Go to previous message
Tobias Hoppenthaler is currently offline Tobias HoppenthalerFriend
Messages: 21
Registered: July 2009
Junior Member
I just got it working. In the preferences for the target platform in
Eclipse I unchecked the "Build target platform based on the target's
installed plug-ins" and then hit the "add required plug-ins" button in
the product-file on the configuration tab. After that everything
worked like a charm.
Previous Topic:Extensions and Extension Points
Next Topic:What is the most efficient way to debug plug-ins?
Goto Forum:
  


Current Time: Fri Sep 24 22:14:04 GMT 2021

Powered by FUDForum. Page generated in 0.02490 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top