Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EMFCompare, Edapt] Install different versions
[EMFCompare, Edapt] Install different versions [message #1507399] Thu, 11 December 2014 15:46 Go to next message
Hauke Fuhrmann is currently offline Hauke FuhrmannFriend
Messages: 333
Registered: July 2009
Senior Member
Hi there,

I try to install EMFCompare v3 and Edapt 1. I get the error below. I
assume that Edapt uses an earlier version of EMFCompare.

It seems that differen versions of EMFCompare core cannot be installed
at the same time. Why is that a problem? I thought this is all the
purpose of OSGi and Eclipse using plugins which can be made in different
versions in the same installation. Any solution?

Cheers,
Hauke

Cannot complete the install because of a conflicting dependency.
Software being installed: EMF Compare SDK 1.3.2.v20120918-1125
(org.eclipse.emf.compare.sdk.feature.group 1.3.2.v20120918-1125)
Software currently installed: Edapt Recorder Feature
1.0.0.201411071217 (org.eclipse.emf.edapt.recorder.feature.feature.group
1.0.0.201411071217)
Only one of the following can be installed at once:
EMF Compare core 1.2.1.v20110913-0926 (org.eclipse.emf.compare
1.2.1.v20110913-0926)
EMF Compare core 1.1.0.v201006150400 (org.eclipse.emf.compare
1.1.0.v201006150400)
EMF Compare core 1.3.2.v20120918-1125 (org.eclipse.emf.compare
1.3.2.v20120918-1125)
EMF Compare core 1.0.1.v200909161031 (org.eclipse.emf.compare
1.0.1.v200909161031)
EMF Compare core 1.2.2.v20120214-0915 (org.eclipse.emf.compare
1.2.2.v20120214-0915)
EMF Compare core 1.2.0.v20110607-2028 (org.eclipse.emf.compare
1.2.0.v20110607-2028)
EMF Compare core 1.3.1.v20120605-0748 (org.eclipse.emf.compare
1.3.1.v20120605-0748)
EMF Compare Core 2.0.0.201209121410 (org.eclipse.emf.compare
2.0.0.201209121410)
EMF Compare core 1.0.0.v200906220949 (org.eclipse.emf.compare
1.0.0.v200906220949)
EMF Compare core 1.1.1.v201009150438 (org.eclipse.emf.compare
1.1.1.v201009150438)
EMF Compare Core 3.0.1.201309031318 (org.eclipse.emf.compare
3.0.1.201309031318)
Cannot satisfy dependency:
From: EMF Compare 1.3.2.v20120918-1125
(org.eclipse.emf.compare.feature.group 1.3.2.v20120918-1125)
To: org.eclipse.emf.compare [1.3.2.v20120918-1125]
Cannot satisfy dependency:
From: EMF Compare SDK 1.3.2.v20120918-1125
(org.eclipse.emf.compare.sdk.feature.group 1.3.2.v20120918-1125)
To: org.eclipse.emf.compare.feature.group [1.3.2.v20120918-1125]
Cannot satisfy dependency:
From: Edapt History Edit Support 1.0.0.201411071217
(org.eclipse.emf.edapt.history.edit 1.0.0.201411071217)
To: bundle org.eclipse.emf.compare [3.0.0,4.0.0)
Cannot satisfy dependency:
From: Edapt Recorder Feature 1.0.0.201411071217
(org.eclipse.emf.edapt.recorder.feature.feature.group 1.0.0.201411071217)
To: org.eclipse.emf.edapt.history.edit [1.0.0.201411071217]
Re: [EMFCompare, Edapt] Install different versions [message #1512260 is a reply to message #1507399] Mon, 15 December 2014 15:55 Go to previous messageGo to next message
Johannes Faltermeier is currently offline Johannes FaltermeierFriend
Messages: 96
Registered: December 2013
Member

Hi Hauke,

It seems that you are trying to install EMFCompare 1.3 instead of 3.
Edapt and EMFCompare 3 can be installed in the same IDE.

Best regards
Johannes

Hauke Fuhrmann wrote on Thu, 11 December 2014 15:46
Hi there,

I try to install EMFCompare v3 and Edapt 1. I get the error below. I
assume that Edapt uses an earlier version of EMFCompare.

It seems that differen versions of EMFCompare core cannot be installed
at the same time. Why is that a problem? I thought this is all the
purpose of OSGi and Eclipse using plugins which can be made in different
versions in the same installation. Any solution?

Cheers,
Hauke

Cannot complete the install because of a conflicting dependency.
Software being installed: EMF Compare SDK 1.3.2.v20120918-1125
(org.eclipse.emf.compare.sdk.feature.group 1.3.2.v20120918-1125)
Software currently installed: Edapt Recorder Feature
1.0.0.201411071217 (org.eclipse.emf.edapt.recorder.feature.feature.group
1.0.0.201411071217)
Only one of the following can be installed at once:
EMF Compare core 1.2.1.v20110913-0926 (org.eclipse.emf.compare
1.2.1.v20110913-0926)
EMF Compare core 1.1.0.v201006150400 (org.eclipse.emf.compare
1.1.0.v201006150400)
EMF Compare core 1.3.2.v20120918-1125 (org.eclipse.emf.compare
1.3.2.v20120918-1125)
EMF Compare core 1.0.1.v200909161031 (org.eclipse.emf.compare
1.0.1.v200909161031)
EMF Compare core 1.2.2.v20120214-0915 (org.eclipse.emf.compare
1.2.2.v20120214-0915)
EMF Compare core 1.2.0.v20110607-2028 (org.eclipse.emf.compare
1.2.0.v20110607-2028)
EMF Compare core 1.3.1.v20120605-0748 (org.eclipse.emf.compare
1.3.1.v20120605-0748)
EMF Compare Core 2.0.0.201209121410 (org.eclipse.emf.compare
2.0.0.201209121410)
EMF Compare core 1.0.0.v200906220949 (org.eclipse.emf.compare
1.0.0.v200906220949)
EMF Compare core 1.1.1.v201009150438 (org.eclipse.emf.compare
1.1.1.v201009150438)
EMF Compare Core 3.0.1.201309031318 (org.eclipse.emf.compare
3.0.1.201309031318)
Cannot satisfy dependency:
From: EMF Compare 1.3.2.v20120918-1125
(org.eclipse.emf.compare.feature.group 1.3.2.v20120918-1125)
To: org.eclipse.emf.compare [1.3.2.v20120918-1125]
Cannot satisfy dependency:
From: EMF Compare SDK 1.3.2.v20120918-1125
(org.eclipse.emf.compare.sdk.feature.group 1.3.2.v20120918-1125)
To: org.eclipse.emf.compare.feature.group [1.3.2.v20120918-1125]
Cannot satisfy dependency:
From: Edapt History Edit Support 1.0.0.201411071217
(org.eclipse.emf.edapt.history.edit 1.0.0.201411071217)
To: bundle org.eclipse.emf.compare [3.0.0,4.0.0)
Cannot satisfy dependency:
From: Edapt Recorder Feature 1.0.0.201411071217
(org.eclipse.emf.edapt.recorder.feature.feature.group 1.0.0.201411071217)
To: org.eclipse.emf.edapt.history.edit [1.0.0.201411071217]



Johannes Faltermeier

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: [EMFCompare, Edapt] Install different versions [message #1513099 is a reply to message #1512260] Tue, 16 December 2014 08:11 Go to previous messageGo to next message
Hauke Fuhrmann is currently offline Hauke FuhrmannFriend
Messages: 333
Registered: July 2009
Senior Member
Hi Johannes,

no, I'm installing EMF Compare in Eclipse Luna via the Eclipse
Marketplace, which states that it is EMF Compare 3, which I'm installing.
The wizard shows that it installs from
http://download.eclipse.org/modeling/emf/compare/updates/releases the
feature "EMF Compare SDK" from the category "EMF compare: model
comparison and merge 3.0". If this feature contains older version
numbers, there is something wrong with the marketplace/updatesite.

I tried to install manually via update site
http://download.eclipse.org/modeling/emf/compare/updates/releases/latest

From the update site it works fine. So there must be some issue with
the marketplace?

Cheers,
Hauke

Am 15.12.2014 16:55, schrieb Johannes Faltermeier:
> Hi Hauke,
> It seems that you are trying to install EMFCompare 1.3 instead of 3.
> Edapt and EMFCompare 3 can be installed in the same IDE.
> Best regards
> Johannes
>
> Hauke Fuhrmann wrote on Thu, 11 December 2014 15:46
>> Hi there,
>>
>> I try to install EMFCompare v3 and Edapt 1. I get the error below. I
>> assume that Edapt uses an earlier version of EMFCompare.
>>
>> It seems that differen versions of EMFCompare core cannot be installed
>> at the same time. Why is that a problem? I thought this is all the
>> purpose of OSGi and Eclipse using plugins which can be made in
>> different versions in the same installation. Any solution?
>>
>> Cheers,
>> Hauke
>>
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: EMF Compare SDK 1.3.2.v20120918-1125
>> (org.eclipse.emf.compare.sdk.feature.group 1.3.2.v20120918-1125)
>> Software currently installed: Edapt Recorder Feature
>> 1.0.0.201411071217
>> (org.eclipse.emf.edapt.recorder.feature.feature.group 1.0.0.201411071217)
>> Only one of the following can be installed at once:
>> EMF Compare core 1.2.1.v20110913-0926 (org.eclipse.emf.compare
>> 1.2.1.v20110913-0926)
>> EMF Compare core 1.1.0.v201006150400 (org.eclipse.emf.compare
>> 1.1.0.v201006150400)
>> EMF Compare core 1.3.2.v20120918-1125 (org.eclipse.emf.compare
>> 1.3.2.v20120918-1125)
>> EMF Compare core 1.0.1.v200909161031 (org.eclipse.emf.compare
>> 1.0.1.v200909161031)
>> EMF Compare core 1.2.2.v20120214-0915 (org.eclipse.emf.compare
>> 1.2.2.v20120214-0915)
>> EMF Compare core 1.2.0.v20110607-2028 (org.eclipse.emf.compare
>> 1.2.0.v20110607-2028)
>> EMF Compare core 1.3.1.v20120605-0748 (org.eclipse.emf.compare
>> 1.3.1.v20120605-0748)
>> EMF Compare Core 2.0.0.201209121410 (org.eclipse.emf.compare
>> 2.0.0.201209121410)
>> EMF Compare core 1.0.0.v200906220949 (org.eclipse.emf.compare
>> 1.0.0.v200906220949)
>> EMF Compare core 1.1.1.v201009150438 (org.eclipse.emf.compare
>> 1.1.1.v201009150438)
>> EMF Compare Core 3.0.1.201309031318 (org.eclipse.emf.compare
>> 3.0.1.201309031318)
>> Cannot satisfy dependency:
>> From: EMF Compare 1.3.2.v20120918-1125
>> (org.eclipse.emf.compare.feature.group 1.3.2.v20120918-1125)
>> To: org.eclipse.emf.compare [1.3.2.v20120918-1125]
>> Cannot satisfy dependency:
>> From: EMF Compare SDK 1.3.2.v20120918-1125
>> (org.eclipse.emf.compare.sdk.feature.group 1.3.2.v20120918-1125)
>> To: org.eclipse.emf.compare.feature.group [1.3.2.v20120918-1125]
>> Cannot satisfy dependency:
>> From: Edapt History Edit Support 1.0.0.201411071217
>> (org.eclipse.emf.edapt.history.edit 1.0.0.201411071217)
>> To: bundle org.eclipse.emf.compare [3.0.0,4.0.0)
>> Cannot satisfy dependency:
>> From: Edapt Recorder Feature 1.0.0.201411071217
>> (org.eclipse.emf.edapt.recorder.feature.feature.group 1.0.0.201411071217)
>> To: org.eclipse.emf.edapt.history.edit [1.0.0.201411071217]
>
>
Re: [EMFCompare, Edapt] Install different versions [message #1514709 is a reply to message #1507399] Wed, 17 December 2014 14:31 Go to previous message
Mikael Barbero is currently offline Mikael BarberoFriend
Messages: 55
Registered: July 2009
Member
Hi Hauke,

I'm the project lead of EMF Compare. Sorry about the mistake. The marketplace were referencing the wrong feature id (one that was existing only in 1.3 and before) so the marketpalce was always trying to install version 1.3.

I fixed the issue and you should now be able to install it properly.

Sorry for the disturbance and thank you for having raised the issue.


Best regards,

Mikael Barbero
Obeo
Previous Topic:[Edapt] support of xcore ?
Next Topic:[EMF Forms] JavaFX sample application ?
Goto Forum:
  


Current Time: Sun May 24 23:40:18 GMT 2020

Powered by FUDForum. Page generated in 0.02009 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top