Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » svn subclipse password issue
icon9.gif  svn subclipse password issue [message #1498479] Thu, 04 December 2014 12:38 Go to next message
Ben Ward is currently offline Ben WardFriend
Messages: 1
Registered: December 2014
Junior Member
Hello,

I've been using eclipse for my PHP developments for a few months now and I've finally got around to getting some proper source control.

There is an issue though Sad every single thing I do in repository explorer prompts me for my svn password even though I ticked the save password box.

Software versions as below;

Eclipse: Kepler Service Release 2 Build id: 20140224-0627
Subversion JavaHL v1.8.8 (from the tigris project)
PDT 3.2.0.201306051924
Subclipse 1.10.4
Subversion client adapter 1.10.1
Windows Version 6.1 (Build 7601: Service Pack 1) (AKA Window 7 Pro SP1)

I've tried deleting the %APPDATA%\Subversion\auth\* files. There's no .keyring file to delete and manually adding a proxy bypass to the svn server.

I've been googling for ages and have found no solution. The only clue I have found is an error message in the .metadata workspace logfile suggesting that there's a problem with the equinox security plugin:
!MESSAGE Unable to locate secure storage module (org.eclipse.equinox.security.windowspasswordprovider).

at org.eclipse.equinox.internal.security.storage.PasswordProviderSelector.findStorageModule(PasswordProviderSelector.java:190)


This may be entirely unrelated though...

I've been messing with this for well over an hour now and I'm starting to loose the will.

Any ideas?

Many Thanks
Ben
Re: svn subclipse password issue [message #1500696 is a reply to message #1498479] Sat, 06 December 2014 05:38 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3799
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 12/04/2014 05:53 AM, Ben Ward wrote:
> Hello,
>
> I've been using eclipse for my PHP developments for a few months now and
> I've finally got around to getting some proper source control.
>
> There is an issue though :( every single thing I do in repository
> explorer prompts me for my svn password even though I ticked the save
> password box.
>
> Software versions as below;
>
> Eclipse: Kepler Service Release 2 Build id: 20140224-0627
> Subversion JavaHL v1.8.8 (from the tigris project)
> PDT 3.2.0.201306051924
> Subclipse 1.10.4
> Subversion client adapter 1.10.1
> Windows Version 6.1 (Build 7601: Service Pack 1) (AKA Window 7 Pro SP1)
>
> I've tried deleting the %APPDATA%\Subversion\auth\* files. There's no
> .keyring file to delete and manually adding a proxy bypass to the svn
> server.
>
> I've been googling for ages and have found no solution. The only clue I
> have found is an error message in the .metadata workspace logfile
> suggesting that there's a problem with the equinox security plugin:
>
> !MESSAGE Unable to locate secure storage module
> (org.eclipse.equinox.security.windowspasswordprovider).
>
> at
> org.eclipse.equinox.internal.security.storage.PasswordProviderSelector.findStorageModule(PasswordProviderSelector.java:190)
>
>
> This may be entirely unrelated though...
> I've been messing with this for well over an hour now and I'm starting
> to loose the will.
>
> Any ideas?
>
> Many Thanks
> Ben


Frankly, I don't want to make your life more difficult by suggesting
your shift gears, but Subversion is more than a bit passé.

Eclipse integrates Git now and you can easily set up numerous free and
private repositories using bitbucket.com. It's pretty painless; you
don't have to create and manage your own Subversion server. I know about
this because I did it for years.

Think about upgrading Eclipse to Luna (although I think Git integration
began in Kepler). The way I see it now, Git is Eclipse's primary
version-control system. There's also an Eclipse forum dedicated to Git
questions.

Git will also give you access to many open source projects and
collaboration.

http://www.vogella.com/tutorials/EclipseGit/article.html

Hope this helps. At least it's something to think about.
Re: svn subclipse password issue [message #1700313 is a reply to message #1498479] Wed, 01 July 2015 17:54 Go to previous message
Dan Pride is currently offline Dan PrideFriend
Messages: 1
Registered: July 2015
Junior Member
I had the exact same experience, many times. Finally after 8 solid days of fighting with xdebug configuration on Luna, I punted. THANK GOD I DID. I took a look at PhpStorm. It was so beautiful I wanted to cry. Eclipse Php should be removed from the market. There is no comparison. Thanks to the guys who did php eclipse, for a long time it was the only real IDE on the market that was worth anything. It was a tremendous help for years. But With the advances in PhpStorm, and the insane config issues that waste so much of peoples time it is really better to just remove this thing from the market. Had it been done already, i would have saved 8 of the most horrible screaming cursing days I have had in many years as a programmmer
Previous Topic:eclipse wont start
Next Topic:Reviving an old project
Goto Forum:
  


Current Time: Thu Aug 22 07:34:04 GMT 2019

Powered by FUDForum. Page generated in 0.03015 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top