Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Eclipse Luna EE Plug In Project Tutorial Help(can not right click in extension tab. )
Eclipse Luna EE Plug In Project Tutorial Help [message #1480929] Thu, 20 November 2014 16:04 Go to next message
Gary Mottl is currently offline Gary MottlFriend
Messages: 3
Registered: October 2014
Junior Member
i was doing the tutorial this morning when i got to the create a new category section and trouble hit. i was able to add org.eclipse.ui.view when i couldn't right click to create a new category or a new view.

i also got this message in the console.

!SESSION 2014-11-20 08:41:17.606 -----------------------------------------------
eclipse.buildId=4.4.1.M20140925-0400
java.version=1.8.0_25
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.platform.ide
Command-line arguments: -product org.eclipse.platform.ide -data C:\Users\gary\workspace/../runtime-EclipseApplication -dev file:C:/Users/gary/workspace/.metadata/.plugins/org.eclipse.pde.core/Eclipse Application/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog

!ENTRY org.eclipse.egit.ui 2 0 2014-11-20 08:41:39.394
!MESSAGE Warning: EGit couldn't detect the installation path "gitPrefix" of native Git. Hence EGit can't respect system level
Git settings which might be configured in ${gitPrefix}/etc/gitconfig under the native Git installation directory.
The most important of these settings is core.autocrlf. Git for Windows by default sets this parameter to true in
this system level configuration. The Git installation location can be configured on the
Team > Git > Configuration preference page's 'System Settings' tab.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

!ENTRY org.eclipse.egit.ui 2 0 2014-11-20 08:41:39.394
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: 'C:\Users\gary'. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

this worked in the standard edition but i was told to switch to EE because of the better options included. this is really frustrating can someone help me please.
Re: Eclipse Luna EE Plug In Project Tutorial Help [message #1482083 is a reply to message #1480929] Fri, 21 November 2014 13:22 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 360
Registered: July 2009
Location: Japan
Senior Member
>i was doing the tutorial this morning when i got to the create a new category section and trouble hit. i was able to add org.eclipse.ui.view when i couldn't right click to create a new category or a new view.

This is because JEE package is lacking the Platform SDK. (there is "Eclipse Platform Plug-in Developer Resources" in Eclipse IDE for Eclipse Committers(former Eclipse Standard), but not in Eclipse IDE for Java EE Developers.)
You can solve this bug by installing it manually from "The Eclipse Project Updates" site. (Help->Install New Software->choose "The Eclipse Project Updates"->uncheck "Group items by category"->select "Eclipse Platform Plug-in Developer Resources")

(for EGit warnings, they are just warnings and have no relation to this problem)

--
https://www.eclipse.org/forums/index.php/t/796235/
http://blog.goo.ne.jp/atlanto/e/486d016e352493980051e68dd9e8b3e6
Re: Eclipse Luna EE Plug In Project Tutorial Help [message #1482257 is a reply to message #1482083] Fri, 21 November 2014 16:24 Go to previous message
Gary Mottl is currently offline Gary MottlFriend
Messages: 3
Registered: October 2014
Junior Member
thank you. i installed the update an it fixed the problem. quick question, there were other updates listed. would you recommend downloading them too or would that be a problem. i'm still very new to this.
Previous Topic:Developing a Plugin and test it
Next Topic:Code for New->Java Project
Goto Forum:
  


Current Time: Wed Oct 16 16:56:33 GMT 2019

Powered by FUDForum. Page generated in 0.02728 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top