Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Unable to launch sample E4 application
icon5.gif  Unable to launch sample E4 application [message #1462528] Wed, 05 November 2014 17:23 Go to next message
Romain Larvet is currently offline Romain LarvetFriend
Messages: 2
Registered: November 2014
Location: France
Junior Member
Hello,

I'm new to E4 and I'm trying to create a new application.

I tried to follow this tutorial : vogella.com/tutorials/EclipseRCP/article.html#tutorial_e4wizard, which makes you create a default sample E4 application and launch it.

When I do this, I get compilation errors in the project created by the wizard and I can't launch it.

Here is one of the first errors : The import org.eclipse.e4.core cannot be resolved
Eclipse cannot find any annotation or class from e4 packages.

I'm working with Eclipse Luna under Ubuntu, and I installed E4 Tools from the stable build 0.16 repository : http://download.eclipse.org/e4/downloads/drops/S-0.16-201408072200/repository/

Can you tell me what is wrong and how I can fix it?
Re: Unable to launch sample E4 application [message #1463887 is a reply to message #1462528] Fri, 07 November 2014 01:49 Go to previous messageGo to next message
Gary Bradshaw is currently offline Gary BradshawFriend
Messages: 4
Registered: November 2014
Junior Member
Is org.eclipse.e4.core listed on the Dependencies tab?
Re: Unable to launch sample E4 application [message #1464178 is a reply to message #1463887] Fri, 07 November 2014 09:06 Go to previous message
Romain Larvet is currently offline Romain LarvetFriend
Messages: 2
Registered: November 2014
Location: France
Junior Member
Hi,

I found what caused the problem : I had another project in the same workspace, defining its own target platform. I tried to create the new application in a new workspace and it worked.

Thanks for your answer, you made me find the solution
Previous Topic:Handlers for default eclipse commands with the compatibility layer
Next Topic:ComboBoxViewerCellEditor TroubleShoot
Goto Forum:
  


Current Time: Wed Mar 03 15:20:08 GMT 2021

Powered by FUDForum. Page generated in 0.01764 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top