Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » SOLVED: Eclipse keeps asking for passphrase (even when entered)
SOLVED: Eclipse keeps asking for passphrase (even when entered) [message #1462262] Wed, 05 November 2014 11:36 Go to next message
Martijn vE is currently offline Martijn vEFriend
Messages: 2
Registered: November 2014
Location: Netherlands
Junior Member
I set up Eclipse with git over SSH a while ago. I use public key authorization and stored the Passphrase in the Secure Storage. From that moment on I only had to enter the Secure Storage once every session and could push and pull without any further questions for my passphrase.

Yesterday the remote repository was moved to a different server. I forgot to add my public key to the authorized keys on the server so I could not log in at first. So I added the key again on the server, but now I keep getting a popup window saying:
"Provide information for ssh://user@server:22
Passphrase for /home/martijn/.ssh/id_rsa"

(Of course user and server are an actual username and hostname.)

If I enter the correct passphrase, I get the same window again, and again, and again.....
If I click cancel, I get either the question to enter the password for the Secure Storage (if it's the first time in the session) or the Push/Pull action is executed.

So I can work on by just clicking cancel every time, but my questions are: why am I gettting this popup and how can I get rid of it.

Eclipse version: 3.7.2
Egit version: 1.3

Thanks in advance for any help

[Updated on: Wed, 05 November 2014 14:44]

Report message to a moderator

Re: Eclipse keeps asking for passphrase (even when entered) [message #1462342 is a reply to message #1462262] Wed, 05 November 2014 13:27 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1093
Registered: July 2009
Senior Member
EGit 1.3 is no longer maintained, the latest EGit release is 3.5.1 and can be installed from http://download.eclipse.org/egit/updates
Re: Eclipse keeps asking for passphrase (even when entered) [message #1462403 is a reply to message #1462342] Wed, 05 November 2014 14:43 Go to previous messageGo to next message
Martijn vE is currently offline Martijn vEFriend
Messages: 2
Registered: November 2014
Location: Netherlands
Junior Member
I was unable to install Egit 3.5 in Indigo. So I had to move from the Ubuntu 12.04 respository version to a manual installation. I now have Luna with Egit 3.5.

I still get the popup, but when I now enter my password it works and I don't have to enter it again. But I don't get the Secure Storage password window either.

Anyway, this works for me. I just hope Luna isn't buggier than the Indigo I had before. I'm not really fond of Java applications anyway, but there's no serious (free) alternative to Eclipse as far as I can tell.
Re: Eclipse keeps asking for passphrase (even when entered) [message #1463381 is a reply to message #1462403] Thu, 06 November 2014 14:06 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1093
Registered: July 2009
Senior Member
Looks like we'll get support for ssh-agent https://bugs.eclipse.org/bugs/show_bug.cgi?id=179924
Previous Topic:Working with git clone but on remote server
Next Topic:When is the staging view updated?
Goto Forum:
  


Current Time: Sun Sep 15 08:07:16 GMT 2019

Powered by FUDForum. Page generated in 0.02519 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top