Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Preview tab is missing
Preview tab is missing [message #262652] Tue, 04 December 2007 20:37 Go to next message
Eclipse UserFriend
Originally posted by: rainer.home.de

I have installed eclipse from deb and then downloaded birt with the
eclipse updater. When I create a birt project and a report, the preview
tab is missing. The .log file:

eclipse.buildId=M20060921-0945
java.version=1.6.0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=de_DE
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 2 1 2007-12-04 20:22:15.316
!MESSAGE NLS missing message: initializer_error in:
org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 2 1 2007-12-04 20:22:15.317
!MESSAGE NLS missing message: fileInitializer_fileNotFound in:
org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 2 1 2007-12-04 20:22:15.317
!MESSAGE NLS missing message: fileInitializer_IOError in:
org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 2 1 2007-12-04 20:22:15.317
!MESSAGE NLS missing message: fileInitializer_missingFileName in:
org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.ui 4 4 2007-12-04 20:22:22.174
!MESSAGE Unable to associate action set with part:
org.eclipse.birt.report.designer.ui.editors.ReportEditor. Action set
org.eclipse.birt.report.designer.ui.previewActionSet not found.


My configuration:

- Debian Testing
- Eclipse 3.2.0
- Birt 2.1.2
Re: Preview tab is missing [message #262658 is a reply to message #262652] Tue, 04 December 2007 21:01 Go to previous messageGo to next message
Snjezana Peco is currently offline Snjezana PecoFriend
Messages: 789
Registered: July 2009
Senior Member
The preview tab is defined in the
org.eclipse.birt.report.designer.ui.preview plugin.
You don't have this plugin or it is broken.

Snjeza

Rainer wrote:
> I have installed eclipse from deb and then downloaded birt with the
> eclipse updater. When I create a birt project and a report, the preview
> tab is missing. The .log file:
>
> eclipse.buildId=M20060921-0945
> java.version=1.6.0
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=de_DE
> Command-line arguments: -os linux -ws gtk -arch x86
>
> !ENTRY org.eclipse.osgi 2 1 2007-12-04 20:22:15.316
> !MESSAGE NLS missing message: initializer_error in:
> org.eclipse.core.internal.runtime.messages
>
> !ENTRY org.eclipse.osgi 2 1 2007-12-04 20:22:15.317
> !MESSAGE NLS missing message: fileInitializer_fileNotFound in:
> org.eclipse.core.internal.runtime.messages
>
> !ENTRY org.eclipse.osgi 2 1 2007-12-04 20:22:15.317
> !MESSAGE NLS missing message: fileInitializer_IOError in:
> org.eclipse.core.internal.runtime.messages
>
> !ENTRY org.eclipse.osgi 2 1 2007-12-04 20:22:15.317
> !MESSAGE NLS missing message: fileInitializer_missingFileName in:
> org.eclipse.core.internal.runtime.messages
>
> !ENTRY org.eclipse.ui 4 4 2007-12-04 20:22:22.174
> !MESSAGE Unable to associate action set with part:
> org.eclipse.birt.report.designer.ui.editors.ReportEditor. Action set
> org.eclipse.birt.report.designer.ui.previewActionSet not found.
>
>
> My configuration:
>
> - Debian Testing
> - Eclipse 3.2.0 - Birt 2.1.2
>
>
>
Re: Preview tab is missing [message #1389141 is a reply to message #262658] Fri, 27 June 2014 11:52 Go to previous messageGo to next message
José Litux is currently offline José LituxFriend
Messages: 52
Registered: March 2013
Member
Hi

same issue here. Preview tab is missing. Installed twice.

any other suggestion?

regards
Re: Preview tab is missing [message #1389223 is a reply to message #1389141] Fri, 27 June 2014 14:03 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

José,

What version are you using? If the latest verions, 4.4, I believe the preview tab has been removed in favor of the normal output options from the toolbar. Let me know.



Michael

Developer Evangelist, Silanis
Re: Preview tab is missing [message #1389359 is a reply to message #1389223] Fri, 27 June 2014 17:46 Go to previous messageGo to next message
José Litux is currently offline José LituxFriend
Messages: 52
Registered: March 2013
Member
Hi

I'm using Eclipse Luna.


Regards
Re: Preview tab is missing [message #1389602 is a reply to message #1389359] Sat, 28 June 2014 02:55 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Yep. In Luna, the Preview tab was removed. This was done in favor of the toolbar option. Adding to this, the best way to test your designs how they'll actually look is to use an external browser so you can test across the different browsers. To set this up, go to Window -> Preference -> Report Design -> Preview. On the preview window, select the "use external browser" check box. To specify which browser you want to use, you can navigate to the web browser section under the general tab or by clicking the link below the checkbox. Hope this helps.

Michael

Developer Evangelist, Silanis
Re: Preview tab is missing [message #1390889 is a reply to message #1389602] Mon, 30 June 2014 06:18 Go to previous messageGo to next message
José Litux is currently offline José LituxFriend
Messages: 52
Registered: March 2013
Member
Hi Michael


so, the correct way to preview is....
Re: Preview tab is missing [message #1390918 is a reply to message #1390889] Mon, 30 June 2014 07:20 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Use the "View Report" drop down in the toolbar to select the output to preview in. The old preview tab was just a straight html output, so if you liked that preview, choose HTML from the drop down list.



Michael

Developer Evangelist, Silanis
Re: Preview tab is missing [message #1798568 is a reply to message #1390918] Tue, 20 November 2018 13:35 Go to previous message
Angelo Endaya is currently offline Angelo EndayaFriend
Messages: 1
Registered: November 2018
Junior Member
Yes you are right, its from the tool bar View Report
Previous Topic:Access Dataset Result in Script
Next Topic:"dataSetRow" is not defined
Goto Forum:
  


Current Time: Sat Dec 14 03:27:28 GMT 2019

Powered by FUDForum. Page generated in 0.02043 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top