Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Riena » Wrong service implementation used since 1.1.0M7
Wrong service implementation used since 1.1.0M7 [message #25856] Wed, 13 May 2009 05:41 Go to next message
Carsten Spieker is currently offline Carsten SpiekerFriend
Messages: 197
Registered: July 2009
Senior Member
Hi,

since I switched to Riena 1.1.0M7 I have problems with my own implementation
of IPermissionStore.

I implemented IPermissionStore in my own bundle and registered it with
service.ranking=0 (since riena services are registered with
service.ranking=-100). My bundle and the bundle
org.eclipse.riena.security.simpleServices are both ACTIVE on server side.
When checking services in the OSGi Management agent I can see that the
service implementation of org.eclipse.riena.security.simpleServices is used
and not mine. Because of that my IPermissionStore implementation is not used
when checking user rights using Sentinel-class.

What can be wrong here? With 1.1.0M6 everything worked fine.

Thanks a lot!

Greetz,
Carsten
Re: Wrong service implementation used since 1.1.0M7 [message #25898 is a reply to message #25856] Wed, 13 May 2009 06:32 Go to previous messageGo to next message
Carsten Spieker is currently offline Carsten SpiekerFriend
Messages: 197
Registered: July 2009
Senior Member
This is the information shown in OSGi Management Agent:

<agent-output>

{org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=0,
service.id=70}
Registered by bundle: com.pa.eai.spieker.authentication_1.0.0.qualifier
[14]
No bundles using service.

....

{org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=-100,
service.id=76}
Registered by bundle: org.eclipse.riena.security.simpleservices_1.1.0.M7
[36]
Bundles using service:
org.eclipse.riena.security.services_1.1.0.M7 [34]

</agent-output>

Greetz,
Carsten


"Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
news:gudmhe$avr$1@build.eclipse.org...
> Hi,
>
> since I switched to Riena 1.1.0M7 I have problems with my own
> implementation of IPermissionStore.
>
> I implemented IPermissionStore in my own bundle and registered it with
> service.ranking=0 (since riena services are registered with
> service.ranking=-100). My bundle and the bundle
> org.eclipse.riena.security.simpleServices are both ACTIVE on server side.
> When checking services in the OSGi Management agent I can see that the
> service implementation of org.eclipse.riena.security.simpleServices is
> used and not mine. Because of that my IPermissionStore implementation is
> not used when checking user rights using Sentinel-class.
>
> What can be wrong here? With 1.1.0M6 everything worked fine.
>
> Thanks a lot!
>
> Greetz,
> Carsten
>
Re: Wrong service implementation used since 1.1.0M7 [message #26184 is a reply to message #25898] Mon, 18 May 2009 04:52 Go to previous messageGo to next message
Carsten Spieker is currently offline Carsten SpiekerFriend
Messages: 197
Registered: July 2009
Senior Member
Does not anyone have the same problem with 1.1.0M7 or any idea?

Thanks a lot!
Carsten

"Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
news:gudpi2$6jl$1@build.eclipse.org...
> This is the information shown in OSGi Management Agent:
>
> <agent-output>
>
> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=0,
> service.id=70}
> Registered by bundle: com.pa.eai.spieker.authentication_1.0.0.qualifier
> [14]
> No bundles using service.
>
> ...
>
> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=-100,
> service.id=76}
> Registered by bundle: org.eclipse.riena.security.simpleservices_1.1.0.M7
> [36]
> Bundles using service:
> org.eclipse.riena.security.services_1.1.0.M7 [34]
>
> </agent-output>
>
> Greetz,
> Carsten
>
>
> "Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
> news:gudmhe$avr$1@build.eclipse.org...
>> Hi,
>>
>> since I switched to Riena 1.1.0M7 I have problems with my own
>> implementation of IPermissionStore.
>>
>> I implemented IPermissionStore in my own bundle and registered it with
>> service.ranking=0 (since riena services are registered with
>> service.ranking=-100). My bundle and the bundle
>> org.eclipse.riena.security.simpleServices are both ACTIVE on server side.
>> When checking services in the OSGi Management agent I can see that the
>> service implementation of org.eclipse.riena.security.simpleServices is
>> used and not mine. Because of that my IPermissionStore implementation is
>> not used when checking user rights using Sentinel-class.
>>
>> What can be wrong here? With 1.1.0M6 everything worked fine.
>>
>> Thanks a lot!
>>
>> Greetz,
>> Carsten
>>
>
>
Re: Wrong service implementation used since 1.1.0M7 [message #26265 is a reply to message #26184] Mon, 18 May 2009 13:35 Go to previous messageGo to next message
Christian Campo is currently offline Christian CampoFriend
Messages: 597
Registered: July 2009
Senior Member
Hi Carsten,

I am sorry that I am coming back to late. We are really in a little bit of stress with the Galileo Release. What you
describe sounds like a bug. Please dont hesitate and file a bug report if you find something like this. And then we will
look into the problem.

Looks very strange indeed. However the bundle org.eclipse.riena.security.simpleservices is not meant for production or a
real system. Its the intentention that you simply not deploy it and only use your own implementations of
IPermissionStore and ISessionStore and LoginModule.

cheers
christian


Carsten Spieker schrieb:
> Does not anyone have the same problem with 1.1.0M7 or any idea?
>
> Thanks a lot!
> Carsten
>
> "Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
> news:gudpi2$6jl$1@build.eclipse.org...
>> This is the information shown in OSGi Management Agent:
>>
>> <agent-output>
>>
>> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=0,
>> service.id=70}
>> Registered by bundle: com.pa.eai.spieker.authentication_1.0.0.qualifier
>> [14]
>> No bundles using service.
>>
>> ...
>>
>> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=-100,
>> service.id=76}
>> Registered by bundle: org.eclipse.riena.security.simpleservices_1.1.0.M7
>> [36]
>> Bundles using service:
>> org.eclipse.riena.security.services_1.1.0.M7 [34]
>>
>> </agent-output>
>>
>> Greetz,
>> Carsten
>>
>>
>> "Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
>> news:gudmhe$avr$1@build.eclipse.org...
>>> Hi,
>>>
>>> since I switched to Riena 1.1.0M7 I have problems with my own
>>> implementation of IPermissionStore.
>>>
>>> I implemented IPermissionStore in my own bundle and registered it with
>>> service.ranking=0 (since riena services are registered with
>>> service.ranking=-100). My bundle and the bundle
>>> org.eclipse.riena.security.simpleServices are both ACTIVE on server side.
>>> When checking services in the OSGi Management agent I can see that the
>>> service implementation of org.eclipse.riena.security.simpleServices is
>>> used and not mine. Because of that my IPermissionStore implementation is
>>> not used when checking user rights using Sentinel-class.
>>>
>>> What can be wrong here? With 1.1.0M6 everything worked fine.
>>>
>>> Thanks a lot!
>>>
>>> Greetz,
>>> Carsten
>>>
>>
>
>
Re: Wrong service implementation used since 1.1.0M7 [message #26380 is a reply to message #26265] Tue, 19 May 2009 06:11 Go to previous message
Carsten Spieker is currently offline Carsten SpiekerFriend
Messages: 197
Registered: July 2009
Senior Member
Hi Christian,

I opened bug 276738.

Greetz,
Carsten


"Christian Campo" <christian.campo@compeople.de> schrieb im Newsbeitrag
news:4A116430.3000207@compeople.de...
> Hi Carsten,
>
> I am sorry that I am coming back to late. We are really in a little bit of
> stress with the Galileo Release. What you describe sounds like a bug.
> Please dont hesitate and file a bug report if you find something like
> this. And then we will look into the problem.
>
> Looks very strange indeed. However the bundle
> org.eclipse.riena.security.simpleservices is not meant for production or a
> real system. Its the intentention that you simply not deploy it and only
> use your own implementations of IPermissionStore and ISessionStore and
> LoginModule.
>
> cheers
> christian
>
>
> Carsten Spieker schrieb:
>> Does not anyone have the same problem with 1.1.0M7 or any idea?
>>
>> Thanks a lot!
>> Carsten
>>
>> "Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
>> news:gudpi2$6jl$1@build.eclipse.org...
>>> This is the information shown in OSGi Management Agent:
>>>
>>> <agent-output>
>>>
>>> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=0,
>>> service.id=70}
>>> Registered by bundle: com.pa.eai.spieker.authentication_1.0.0.qualifier
>>> [14]
>>> No bundles using service.
>>>
>>> ...
>>>
>>> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=-100,
>>> service.id=76}
>>> Registered by bundle:
>>> org.eclipse.riena.security.simpleservices_1.1.0.M7 [36]
>>> Bundles using service:
>>> org.eclipse.riena.security.services_1.1.0.M7 [34]
>>>
>>> </agent-output>
>>>
>>> Greetz,
>>> Carsten
>>>
>>>
>>> "Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
>>> news:gudmhe$avr$1@build.eclipse.org...
>>>> Hi,
>>>>
>>>> since I switched to Riena 1.1.0M7 I have problems with my own
>>>> implementation of IPermissionStore.
>>>>
>>>> I implemented IPermissionStore in my own bundle and registered it with
>>>> service.ranking=0 (since riena services are registered with
>>>> service.ranking=-100). My bundle and the bundle
>>>> org.eclipse.riena.security.simpleServices are both ACTIVE on server
>>>> side. When checking services in the OSGi Management agent I can see
>>>> that the service implementation of
>>>> org.eclipse.riena.security.simpleServices is used and not mine. Because
>>>> of that my IPermissionStore implementation is not used when checking
>>>> user rights using Sentinel-class.
>>>>
>>>> What can be wrong here? With 1.1.0M6 everything worked fine.
>>>>
>>>> Thanks a lot!
>>>>
>>>> Greetz,
>>>> Carsten
>>>>
>>>
>>
Re: Wrong service implementation used since 1.1.0M7 [message #582435 is a reply to message #25856] Wed, 13 May 2009 06:32 Go to previous message
Carsten Spieker is currently offline Carsten SpiekerFriend
Messages: 197
Registered: July 2009
Senior Member
This is the information shown in OSGi Management Agent:

<agent-output>

{org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=0,
service.id=70}
Registered by bundle: com.pa.eai.spieker.authentication_1.0.0.qualifier
[14]
No bundles using service.

....

{org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=-100,
service.id=76}
Registered by bundle: org.eclipse.riena.security.simpleservices_1.1.0.M7
[36]
Bundles using service:
org.eclipse.riena.security.services_1.1.0.M7 [34]

</agent-output>

Greetz,
Carsten


"Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
news:gudmhe$avr$1@build.eclipse.org...
> Hi,
>
> since I switched to Riena 1.1.0M7 I have problems with my own
> implementation of IPermissionStore.
>
> I implemented IPermissionStore in my own bundle and registered it with
> service.ranking=0 (since riena services are registered with
> service.ranking=-100). My bundle and the bundle
> org.eclipse.riena.security.simpleServices are both ACTIVE on server side.
> When checking services in the OSGi Management agent I can see that the
> service implementation of org.eclipse.riena.security.simpleServices is
> used and not mine. Because of that my IPermissionStore implementation is
> not used when checking user rights using Sentinel-class.
>
> What can be wrong here? With 1.1.0M6 everything worked fine.
>
> Thanks a lot!
>
> Greetz,
> Carsten
>
Re: Wrong service implementation used since 1.1.0M7 [message #582560 is a reply to message #25898] Mon, 18 May 2009 04:52 Go to previous message
Carsten Spieker is currently offline Carsten SpiekerFriend
Messages: 197
Registered: July 2009
Senior Member
Does not anyone have the same problem with 1.1.0M7 or any idea?

Thanks a lot!
Carsten

"Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
news:gudpi2$6jl$1@build.eclipse.org...
> This is the information shown in OSGi Management Agent:
>
> <agent-output>
>
> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=0,
> service.id=70}
> Registered by bundle: com.pa.eai.spieker.authentication_1.0.0.qualifier
> [14]
> No bundles using service.
>
> ...
>
> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=-100,
> service.id=76}
> Registered by bundle: org.eclipse.riena.security.simpleservices_1.1.0.M7
> [36]
> Bundles using service:
> org.eclipse.riena.security.services_1.1.0.M7 [34]
>
> </agent-output>
>
> Greetz,
> Carsten
>
>
> "Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
> news:gudmhe$avr$1@build.eclipse.org...
>> Hi,
>>
>> since I switched to Riena 1.1.0M7 I have problems with my own
>> implementation of IPermissionStore.
>>
>> I implemented IPermissionStore in my own bundle and registered it with
>> service.ranking=0 (since riena services are registered with
>> service.ranking=-100). My bundle and the bundle
>> org.eclipse.riena.security.simpleServices are both ACTIVE on server side.
>> When checking services in the OSGi Management agent I can see that the
>> service implementation of org.eclipse.riena.security.simpleServices is
>> used and not mine. Because of that my IPermissionStore implementation is
>> not used when checking user rights using Sentinel-class.
>>
>> What can be wrong here? With 1.1.0M6 everything worked fine.
>>
>> Thanks a lot!
>>
>> Greetz,
>> Carsten
>>
>
>
Re: Wrong service implementation used since 1.1.0M7 [message #582584 is a reply to message #26184] Mon, 18 May 2009 13:35 Go to previous message
Christian Campo is currently offline Christian CampoFriend
Messages: 597
Registered: July 2009
Senior Member
Hi Carsten,

I am sorry that I am coming back to late. We are really in a little bit of stress with the Galileo Release. What you
describe sounds like a bug. Please dont hesitate and file a bug report if you find something like this. And then we will
look into the problem.

Looks very strange indeed. However the bundle org.eclipse.riena.security.simpleservices is not meant for production or a
real system. Its the intentention that you simply not deploy it and only use your own implementations of
IPermissionStore and ISessionStore and LoginModule.

cheers
christian


Carsten Spieker schrieb:
> Does not anyone have the same problem with 1.1.0M7 or any idea?
>
> Thanks a lot!
> Carsten
>
> "Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
> news:gudpi2$6jl$1@build.eclipse.org...
>> This is the information shown in OSGi Management Agent:
>>
>> <agent-output>
>>
>> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=0,
>> service.id=70}
>> Registered by bundle: com.pa.eai.spieker.authentication_1.0.0.qualifier
>> [14]
>> No bundles using service.
>>
>> ...
>>
>> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=-100,
>> service.id=76}
>> Registered by bundle: org.eclipse.riena.security.simpleservices_1.1.0.M7
>> [36]
>> Bundles using service:
>> org.eclipse.riena.security.services_1.1.0.M7 [34]
>>
>> </agent-output>
>>
>> Greetz,
>> Carsten
>>
>>
>> "Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
>> news:gudmhe$avr$1@build.eclipse.org...
>>> Hi,
>>>
>>> since I switched to Riena 1.1.0M7 I have problems with my own
>>> implementation of IPermissionStore.
>>>
>>> I implemented IPermissionStore in my own bundle and registered it with
>>> service.ranking=0 (since riena services are registered with
>>> service.ranking=-100). My bundle and the bundle
>>> org.eclipse.riena.security.simpleServices are both ACTIVE on server side.
>>> When checking services in the OSGi Management agent I can see that the
>>> service implementation of org.eclipse.riena.security.simpleServices is
>>> used and not mine. Because of that my IPermissionStore implementation is
>>> not used when checking user rights using Sentinel-class.
>>>
>>> What can be wrong here? With 1.1.0M6 everything worked fine.
>>>
>>> Thanks a lot!
>>>
>>> Greetz,
>>> Carsten
>>>
>>
>
>
Re: Wrong service implementation used since 1.1.0M7 [message #582627 is a reply to message #26265] Tue, 19 May 2009 06:11 Go to previous message
Carsten Spieker is currently offline Carsten SpiekerFriend
Messages: 197
Registered: July 2009
Senior Member
Hi Christian,

I opened bug 276738.

Greetz,
Carsten


"Christian Campo" <christian.campo@compeople.de> schrieb im Newsbeitrag
news:4A116430.3000207@compeople.de...
> Hi Carsten,
>
> I am sorry that I am coming back to late. We are really in a little bit of
> stress with the Galileo Release. What you describe sounds like a bug.
> Please dont hesitate and file a bug report if you find something like
> this. And then we will look into the problem.
>
> Looks very strange indeed. However the bundle
> org.eclipse.riena.security.simpleservices is not meant for production or a
> real system. Its the intentention that you simply not deploy it and only
> use your own implementations of IPermissionStore and ISessionStore and
> LoginModule.
>
> cheers
> christian
>
>
> Carsten Spieker schrieb:
>> Does not anyone have the same problem with 1.1.0M7 or any idea?
>>
>> Thanks a lot!
>> Carsten
>>
>> "Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
>> news:gudpi2$6jl$1@build.eclipse.org...
>>> This is the information shown in OSGi Management Agent:
>>>
>>> <agent-output>
>>>
>>> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=0,
>>> service.id=70}
>>> Registered by bundle: com.pa.eai.spieker.authentication_1.0.0.qualifier
>>> [14]
>>> No bundles using service.
>>>
>>> ...
>>>
>>> {org.eclipse.riena.security.authorizationservice.IPermission Store}={service.ranking=-100,
>>> service.id=76}
>>> Registered by bundle:
>>> org.eclipse.riena.security.simpleservices_1.1.0.M7 [36]
>>> Bundles using service:
>>> org.eclipse.riena.security.services_1.1.0.M7 [34]
>>>
>>> </agent-output>
>>>
>>> Greetz,
>>> Carsten
>>>
>>>
>>> "Carsten Spieker" <carsten.spieker@d-velop.de> schrieb im Newsbeitrag
>>> news:gudmhe$avr$1@build.eclipse.org...
>>>> Hi,
>>>>
>>>> since I switched to Riena 1.1.0M7 I have problems with my own
>>>> implementation of IPermissionStore.
>>>>
>>>> I implemented IPermissionStore in my own bundle and registered it with
>>>> service.ranking=0 (since riena services are registered with
>>>> service.ranking=-100). My bundle and the bundle
>>>> org.eclipse.riena.security.simpleServices are both ACTIVE on server
>>>> side. When checking services in the OSGi Management agent I can see
>>>> that the service implementation of
>>>> org.eclipse.riena.security.simpleServices is used and not mine. Because
>>>> of that my IPermissionStore implementation is not used when checking
>>>> user rights using Sentinel-class.
>>>>
>>>> What can be wrong here? With 1.1.0M6 everything worked fine.
>>>>
>>>> Thanks a lot!
>>>>
>>>> Greetz,
>>>> Carsten
>>>>
>>>
>>
Previous Topic:where to do the remote service call
Next Topic:RAP Support
Goto Forum:
  


Current Time: Wed Dec 01 22:31:51 GMT 2021

Powered by FUDForum. Page generated in 0.02583 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top