Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to install JCDE on Eclipse 3.8
Unable to install JCDE on Eclipse 3.8 [message #1453348] Sun, 26 October 2014 21:17 Go to next message
adomniac alex is currently offline adomniac alexFriend
Messages: 3
Registered: October 2014
Junior Member
Hello everybody,

I am new to JavaCard technology. I installed Eclipse 3.8 and I try to install JCDE, I'm on Ubuntu 14.04.

I downloaded Java Card Development Kit 2.2.2 and Eclipse Plugin JCDE 0.2.
I extrated eclipse-jcde-0.2.zip into eclipse/plugins. I verified, I have :
org.eclipsejcde.cref_0.1.0.jar
org.eclipsejcde.jcbp_0.1.0.jar
org.eclipsejcde.jcbp.wizards_0.1.0.jar
org.eclipsejcde.jctools_0.1.0.jar
org.eclipsejcde.jcwde_0.1.0.jar
org.eclipsejcde.preferences_0.1.0.jar
org.eclipsejcde.wizards_0.1.0.jar
in my eclipse/plugins directory.

Plus, I extracted java_card_kit-2_2_2-linux.zip in ~ directory.
When I launch Eclipse, there is nothing about JavaCard Sad can someone tell me what I did wrong ?
Sorry if the question was already asked but I searched on the internet but I did not find any response to solve my problem...

Thank you very much Smile
Re: Unable to install JCDE on Eclipse 3.8 [message #1453774 is a reply to message #1453348] Mon, 27 October 2014 13:12 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
It looks like the JCDE plugin(s) were written for an old version of Eclipse and haven't been updated in a while. Installing plugins by dropping them into your Eclipse file system is a very error-prone way to do it and as you've seen there is no feedback when something doesn't work. It would be better for the JCDE project to supply an update site that you could use from within Eclipse, but I guess they don't. The best you could do would be to open your Error Log in Eclipse and see if you can decipher what is incompatible, or get an old version of Eclipse that the JCDE plugin was designed to work with.
Re: Unable to install JCDE on Eclipse 3.8 [message #1453906 is a reply to message #1453774] Mon, 27 October 2014 17:39 Go to previous messageGo to next message
adomniac alex is currently offline adomniac alexFriend
Messages: 3
Registered: October 2014
Junior Member
Thank you for your response.

I will try to download Eclipse 3.2 which seems compatible with these plugins and I will tell you what is going on after this.
Re: Unable to install JCDE on Eclipse 3.8 [message #1453955 is a reply to message #1453906] Mon, 27 October 2014 19:09 Go to previous message
adomniac alex is currently offline adomniac alexFriend
Messages: 3
Registered: October 2014
Junior Member
So, I installed the 3.5 version and I did the same thing, ie extract eclipse-jcde-0.2.zip into the eclipse/plugins folder and it finally works...
So thank you, you were right these plugins were probably written for an older version than 3.8...
JCDE project should really supply an update site like you said, it will be realy more simple but whatever...

Anyway thank you, you made my day Very Happy
Previous Topic:Is Luna compatible with JavaFX project?
Next Topic:"Error in Services Launch Sequence."
Goto Forum:
  


Current Time: Fri Nov 15 13:29:40 GMT 2019

Powered by FUDForum. Page generated in 0.02947 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top