Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dali » JPA Diagram Editor 1.1.1 and Eclipse Luna 4.4.1(Should it work?)
JPA Diagram Editor 1.1.1 and Eclipse Luna 4.4.1 [message #1445048] Tue, 14 October 2014 23:52 Go to next message
Andrew Sumner is currently offline Andrew SumnerFriend
Messages: 2
Registered: June 2013
Junior Member
I've been trying to get this to work and keep getting exceptions such as the one below. Should JPA Diagram editor work with the latest eclipse?

This is my first attempt at JPA so not sure if I've screwed something up or there's a bug that I've hit.

java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_NZ
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

This is a continuation of log file C:\Work_Java\workspace\.metadata\.bak_0.log
Created Time: 2014-10-15 12:04:36.622

Wed Oct 15 12:23:48 NZDT 2014
Unhandled event loop exception

java.lang.NoClassDefFoundError: org/eclipse/jpt/jpa/ui/JpaRootContextNodeModel
at org.eclipse.jpt.jpadiagrameditor.ui.internal.modelintegration.ui.OpenJpaDiagramActionDelegate.obtainJpaProjectAndPersistenceUnit(
at org.eclipse.ui.internal.PluginAction.runWithEvent(
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(
at org.eclipse.jface.action.ActionContributionItem.access$2(
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(
at org.eclipse.swt.widgets.EventTable.sendEvent(
at org.eclipse.swt.widgets.Display.sendEvent(
at org.eclipse.swt.widgets.Widget.sendEvent(
at org.eclipse.swt.widgets.Display.runDeferredEvents(
at org.eclipse.swt.widgets.Display.readAndDispatch(
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$
at org.eclipse.core.databinding.observable.Realm.runWithDefault(
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(
at org.eclipse.ui.internal.Workbench$
at org.eclipse.core.databinding.observable.Realm.runWithDefault(
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
at org.eclipse.ui.internal.ide.application.IDEApplication.start(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(
at org.eclipse.equinox.launcher.Main.main(

Re: JPA Diagram Editor 1.1.1 and Eclipse Luna 4.4.1 [message #1452112 is a reply to message #1445048] Fri, 24 October 2014 20:28 Go to previous messageGo to next message
Petya Sabeva is currently offline Petya SabevaFriend
Messages: 5
Registered: July 2009
Junior Member
Hi Andrew,

can you describe the exact steps? I've just downloaded the Eclipse Luna SR1, installed the JPA Diagram Editor feature from the available software option, created a JPA project, downloaded and installed the EclipseLink 2.5.2 and tried the both options to open the diagram editor. Everything works as expected - no exceptions occurred. So I can confirm that the JPA Diagram editor works with latest eclipse version, but to be sure I need the exact steps which you performed.

Re: JPA Diagram Editor 1.1.1 and Eclipse Luna 4.4.1 [message #1460136 is a reply to message #1452112] Mon, 03 November 2014 08:25 Go to previous messageGo to next message
Jernej Srebrnič is currently offline Jernej SrebrničFriend
Messages: 1
Registered: November 2014
Junior Member
I had the same problem
upgrade to eclipse 4.4.1 fixed it
Re: JPA Diagram Editor 1.1.1 and Eclipse Luna 4.4.1 [message #1515451 is a reply to message #1460136] Thu, 18 December 2014 04:52 Go to previous messageGo to next message
Hugh Mising nameFriend
Messages: 1
Registered: December 2014
Junior Member
It doesn't work for me on Luna 4.4.1.
I can't even install it because of missing dependency. (Even when i use "contact all update sites during install to find required software")

Cannot complete the install because one or more required items could not be found.
Software being installed: JPA Diagram Editor (Incubation) (
Missing requirement: JPA Diagram Editor (org.eclipse.jpt.ui.diagrameditor requires 'bundle org.eclipse.jpt.ui 0.0.0' but it could not be found
Cannot satisfy dependency:
From: JPA Diagram Editor (Incubation) (
To: org.eclipse.jpt.ui.diagrameditor []
Re: JPA Diagram Editor 1.1.1 and Eclipse Luna 4.4.1 [message #1604184 is a reply to message #1445048] Fri, 06 February 2015 17:45 Go to previous message
Nico Bachmann is currently offline Nico BachmannFriend
Messages: 1
Registered: February 2015
Junior Member
Hi Andrew,

I had the same problem after installing the JPA Diagram Editor via Eclipse Marketplace into Eclipse Kepler.

For some reason Eclipse Marketplace delivers an old feature-version org.eclipse.jpt.jpadiagrameditor.feature_1.1.2.v201301082148-408c9oB58C5FCB77B5. This feature contains the plugin org.eclipse.jpt.jpadiagrameditor.ui_1.0.3.v201301300050 which is binary incompatible to the Kepler plugin org.eclipse.jpt.jpa.ui_3.3.2.v201401172016.jar. That's why the Excpetion is thrown.

I resolved the problem after updating the JPA Diagram Editor Feature to Version 1.2 via the Eclipse Kepler update site.


Previous Topic:Generate Entities from Tables - Skips One Table
Next Topic:one-to-one foreign not primary key association mapping error in dali
Goto Forum:

Current Time: Thu Jul 29 10:34:12 GMT 2021

Powered by FUDForum. Page generated in 0.03332 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top