Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Papyrus installation on Eclipse Luna
Papyrus installation on Eclipse Luna [message #1443838] Mon, 13 October 2014 09:15 Go to next message
Loïc FRETTE is currently offline Loïc FRETTEFriend
Messages: 5
Registered: October 2014
Junior Member
Hi,

I'm trying to install Papyrus on my computer. I have download Eclipe Modeling Tool (on Luna Release SR1).

I click on Install More Modeling Component -> Selection of Papyrus

Error appears about hyperlinks. I try to access to the link (http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna/) directly with internet explorer -> Not found

Do you have any idea how to install Papyrus on my PC ?

Thanks you.

Loïc
Re: Papyrus installation on Eclipse Luna [message #1444003 is a reply to message #1443838] Mon, 13 October 2014 14:22 Go to previous messageGo to next message
Mickael ADAM is currently offline Mickael ADAMFriend
Messages: 31
Registered: February 2014
Member
hi,

http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/luna/ is the update site.

To install papyrus go to Help>Install new software > paste the update site and select Papyrus UML.


Mickaël
Re: Papyrus installation on Eclipse Luna [message #1444012 is a reply to message #1444003] Mon, 13 October 2014 14:31 Go to previous messageGo to next message
Loïc FRETTE is currently offline Loïc FRETTEFriend
Messages: 5
Registered: October 2014
Junior Member
Hi Mickaël,

Thanks for the answer.

I've already try to install a new software with this link. I join a picture of the error.

That's why I can't add Papyrus on my computer. Do you have already see this error ?

Cheers,

Loïc



Re: Papyrus installation on Eclipse Luna [message #1444017 is a reply to message #1443838] Mon, 13 October 2014 14:40 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Hi Loïc,

This link is not a web page; it is an Eclipse update site:

Quote:
Not Found

We're sorry, the page or file cannot be found. Here are some reasons why:

    This is an Eclipse Update site/p2 repository; you must access it from Eclipse (see how).


So, it is expected that you can't access it via a web browser.

The update site is valid and exists.

The solution Mickaël suggested should work, but with Eclipse Modeling you don't even need to use update sites: once Eclipse Modeling is started, just go to Help > Install Modeling Components, then select Papyrus, then finish. That's it!


Regards,
Camille


Camille Letavernier
Re: Papyrus installation on Eclipse Luna [message #1444028 is a reply to message #1444017] Mon, 13 October 2014 14:52 Go to previous messageGo to next message
Loïc FRETTE is currently offline Loïc FRETTEFriend
Messages: 5
Registered: October 2014
Junior Member
Hi Camille,

I understand for the update site, thanks for the explication.

The solution suggested by Mickaël was the first solution I tried. When I try to install Papyrus with "Install Modeling Components" an error appears.

That's why I started to look on update site.

Regards,

Loïc
Re: Papyrus installation on Eclipse Luna [message #1444033 is a reply to message #1444028] Mon, 13 October 2014 14:58 Go to previous messageGo to next message
Mickael ADAM is currently offline Mickael ADAMFriend
Messages: 31
Registered: February 2014
Member
I'me not sure but apparently there is an error on your network. try to configure the proxy.
Re: Papyrus installation on Eclipse Luna [message #1444034 is a reply to message #1444028] Mon, 13 October 2014 15:00 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Hi,

Apparently you need to go through a proxy to get HTTP access, so you need to configure this proxy in Eclipse as well. Not sure how it works exactly, but you should have a look at the Eclipse Preferences, under General > Network Connections

HTH,
Camille


Camille Letavernier
Re: Papyrus installation on Eclipse Luna [message #1444046 is a reply to message #1444034] Mon, 13 October 2014 15:11 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
BTW, if you can't properly configure the proxy in Eclipse, you can download the zipped update site here:

https://www.eclipse.org/papyrus/downloads/ (Choose 1.0.1 under Latest Releases)

then use Help > Install new software > Add... > Archive...

Regards,
Camille


Camille Letavernier
Re: Papyrus installation on Eclipse Luna [message #1444519 is a reply to message #1444046] Tue, 14 October 2014 07:19 Go to previous messageGo to next message
Loïc FRETTE is currently offline Loïc FRETTEFriend
Messages: 5
Registered: October 2014
Junior Member
Hi,

In fact, that was my entreprise network which not allowed the connection.

I did it myself on my own PC and it works.

Thanks for your time, sorry for the inconvenience.

Regards,

Loïc
Re: Papyrus installation on Eclipse Luna [message #1736965 is a reply to message #1444003] Mon, 04 July 2016 17:14 Go to previous messageGo to next message
jagdeep kaur is currently offline jagdeep kaurFriend
Messages: 4
Registered: July 2016
Junior Member
http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/kepler

i found errors when i was trying to install new softwares in eclipse.

  • Attachment: error.jpg
    (Size: 177.34KB, Downloaded 218 times)
Re: Papyrus installation on Eclipse Luna [message #1737230 is a reply to message #1736965] Wed, 06 July 2016 13:40 Go to previous message
Benoit Maggi is currently offline Benoit MaggiFriend
Messages: 129
Registered: March 2013
Location: Bordeaux, France
Senior Member
I can reach the kepler update site without problem.

Are you behind a corporate firewall?
Previous Topic:Can´t run Papyrus in OS X 10.9.5
Next Topic:ClassNotFound when adding a Matcher to an ElementTypesConfiguration
Goto Forum:
  


Current Time: Fri Aug 14 23:51:24 GMT 2020

Powered by FUDForum. Page generated in 0.02378 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top