Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Eclipse Kepler got slow(And every other version as well)
Eclipse Kepler got slow [message #1411213] Fri, 22 August 2014 17:44 Go to next message
Eclipse GuestFriend
Messages: 93
Registered: February 2013
Location: Vienna
Member
Hi all,

I'm currently facing a problem that I've tried of everything and couldn't get it to work. I use Eclipse Kepler SR1 build 20130919-0819 and suddently it wasn't working properly. It got soooo sloooow for doing anything: code completion, switching perspectives, scrolling project files. Debugging got impossible. Took like 20s to go to another line.

I haven't installed anything new to the computer or changed any plugins whatsoever.It just got too damn slow!

I've tried changing every memory configuration, installed the latest 1.7_67 VM, used a different Eclipse without any plugins. Nothing worked anymore, but the computer runs smoothly. I've executed eclipse with -clean, put a brand new workspace. Everything you can imagine, I've done it. In the end I ran Java Mission Control and got it to profile Eclipse for a few minutes but couldn't get any information of it.


I hope you can get some answers because I will format my computer so I can use Eclipse again.

My PC is a i7 with SSD, running on Win 64bits and Java 1.7 32bits.
Re: Eclipse Kepler got slow [message #1411840 is a reply to message #1411213] Sun, 24 August 2014 15:54 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 877
Registered: January 2012
Senior Member

You didn't explicitly say so have you tried rebooting your machine?

Do other Java apps run slowly? (e.g., Java Mission Control)

Does a new download of Eclipse run slowly?

Is there anything in your logs? Also try running with
-console
just in case something's being written to stdout.
Previous Topic:hidePart during shutdown leaves something behind
Next Topic:Window without maximize minimize and close
Goto Forum:
  


Current Time: Mon Mar 08 16:38:05 GMT 2021

Powered by FUDForum. Page generated in 0.02327 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top