Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Ubunut apt-get eclipse-cdt and no c++ projects available(Ubuntu apt-get eclipse-cdt and no c++ projects available)
Ubunut apt-get eclipse-cdt and no c++ projects available [message #1396940] Wed, 09 July 2014 01:39 Go to next message
Andrew Trapani is currently offline Andrew TrapaniFriend
Messages: 1
Registered: January 2014
Junior Member
tl;dr I uninstalled and reinstalled eclipse-cdt using apt-get on "Ubuntu 12.04.4 LTS" 32-bit and C++ projects and perspectives are not available for selection, only Java and Java related.

Earlier this afternoon, most everything was working with my eclipse-cdt environment, except something annoying with the indexer, so I decided to check for updates.

I noted I did not have auto update on and so when I did a "check for updates" inside of eclipse there were a lot. Last time I update was on 4/7/2014.

Some of them didn't work, so I unchecked them and installed the rest containing C++.

Upon restart, nothing worked with C++. I couldn't make a C++ project and there wasn't a C++ perspective.

So after some wrangling, eclipse -clean in a new temporary workspace, trying to "revert" to previous set of plugins, and not getting anywhere, I decided to try uninstalling.

So I searched the net and found some links.
From several links I am not allowed to post due to forum rules, I figured out the following commands.

So the commands I ran:
sudo apt-get remove --purge eclipse
sudo apt-get autoremove
sudo rm -rf /usr/bin/eclipse /usr/lib/eclipse/ /usr/share/eclipse /usr/share/man/man1/eclipse.1.gz /etc/eclipse.ini
rm -rf ~/.eclipse
rm -rf ~/tempEclipseWorkspace

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-4.7 g++-4.7
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.6 60 --slave /usr/bin/g++ g++ /usr/bin/g++-4.6
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.7 40 --slave /usr/bin/g++ g++ /usr/bin/g++-4.7
sudo update-alternatives --config gcc

Make sure it's gcc-4.7:
g++ --version
g++ (Ubuntu/Linaro 4.7.3-2ubuntu1~12.04) 4.7.3

Now try eclipse again:
sudo apt-get install eclipse eclipse-cdt

Now that it's done installing, I run, create a new ~/tempEclipseWorkspace/:
eclipse -clean
Select my tempEclipseWorkspace

And no C++ projects nor perspectives are available. It's just Java, Java related, and CSV.

Please help ;_;
Re: Ubunut apt-get eclipse-cdt and no c++ projects available [message #1397457 is a reply to message #1396940] Wed, 09 July 2014 19:10 Go to previous message
David Wegener is currently offline David WegenerFriend
Messages: 1441
Registered: July 2009
Senior Member
Don't use the Eclipse in the Ubuntu repositories. Download Eclipse directly from and untar the download to a directory on your system.
Previous Topic:Build problems
Next Topic:Question on supplying arguments to the command line executable
Goto Forum:

Current Time: Mon Sep 20 23:08:48 GMT 2021

Powered by FUDForum. Page generated in 0.02034 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top