Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » require-bundle: bundle cannot be resolved
require-bundle: bundle cannot be resolved [message #1386038] Fri, 13 June 2014 07:08 Go to next message
Daniel Ludin is currently offline Daniel LudinFriend
Messages: 1
Registered: June 2014
Junior Member
Hello,

I am trying to install an example project that contains some BIRT examples.
In the MANIFEST.MF there are some dependencies defined:

Require-Bundle: org.eclipse.ui,
org.eclipse.core.runtime,
org.eclipse.birt.chart.engine,
org.eclipse.birt.chart.engine.extension,
org.eclipse.birt.core,
org.eclipse.birt.chart.device.extension,

here I get an error: bundle cannot be resolved (for the BIRT libraries).

My question: how do I make these dependencies available to the project?
Of course, I have the BIRT software installed in eclipse, but shouldn't
the BIRT stuff show up in the view Plug-In Registry afterwards? Is this why they
can't be found? Is there a way to define the referenced stuff manually?

Daniel
Re: require-bundle: bundle cannot be resolved [message #1386197 is a reply to message #1386038] Sat, 14 June 2014 18:29 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 06/13/2014 07:03 AM, Daniel Ludin wrote:
> Hello,
>
> I am trying to install an example project that contains some BIRT examples.
> In the MANIFEST.MF there are some dependencies defined:
>
> Require-Bundle: org.eclipse.ui,
> org.eclipse.core.runtime,
> org.eclipse.birt.chart.engine,
> org.eclipse.birt.chart.engine.extension,
> org.eclipse.birt.core,
> org.eclipse.birt.chart.device.extension,
>
> here I get an error: bundle cannot be resolved (for the BIRT libraries).
>
> My question: how do I make these dependencies available to the project?
> Of course, I have the BIRT software installed in eclipse, but shouldn't
> the BIRT stuff show up in the view Plug-In Registry afterwards? Is this
> why they
> can't be found? Is there a way to define the referenced stuff manually?
>
> Daniel

There's a separate BIRT forum.
Previous Topic:Viewing file properties in PHP Explorer and Navigator
Next Topic:32bit Eclipse, 32bit JRE "Can't load IA 32-bit .dll on a AMD 64-bit platform
Goto Forum:
  


Current Time: Thu Dec 03 16:20:16 GMT 2020

Powered by FUDForum. Page generated in 0.03351 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top