Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Remote Debugger Wrong Line(Debugger stopping in wrong method)
Remote Debugger Wrong Line [message #1299101] Wed, 16 April 2014 18:43 Go to next message
Andy Zaluski is currently offline Andy ZaluskiFriend
Messages: 4
Registered: April 2014
Junior Member
I am attempting to remote debug some Java code. I have added a new method in the class and when the debugger stops on a break point within the new method it appears that it is stopping in the original file(Old code). I have grabbed the latest version of Eclipse:

Version: Kepler Service Release 2
Build id: 20140224-0627

I have created a new workspace and project with no luck. I have cleaned the project both manually and through the tool. Please help????
Re: Remote Debugger Wrong Line [message #1299200 is a reply to message #1299101] Wed, 16 April 2014 20:13 Go to previous messageGo to next message
Andy Zaluski is currently offline Andy ZaluskiFriend
Messages: 4
Registered: April 2014
Junior Member
I have always debugged locally. The only thing that makes sense is that I will need to deploy any new code to the server. Is this correct? It defeats the purpose of using the debugger for me in this instance.
Re: Remote Debugger Wrong Line [message #1299211 is a reply to message #1299200] Wed, 16 April 2014 20:20 Go to previous messageGo to next message
David Wegener is currently offline David WegenerFriend
Messages: 1445
Registered: July 2009
Senior Member
The code that you are debugging has to be deployed to the remote system where the VM is running. The debugger doesn't run code, it interacts with the VM that is actually running the code. If the code isn't available to the remote VM, it has no way to execute it and you can't debug it.
Re: Remote Debugger Wrong Line [message #1300288 is a reply to message #1299101] Thu, 17 April 2014 13:19 Go to previous messageGo to next message
Andy Zaluski is currently offline Andy ZaluskiFriend
Messages: 4
Registered: April 2014
Junior Member
Thank you David for the response. I knew it had to be a simple answer. I was hoping there would be some type of code injection when debugging but it looks like it back to coding in a text editor Smile

Re: Remote Debugger Wrong Line [message #1300330 is a reply to message #1300288] Thu, 17 April 2014 13:54 Go to previous messageGo to next message
David Wegener is currently offline David WegenerFriend
Messages: 1445
Registered: July 2009
Senior Member
I'm not sure why this limits you to coding in a text editor. In either case, the code needs to be made accessible to the VM that actually runs the code. Getting the code to the remote system shouldn't be a major issue especially if you use the Remote System tools provided by the Eclipse Target Management project.
Re: Remote Debugger Wrong Line [message #1300344 is a reply to message #1300330] Thu, 17 April 2014 14:05 Go to previous message
Andy Zaluski is currently offline Andy ZaluskiFriend
Messages: 4
Registered: April 2014
Junior Member
Sorry, I was just joking. Bad humor. I actually love Eclipse. I worked for IBM for a decade and it was the main Java development tool used at the time. I'm not sure what they use now...

I will do some research on the tools or functionality you mentioned. Thx again for the help.

Andy
Previous Topic:Build path vs. compile libraries vs. deployment libraries please help clarify
Next Topic:Trying to run Open JML in Eclipse
Goto Forum:
  


Current Time: Thu Jun 20 03:50:49 GMT 2024

Powered by FUDForum. Page generated in 0.04105 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top