Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Eclipse forgets compiler compliance level
Eclipse forgets compiler compliance level [message #1281176] Mon, 31 March 2014 13:21 Go to next message
Steve Glasgow is currently offline Steve GlasgowFriend
Messages: 10
Registered: January 2014
Junior Member
When initially setting up Eclipse, I set the Compiler compliance level to 1.6 in Window - Preferences - Java - Compiler.

For each project I create, I do NOT enable project specific settings in Project - Properties - Java Compiler. It shows up as 1.6.

Periodically, about twice a week, my WORKING project shows hundreds of errors. Errors that were not there before.

To correct the situation, I go into Project - Properties - Java Compiler, enable project specific settings, change the compliance level to 1.4, click apply, and click yes to the message about rebuilding the project. This, obviously, results in lots of errors.

I then change the level to 1.5, click apply, and click yes to the message about rebuilding the project. This results in significantly fewer errors.

Finally, I change the level to 1.6, apply, and rebuild. This results on NO errors, and everything is good again.

What have I missed? Why is Eclipse doing this to me?

Thank you in advance.
Steve
Re: Eclipse forgets compiler compliance level [message #1281598 is a reply to message #1281176] Tue, 01 April 2014 04:36 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 33163
Registered: July 2009
Senior Member
Steve,

I've never seen that. When this happens, what are the global setting
JDT Compiler preferences set to and what's in the .classpath file of
each project? It sounds as if the global preference is changing, though
I know of nothing that would do that automatically. It's generally
better, in my opinion, for each project to specify locally (project
specifically, in its .classpath file) what Java compliance it should have...

On 31/03/2014 3:21 PM, Steve Glasgow wrote:
> When initially setting up Eclipse, I set the Compiler compliance level
> to 1.6 in Window - Preferences - Java - Compiler.
>
> For each project I create, I do NOT enable project specific settings
> in Project - Properties - Java Compiler. It shows up as 1.6.
>
> Periodically, about twice a week, my WORKING project shows hundreds of
> errors. Errors that were not there before.
>
> To correct the situation, I go into Project - Properties - Java
> Compiler, enable project specific settings, change the compliance
> level to 1.4, click apply, and click yes to the message about
> rebuilding the project. This, obviously, results in lots of errors.
>
> I then change the level to 1.5, click apply, and click yes to the
> message about rebuilding the project. This results in significantly
> fewer errors.
>
> Finally, I change the level to 1.6, apply, and rebuild. This results
> on NO errors, and everything is good again.
>
> What have I missed? Why is Eclipse doing this to me?
>
> Thank you in advance.
> Steve
>


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Eclipse JDT Core 3.4
Next Topic:KeyStore doesn't load new stores
Goto Forum:
  


Current Time: Thu Jun 20 00:50:19 GMT 2024

Powered by FUDForum. Page generated in 0.02491 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top