Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Connection Creation problems via ModelingAssistantProvider
Connection Creation problems via ModelingAssistantProvider [message #210339] Tue, 04 November 2008 16:01
Thomas Beyer is currently offline Thomas BeyerFriend
Messages: 47
Registered: July 2009
Member
This is a multi-part message in MIME format.

------=_NextPart_000_0020_01C93E9E.FD7AAD00
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Dear community,

I ran into some issues while using the Connection Creation Assistant =
(ModelingAssistantProvider).

Debugging the runtime-code, I found, that =
CreateViewAndOptionallyElementCommand fails to find the EditPart to =
connect to in deep structures.
I attached a patch.

Please vote for:https://bugs.eclipse.org/bugs/show_bug.cgi?id=3D253721


Regards=20
Thomas
------=_NextPart_000_0020_01C93E9E.FD7AAD00
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<META content=3D"MSHTML 6.00.2900.2180" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>Dear community,</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>I ran into some issues while using the =
Connection=20
Creation Assistant (ModelingAssistantProvider).</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Debugging the runtime-code, I found, =
that=20
CreateViewAndOptionallyElementCommand fails to find the EditPart to =
connect to=20
in deep structures.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>I attached a patch.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Please vote=20
for:https://bugs.eclipse.org/bugs/show_bug.cgi?id=3D253721</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Regards </FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Thomas</FONT></DIV></BODY></HTML>

------=_NextPart_000_0020_01C93E9E.FD7AAD00--
Previous Topic:(Can't find in newsgroup) LinkMapping Additional Containment Feature
Next Topic:accessing domainmodel objects during command execution
Goto Forum:
  


Current Time: Sun Feb 28 00:25:29 GMT 2021

Powered by FUDForum. Page generated in 0.02805 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top