Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » HandledMenuItem / HandledToolItem from fragment always disabled
HandledMenuItem / HandledToolItem from fragment always disabled [message #1258757] Thu, 27 February 2014 18:28 Go to next message
Tamar Cohen is currently offline Tamar CohenFriend
Messages: 103
Registered: July 2009
Senior Member
I have a fragment.e4xmi that defines some commands and handlers and a part with a toolbar / HandledToolItem, and then also a popup menu with a HandledMenuItem. When I create DirectMenuItem / DirectToolItem, they are properly enabled, but my HandledMenuItem / HandledToolItem start out enabled briefly and then become disabled. They have no parameters and they have no Visible-When expression. My Application has the HandlerProcessingAddon, and in fact I've tried including that in the fragment as well.

Suggestions? I can't find any documentation explaining what I did wrong, as I followed documentation / examples.

thanks much

Tamar Cohen
Intelligent Robotics Group
NASA Ames Research Center
Re: HandledMenuItem / HandledToolItem from fragment always disabled [message #1263969 is a reply to message #1258757] Tue, 04 March 2014 23:04 Go to previous messageGo to next message
Tamar Cohen is currently offline Tamar CohenFriend
Messages: 103
Registered: July 2009
Senior Member
Has anyone else seen this issue with HandledMenuItem or HandledToolItem being disabled when provided from a fragment? I don't want to hardcode DirectMenuItems ...
thanks
Tamar
Re: HandledMenuItem / HandledToolItem from fragment always disabled [message #1264493 is a reply to message #1263969] Wed, 05 March 2014 09:07 Go to previous messageGo to next message
Sopot Cela is currently offline Sopot CelaFriend
Messages: 597
Registered: December 2010
Senior Member

Your fragment looks good. The fact that it starts enabled and disables means that it's probably the @CanExecute evaluation of the handler? What does the @CanExecute of the handler look like?
Re: HandledMenuItem / HandledToolItem from fragment always disabled [message #1366450 is a reply to message #1258757] Mon, 19 May 2014 10:12 Go to previous messageGo to next message
Pieter Voet is currently offline Pieter VoetFriend
Messages: 1
Registered: May 2014
Junior Member
Hi Tamar,

I just can confirm that I'm facing the same issue here...
My Application.e4xmi also already contains the 'HandlerProcessingAddon' addon
and my 'HandledMenuItem' entries from my fragment do show up disabled in the menu..

I'll just keep on searching for a solution, and once I find something, I'll
post it here ofcourse.
Hopefully someone else can shine some light on this.

Have a nice day !

pieter.
Re: HandledMenuItem / HandledToolItem from fragment always disabled [message #1463642 is a reply to message #1264493] Thu, 06 November 2014 19:44 Go to previous message
DW Wheeler is currently offline DW WheelerFriend
Messages: 1
Registered: November 2014
Junior Member
Hi,

I have the same problem as the original poster, but my HandledToolItem is always disabled. It is disabled when I don't have a @CanExecute function as well as when I have a @CanExecute function that always returns true. My Application also has the HandlerProcessingAddon. Suggestions?

Thanks,
DW
Previous Topic:EditorPart failed with E4
Next Topic:Handlers for default eclipse commands with the compatibility layer
Goto Forum:
  


Current Time: Sat Feb 27 23:13:51 GMT 2021

Powered by FUDForum. Page generated in 0.02426 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top