Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » ECP 1.2 feedback(ECP 1.2 feedback)
ECP 1.2 feedback [message #1239604] Tue, 04 February 2014 15:21 Go to next message
Neil Mackenzie is currently offline Neil MackenzieFriend
Messages: 129
Registered: December 2013
Senior Member
I have had a couple of issues getting started with ECP 1.2. I mention them here in case others have the same issue.

1) I loaded the software into a fresh install of the IDE (eclipse kepler modelling edition) via the 1.2 update site. since then I get errors in the IDE of conflicting handlers, plus I cant open new perspectives. I have got round this by downloading the ECP code from git, and only using the supplied target platforms(which is better for me as a developer)

2.) I couldn't log in to EMF store (I have raised this as a seperate topic)

3.) I am not sure if the git branch called 1.2 release is a release or RC1, or neither.

4.) I cannot import a child element from XMI on the RAP version, I have a simple fix for this which may or may not be the best way around the problem. I have raised a bug report for this on bugzilla, however I am not sure if that is the correct thing to do if this is not a full or RC release (I couldnt choose version 1.2. so I set the version as other)

5.) I am not sure if I should be using the e4 product or e3 application. There is only a preconfigured launch/run configuration for e3 RCP.

Regards,
Neil
Re: ECP 1.2 feedback [message #1239926 is a reply to message #1239604] Wed, 05 February 2014 10:33 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

thank you for the feedback, comments below...

Am 04.02.2014 16:21, schrieb Neil Mackenzie:
> I have had a couple of issues getting started with ECP 1.2. I mention
> them here in case others have the same issue.
>
> 1) I loaded the software into a fresh install of the IDE (eclipse kepler
> modelling edition) via the 1.2 update site. since then I get errors in
> the IDE of conflicting handlers, plus I cant open new perspectives. I
> have got round this by downloading the ECP code from git, and only using
> the supplied target platforms(which is better for me as a developer)

Could you paste the conflicting handlers, please?
What does "cannot open new perspective" exactly mean? You cannot open
any perspective? Is there any error?

> 2.) I couldn't log in to EMF store (I have raised this as a seperate topic)
>
I have answered in the other post.

> 3.) I am not sure if the git branch called 1.2 release is a release or
> RC1, or neither.

The 1.2 branch is the source of all RCs and finally the release 1.2,
therefore, there is not dedicated RC branch.

> 4.) I cannot import a child element from XMI on the RAP version, I have
> a simple fix for this which may or may not be the best way around the
> problem. I have raised a bug report for this on bugzilla, however I am
> not sure if that is the correct thing to do if this is not a full or RC
> release (I couldnt choose version 1.2. so I set the version as other)
See BR
>
> 5.) I am not sure if I should be using the e4 product or e3 application.
> There is only a preconfigured launch/run configuration for e3 RCP.
Depends on if you want to build a e3 or an e4 application..


Best regards

Jonas

>
> Regards,
> Neil
Re: ECP 1.2 feedback [message #1240499 is a reply to message #1239926] Thu, 06 February 2014 15:58 Go to previous messageGo to next message
Neil Mackenzie is currently offline Neil MackenzieFriend
Messages: 129
Registered: December 2013
Senior Member
Regarding the conflicting handlers, here is how I produced the error, plus I have attached the workspace error log, and some screenshots of the errors.

THE PROBLEM:

getting multiple confilicting handler errors in error log tab such as @Conflicting handlers for org.eclipse.ui.file.closeAll: {org.eclipse.ui.internal.CloseAllHandler} vs {org.eclipse.ui.internal.CloseAllHandler@33b06b78}@
AND
previously this seemed to be causing problems in the IDE such as "Windows->OpenPerspective->Other" not showing a popup window, or file exit not closing down eclipse however I could not reproduce this.

HOW I REPRODUCED THE PROBLEM:
I downloaded eclipse from eclipse the latest modelling edition for windows 7 64 bit(eclipse-modeling-kepler-SR1-win32-x86_64),unzipped it, change the eclipse.ini to use my java 7 (added -vm C:/Java/jdk1.7.0_11/bin/javaw.exe ), started eclipse, opened the error log (windows-> show view-> error log) as it might be difficult to open later. then followed the instructions of the ecp website as folows:

Please copy this URL:
http://download.eclipse.org/ecp/releases/releases_12
Navigate to Help → Install New Software
Paste the copied URL into the text field label with "Work with" and press enter
Select all features and press next
Accept the license agreement and finish the installation

The install works ok.
Then I restarted eclipse, and I see a lot of errors in the errror log window.
I have attached the log file where they are stored , and a screenshot of the error log tab, and the result of double clicking on one error.

I notice that I can actually choose windows->openperspective-> other, and choose ECP.
However I still seem to get No response from clicking or right clicking on the localEMFStore icon (I have attached a screenshot). I am pretty sure I have emfstore running (I have run it org.eclipse.emf.emfstore.server.application from the run configurations). I have tried adding new links to an emfstore by clicking the green plus icon and setting these to point to localhost and port 8080, but i still have no response from right clicking on these icons.
I have tried running org.eclipse.emf.ecp.application.e3.application, org.eclipse.emf.ecp.application.e3.product, org.eclipse.emf.ecp.application.e4.product from the run configurations tab, but these never start up succefully for me.

Is there any common reason why right clicking on localemfstore would give no response? Does this suggest it cannot talk to my emfstore server?

Thanks,
Neil

Re: ECP 1.2 feedback [message #1240956 is a reply to message #1240499] Fri, 07 February 2014 09:14 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

Thank you for the reports!
we will need to look into this. I have created:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=427631
https://bugs.eclipse.org/bugs/show_bug.cgi?id=427632

Is your final goal to use ECP from within the IDE or create an
application based on it? Can you tell me, why
org.eclipse.emf.ecp.application.e3.application does not work for you?
Have you followed:
http://eclipsesource.com/blogs/tutorials/getting-started-with-the-emf-client-platform/#custommodel

Regards

Jonas

Am 06.02.2014 16:58, schrieb Neil Mackenzie:
> Regarding the conflicting handlers, here is how I produced the error, plus I have attached the workspace error log, and some screenshots of the errors.
>
> THE PROBLEM:
>
> getting multiple confilicting handler errors in error log tab such as @Conflicting handlers for org.eclipse.ui.file.closeAll: {org.eclipse.ui.internal.CloseAllHandler} vs {mailto:org.eclipse.ui.internal.CloseAllHandler@33b06b78}@
> AND
> previously this seemed to be causing problems in the IDE such as "Windows->OpenPerspective->Other" not showing a popup window, or file exit not closing down eclipse however I could not reproduce this.
>
> HOW I REPRODUCED THE PROBLEM:
> I downloaded eclipse from eclipse the latest modelling edition for windows 7 64 bit(eclipse-modeling-kepler-SR1-win32-x86_64),unzipped it, change the eclipse.ini to use my java 7 (added -vm C:/Java/jdk1.7.0_11/bin/javaw.exe ), started eclipse, opened the error log (windows-> show view-> error log) as it might be difficult to open later. then followed the instructions of the ecp website as folows:
>
> Please copy this URL:
> http://download.eclipse.org/ecp/releases/releases_12
> Navigate to Help → Install New Software
> Paste the copied URL into the text field label with "Work with" and press enter
> Select all features and press next
> Accept the license agreement and finish the installation
>
> The install works ok.
> Then I restarted eclipse, and I see a lot of errors in the errror log window.
> I have attached the log file where they are stored , and a screenshot of the error log tab, and the result of double clicking on one error.
>
> I notice that I can actually choose windows->openperspective-> other, and choose ECP.
> However I still seem to get No response from clicking or right clicking on the localEMFStore icon (I have attached a screenshot). I am pretty sure I have emfstore running (I have run it org.eclipse.emf.emfstore.server.application from the run configurations). I have tried adding new links to an emfstore by clicking the green plus icon and setting these to point to localhost and port 8080, but i still have no response from right clicking on these icons.
> I have tried running org.eclipse.emf.ecp.application.e3.application, org.eclipse.emf.ecp.application.e3.product, org.eclipse.emf.ecp.application.e4.product from the run configurations tab, but these never start up succefully for me.
>
> Is there any common reason why right clicking on localemfstore would give no response? Does this suggest it cannot talk to my emfstore server?
>
> Thanks,
> Neil
>
>
Re: ECP 1.2 feedback [message #1241040 is a reply to message #1240956] Fri, 07 February 2014 11:41 Go to previous messageGo to next message
Neil Mackenzie is currently offline Neil MackenzieFriend
Messages: 129
Registered: December 2013
Senior Member
Thanks,
I dont really need it to run from the IDE. My final goal is to run the demo client including EMFStore from RAP. I am developing a solution using the RCP version of ECP demo client for now until I can use the demo client in RAP. I am an experienced java developer but new to RCP/RAP developement. I would be happy to help in getting RAP working fully with EMFStore, even if I can only help with testing as I learn RAP/RCP programming model.

I have the org.eclipse.emf.ecp.application.e3.application working now. previously I installed all all the components from http://download.eclipse.org/ecp/releases/releases_12 int the IDE as suggested in http://eclipse.org/ecp/download.html where it says "select all features" (I previously chose "select all" when provided with a list of components under http://download.eclipse.org/ecp/releases/releases_12) . This time I only installed the SDK as suggested in http://eclipsesource.com/blogs/tutorials/getting-started-with-the-emf-client-platform/ and now things work fine in the eclipse IDE perspective (and I no longer get the conflicting handlers message). I do see a strange thing when I start org.eclipse.emf.ecp.application.e3.application, things work fine but I see 2 model explorers and 2 repository explorerers (I have attached a screenshot) I will check myself if this is only from my environement, I dont know if its a bug yet.
  • Attachment: doubleecp.PNG
    (Size: 88.97KB, Downloaded 133 times)
Re: ECP 1.2 feedback [message #1241070 is a reply to message #1241040] Fri, 07 February 2014 12:42 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

you are right, you actually found the reason for the issues.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=427631
We will explcitily mark the RAP features to not be installed into the
IDE and also make the description on the download page more clear.
About the other issue: Could you clear the workspace of the demo
application once (Run Configuration => first tab => clear workspace).
The data of the running application will be lost, but the state is clean
then again.
Please let me know, if this helps.

Regards

Jonas

Am 07.02.2014 12:41, schrieb Neil Mackenzie:
> Thanks,
> I dont really need it to run from the IDE. My final goal is to run the demo client including EMFStore from RAP. I am developing a solution using the RCP version of ECP demo client for now until I can use the demo client in RAP. I am an experienced java developer but new to RCP/RAP developement. I would be happy to help in getting RAP working fully with EMFStore, even if I can only help with testing as I learn RAP/RCP programming model.
>
> I have the org.eclipse.emf.ecp.application.e3.application working now. previously I installed all all the components from http://download.eclipse.org/ecp/releases/releases_12 int the IDE as suggested in http://eclipse.org/ecp/download.html where it says "select all features" (I previously chose "select all" when provided with a list of components under http://download.eclipse.org/ecp/releases/releases_12) . This time I only installed the SDK as suggested in http://eclipsesource.com/blogs/tutorials/getting-started-with-the-emf-client-platform/ and now things work fine in the eclipse IDE perspective (and I no longer get the conflicting handlers message). I do see a strange thing when I start org.eclipse.emf.ecp.application.e3.application, things work fine but I see 2 model explorers and 2 repository explorerers (I have attached a screenshot) I will check myself if this is only from my environement, I dont know if its a bug yet.
>
Re: ECP 1.2 feedback [message #1241078 is a reply to message #1241070] Fri, 07 February 2014 12:57 Go to previous message
Neil Mackenzie is currently offline Neil MackenzieFriend
Messages: 129
Registered: December 2013
Senior Member
Thanks Jonas,
clearing the workspace fixes that problem.
Regards,
Neil
Previous Topic:[Edapt] DiagnosticException on an example migration
Next Topic:scope of ECP demo application with RAP/EMFStore
Goto Forum:
  


Current Time: Thu Apr 22 15:22:19 GMT 2021

Powered by FUDForum. Page generated in 0.01904 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top