Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » antlr error with the workflow file
antlr error with the workflow file [message #1237269] Wed, 29 January 2014 09:19 Go to next message
Mehmet Ali Meram is currently offline Mehmet Ali MeramFriend
Messages: 5
Registered: July 2010
Junior Member
Hi there,

i have recently installed the following eclipse:

DSL tools Eclipse DSL Tools

Version: Kepler Service Release 1
Build id: 20130919-0819

And i want to use my existing code using the generated code based on Xtext 1.0. But if i want to generate the code with new new Xtext Framework it yields this strange error:

[main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering platform uri 'H:\Tools\Java_tooling\cdsi_gen'
2765 [main] ERROR eclipse.emf.mwe.core.WorkflowEngine - [ERROR]:

ATTENTION!
The Antlr generator fragment couldn't be found on the classpath.
It is highly recommended to install the feature 'Xtext Antlr SDK' using the external updatesite:

.....

(see http://www.eclipse.org/Xtext/download.html for details).

(Element: -UNKNOWN-; Reported by: -UNKNOWN-)
2765 [main] ERROR eclipse.emf.mwe.core.WorkflowEngine - Workflow interrupted because of configuration errors


The workflow file i use is enclosed in this thread. Do you know how to eliminate this error?


Re: antlr error with the workflow file [message #1237282 is a reply to message #1237269] Wed, 29 January 2014 09:44 Go to previous messageGo to next message
Uli Merkel is currently offline Uli MerkelFriend
Messages: 248
Registered: June 2013
Senior Member
In your project directory, you will find something like: .antlr-generator-3.2.0.jar

Delete this file and rerun the MWE on your XTEXT file.
Then you will be prompted to reply "y" to download the antlr.

At least this worked for me

Re: antlr error with the workflow file [message #1237290 is a reply to message #1237282] Wed, 29 January 2014 10:08 Go to previous messageGo to next message
Mehmet Ali Meram is currently offline Mehmet Ali MeramFriend
Messages: 5
Registered: July 2010
Junior Member

Thanks, i tried it but it didn't work. And the package de.itemis.xtext.antlr is dependent on this antlr version. If i remove this jar then the manifest cannot find the dependency. Du you have the same eclipse version as i posted?

Regards

[Updated on: Wed, 29 January 2014 10:08]

Report message to a moderator

Re: antlr error with the workflow file [message #1237305 is a reply to message #1237290] Wed, 29 January 2014 10:50 Go to previous messageGo to next message
Uli Merkel is currently offline Uli MerkelFriend
Messages: 248
Registered: June 2013
Senior Member
I use Kepler, but if you run on XTEXT 1.0, perhaps you have to MIGRATE to xtext2 (see xtext documentation Chapter 13).

Or your XTEXT 1.0 is just looking for an older ANTLR fragment which is not part of the current delivery.
Whats about the site referenced in your "It is highly recommended to install the feature 'Xtext Antlr SDK' using the external updatesite:"
Re: antlr error with the workflow file [message #1237358 is a reply to message #1237305] Wed, 29 January 2014 13:53 Go to previous message
Mehmet Ali Meram is currently offline Mehmet Ali MeramFriend
Messages: 5
Registered: July 2010
Junior Member
I already migrated to Xtext 2.0. But the reason was this fragment in the workflow file:
<fragment class="org.eclipse.xtext.generator.AntlrDelegatingFragment" />

After i replaced it with this line, it worked:

<fragment class="org.eclipse.xtext.generator.parser.antlr.XtextAntlrGeneratorFragment" />

Previous Topic:ERROR org.eclipse.xtext.builder.impl.XtextBuilder - java.lang.ClassCastException: org.eclipse.xtext
Next Topic:grammar for ecore metamodel
Goto Forum:
  


Current Time: Thu Aug 13 07:04:05 GMT 2020

Powered by FUDForum. Page generated in 0.02246 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top