Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Insert space for tabs not working on C/C++ files in Eclipse CDT("insert/use space for tabs")
Insert space for tabs not working on C/C++ files in Eclipse CDT [message #1221957] Wed, 18 December 2013 20:53 Go to next message
i m is currently offline i mFriend
Messages: 3
Registered: December 2013
Junior Member
I have not been able to "insert/use space for tabs" feature work on Juno SR 2 on C/C++ files using the native editors. The feature works on text files. The platform is Ubuntu 12.04.
Re: Insert space for tabs not working on C/C++ files in Eclipse CDT [message #1222038 is a reply to message #1221957] Thu, 19 December 2013 04:54 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 12/18/2013 08:06 PM, i m wrote:
> I have not been able to "insert/use space for tabs" feature work on Juno
> SR 2 on C/C++ files using the native editors. The feature works on text
> files. The platform is Ubuntu 12.04.

You might ask in the Eclipse CDT forum. The equivalent feature in Java
actually involves a Java-specific setting for the Java editor. I'm
guessing that would be true reciprocally for C/C++.
Re: Insert space for tabs not working on C/C++ files in Eclipse CDT [message #1696002 is a reply to message #1221957] Thu, 21 May 2015 06:14 Go to previous message
Matthias Szusdziara is currently offline Matthias SzusdziaraFriend
Messages: 1
Registered: May 2015
Junior Member
Hit the same problem with TIs' Code Composer Studio (6.1) which is based on Eclipse.

For others hitting that thread in search for the solution to the problem (like me), i'll post it even if the thread is... well, old. Wink

After some poking around i ended up performing the following steps to get the desired result:
- Go to Window -> Preferences
- In tree select C/C++ -> Code Style -> Formatter
- Click 'Edit' button
- Tab 'Identation': Set 'Tab policy' to 'Spaces only'
- Click 'Apply'/'Ok'

HTH,
Matthias
Previous Topic:Hide (not just collapse) comments?
Next Topic:Sudden startup problem
Goto Forum:
  


Current Time: Tue Dec 10 23:41:45 GMT 2019

Powered by FUDForum. Page generated in 0.02508 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top